summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-14 07:55:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-14 07:55:24 +0000
commit5ad9b54b1aa2086bc55861927b6642fa88fd702d (patch)
tree5ba3e58c53fa8da5d33069263390c1fa131c5c54 /media-libs
parentFix dependencies. (diff)
downloadgentoo-2-5ad9b54b1aa2086bc55861927b6642fa88fd702d.tar.gz
gentoo-2-5ad9b54b1aa2086bc55861927b6642fa88fd702d.tar.bz2
gentoo-2-5ad9b54b1aa2086bc55861927b6642fa88fd702d.zip
make tslib USE controlled instead of automagic
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl/ChangeLog6
-rw-r--r--media-libs/libsdl/libsdl-1.2.13-r1.ebuild6
-rw-r--r--media-libs/libsdl/libsdl-1.2.14.ebuild6
-rw-r--r--media-libs/libsdl/metadata.xml1
4 files changed, 14 insertions, 5 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index f82c3e9a105c..7600374f16a9 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libsdl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.165 2009/11/11 13:10:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.166 2009/11/14 07:55:24 mr_bones_ Exp $
+
+ 14 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ libsdl-1.2.13-r1.ebuild, libsdl-1.2.14.ebuild, metadata.xml:
+ make tslib USE controlled instead of automagic
11 Nov 2009; Samuli Suominen <ssuominen@gentoo.org>
libsdl-1.2.13-r1.ebuild:
diff --git a/media-libs/libsdl/libsdl-1.2.13-r1.ebuild b/media-libs/libsdl/libsdl-1.2.13-r1.ebuild
index 363bdb46eb35..b38db06a9199 100644
--- a/media-libs/libsdl/libsdl-1.2.13-r1.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.13-r1.ebuild,v 1.13 2009/11/11 13:10:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.13-r1.ebuild,v 1.14 2009/11/14 07:55:24 mr_bones_ Exp $
EAPI=2
inherit flag-o-matic toolchain-funcs eutils libtool
@@ -16,7 +16,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
# if you disable the audio, video, joystick use flags or turn on the custom-cflags use flag
# in USE and something breaks, you pick up the pieces. Be prepared for
# bug reports to be marked INVALID.
-IUSE="oss alsa esd nas X dga xv xinerama fbcon directfb ggi svga aalib opengl libcaca +audio +video +joystick custom-cflags pulseaudio"
+IUSE="oss alsa esd nas X dga xv xinerama fbcon directfb ggi svga tslib aalib opengl libcaca +audio +video +joystick custom-cflags pulseaudio"
RDEPEND="audio? ( >=media-libs/audiofile-0.1.9 )
alsa? ( media-libs/alsa-lib )
@@ -39,6 +39,7 @@ RDEPEND="audio? ( >=media-libs/audiofile-0.1.9 )
aalib? ( media-libs/aalib )
libcaca? ( >=media-libs/libcaca-0.9-r1 )
opengl? ( virtual/opengl virtual/glu )
+ tslib? ( x11-libs/tslib )
pulseaudio? ( media-sound/pulseaudio )"
DEPEND="${RDEPEND}
nas? (
@@ -135,6 +136,7 @@ src_configure() {
$(use_enable aalib video-aalib) \
$(use_enable libcaca video-caca) \
$(use_enable opengl video-opengl) \
+ $(use_enable tslib input-tslib) \
$(use_with X x) \
--disable-video-x11-xme \
${myconf}
diff --git a/media-libs/libsdl/libsdl-1.2.14.ebuild b/media-libs/libsdl/libsdl-1.2.14.ebuild
index 37fdc09e975e..9862b802ce37 100644
--- a/media-libs/libsdl/libsdl-1.2.14.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.14.ebuild,v 1.4 2009/11/06 16:25:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.14.ebuild,v 1.5 2009/11/14 07:55:24 mr_bones_ Exp $
EAPI=2
inherit flag-o-matic toolchain-funcs eutils libtool
@@ -16,7 +16,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-
# if you disable the audio, video, joystick use flags or turn on the custom-cflags use flag
# in USE and something breaks, you pick up the pieces. Be prepared for
# bug reports to be marked INVALID.
-IUSE="oss alsa nas X dga xv xinerama fbcon directfb ggi svga aalib opengl libcaca +audio +video +joystick custom-cflags pulseaudio ps3"
+IUSE="oss alsa nas X dga xv xinerama fbcon directfb ggi svga tslib aalib opengl libcaca +audio +video +joystick custom-cflags pulseaudio ps3"
RDEPEND="audio? ( >=media-libs/audiofile-0.1.9 )
alsa? ( media-libs/alsa-lib )
@@ -39,6 +39,7 @@ RDEPEND="audio? ( >=media-libs/audiofile-0.1.9 )
libcaca? ( >=media-libs/libcaca-0.9-r1 )
opengl? ( virtual/opengl virtual/glu )
ppc64? ( ps3? ( sys-libs/libspe2 ) )
+ tslib? ( x11-libs/tslib )
pulseaudio? ( media-sound/pulseaudio )"
DEPEND="${RDEPEND}
nas? (
@@ -129,6 +130,7 @@ src_configure() {
$(use_enable libcaca video-caca) \
$(use_enable opengl video-opengl) \
$(use_enable ps3 video-ps3) \
+ $(use_enable tslib input-tslib) \
$(use_with X x) \
--disable-video-x11-xme \
${myconf}
diff --git a/media-libs/libsdl/metadata.xml b/media-libs/libsdl/metadata.xml
index 3014b013c62f..0ee2113934ce 100644
--- a/media-libs/libsdl/metadata.xml
+++ b/media-libs/libsdl/metadata.xml
@@ -22,6 +22,7 @@ PHP, Pike, Python, and Ruby.
<flag name="audio">Control audio support (disable at your own risk)</flag>
<flag name="joystick">Control joystick support (disable at your own risk)</flag>
<flag name="ps3">Build the PS3 video driver</flag>
+ <flag name="tslib">Build with tslib support for touchscreen devices</flag>
<flag name="video">Control video support (disable at your own risk)</flag>
</use>
</pkgmetadata>