summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-11-30 12:43:56 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-11-30 12:43:56 +0000
commit4f1c0de6df725c7c73223af29a5e9c84cced433b (patch)
treeaf4899c210cd3e013518b53d724be0f7bc7bdafd /media-libs
parentamd64/x86 stable, bug #294991 (diff)
downloadgentoo-2-4f1c0de6df725c7c73223af29a5e9c84cced433b.tar.gz
gentoo-2-4f1c0de6df725c7c73223af29a5e9c84cced433b.tar.bz2
gentoo-2-4f1c0de6df725c7c73223af29a5e9c84cced433b.zip
Version bump. Per bug #295163. Thx to bug reporter for the patches.
(Portage version: 2.2_rc53/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/freeglut/ChangeLog10
-rw-r--r--media-libs/freeglut/files/2.6.0-GFX_radeon.patch28
-rw-r--r--media-libs/freeglut/files/freeglut-2.6.0_rc1-bsd_joystick.patch13
-rw-r--r--media-libs/freeglut/freeglut-2.6.0.ebuild (renamed from media-libs/freeglut/freeglut-2.6.0_rc1.ebuild)22
-rw-r--r--media-libs/freeglut/metadata.xml14
5 files changed, 63 insertions, 24 deletions
diff --git a/media-libs/freeglut/ChangeLog b/media-libs/freeglut/ChangeLog
index 9f2144f127fe..1b82863af6c2 100644
--- a/media-libs/freeglut/ChangeLog
+++ b/media-libs/freeglut/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/freeglut
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/freeglut/ChangeLog,v 1.62 2009/10/11 19:36:01 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/freeglut/ChangeLog,v 1.63 2009/11/30 12:43:55 scarabeus Exp $
+
+*freeglut-2.6.0 (30 Nov 2009)
+
+ 30 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/2.6.0-GFX_radeon.patch, -freeglut-2.6.0_rc1.ebuild,
+ +freeglut-2.6.0.ebuild, -files/freeglut-2.6.0_rc1-bsd_joystick.patch,
+ metadata.xml:
+ Version bump. Per bug #295163. Thx to bug reporter for the patches.
11 Oct 2009; nixnut <nixnut@gentoo.org> freeglut-2.6.0_rc1.ebuild:
revert to ~ppc #287229
diff --git a/media-libs/freeglut/files/2.6.0-GFX_radeon.patch b/media-libs/freeglut/files/2.6.0-GFX_radeon.patch
new file mode 100644
index 000000000000..8806fe849cb5
--- /dev/null
+++ b/media-libs/freeglut/files/2.6.0-GFX_radeon.patch
@@ -0,0 +1,28 @@
+Index: src/freeglut_window.c
+===================================================================
+--- src/freeglut_window.c (Revision 832)
++++ src/freeglut_window.c (Arbeitskopie)
+@@ -594,10 +594,9 @@
+ #if TARGET_HOST_POSIX_X11
+ if ( window )
+ {
+- glXMakeContextCurrent(
++ glXMakeCurrent(
+ fgDisplay.Display,
+ window->Window.Handle,
+- window->Window.Handle,
+ window->Window.Context
+ );
+
+@@ -932,10 +932,9 @@
+ XSetWMProtocols( fgDisplay.Display, window->Window.Handle,
+ &fgDisplay.DeleteWindow, 1 );
+
+- glXMakeContextCurrent(
++ glXMakeCurrent(
+ fgDisplay.Display,
+ window->Window.Handle,
+- window->Window.Handle,
+ window->Window.Context
+ );
+
diff --git a/media-libs/freeglut/files/freeglut-2.6.0_rc1-bsd_joystick.patch b/media-libs/freeglut/files/freeglut-2.6.0_rc1-bsd_joystick.patch
deleted file mode 100644
index cde788850aeb..000000000000
--- a/media-libs/freeglut/files/freeglut-2.6.0_rc1-bsd_joystick.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://sourceforge.net/tracker/?func=detail&aid=2862668&group_id=1032&atid=101032
-
---- freeglut-2.6.0/src/freeglut_joystick.c.old 2009-09-20 16:28:07 +0200
-+++ freeglut-2.6.0/src/freeglut_joystick.c 2009-09-20 16:28:18 +0200
-@@ -1325,7 +1325,7 @@
- if( joy->error )
- return;
-
-- snprintf( joyfname, sizeof(buffer), "%s/.joy%drc", getenv( "HOME" ), joy->id );
-+ snprintf( joyfname, sizeof(joyfname), "%s/.joy%drc", getenv( "HOME" ), joy->id );
-
- joyfile = fopen( joyfname, "r" );
- joy->error =( joyfile == NULL );
diff --git a/media-libs/freeglut/freeglut-2.6.0_rc1.ebuild b/media-libs/freeglut/freeglut-2.6.0.ebuild
index 230872486bb7..f74e8e594860 100644
--- a/media-libs/freeglut/freeglut-2.6.0_rc1.ebuild
+++ b/media-libs/freeglut/freeglut-2.6.0.ebuild
@@ -1,30 +1,36 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/freeglut/freeglut-2.6.0_rc1.ebuild,v 1.9 2009/10/11 19:36:01 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/freeglut/freeglut-2.6.0.ebuild,v 1.1 2009/11/30 12:43:55 scarabeus Exp $
EAPI="2"
-inherit eutils flag-o-matic libtool
+inherit eutils flag-o-matic libtool autotools
DESCRIPTION="A completely OpenSourced alternative to the OpenGL Utility Toolkit (GLUT) library"
HOMEPAGE="http://freeglut.sourceforge.net/"
-SRC_URI="mirror://sourceforge/freeglut/${P/_/-}.tar.gz"
+SRC_URI="mirror://sourceforge/freeglut/${P/_/-}.tar.gz
+ mpx? ( http://tisch.sourceforge.net/freeglut-2.6.0-mpx-r6.patch )"
LICENSE="X11"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug"
+IUSE="debug mpx"
-RDEPEND="virtual/opengl
+RDEPEND="
+ virtual/opengl
virtual/glu
- !media-libs/glut"
+ mpx? ( >=x11-libs/libXi-1.3 )
+"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${P/_*/}"
src_prepare() {
- epatch "${FILESDIR}/${P}-bsd_joystick.patch"
- epatch "${FILESDIR}/${PN}-2.4.0-bsd-usb-joystick.patch"
+ epatch "${FILESDIR}/${PV}-GFX_radeon.patch"
+
+ use mpx && epatch "${DISTDIR}/${P}-mpx-r6.patch"
+
+ eautoreconf
# Needed for sane .so versionning on bsd, please don't drop
elibtoolize
}
diff --git a/media-libs/freeglut/metadata.xml b/media-libs/freeglut/metadata.xml
index 2772d643054e..b78c5e306871 100644
--- a/media-libs/freeglut/metadata.xml
+++ b/media-libs/freeglut/metadata.xml
@@ -3,7 +3,17 @@
<pkgmetadata>
<herd>x11</herd>
<maintainer>
- <email>x11@gentoo.org</email>
+ <email>x11@gentoo.org</email>
</maintainer>
-<longdescription>Freeglut provides an open-source alternative to the OpenGL Utility Toolkit (GLUT) library. It is actively developed and maintained, while not being restricted by its license.</longdescription>
+<use>
+ <flag name="mpx">
+ Enable support for multi-pointer-X. One pointer for each pointer
+ device.
+ </flag>
+</use>
+<longdescription>
+ Freeglut provides an open-source alternative to the OpenGL Utility Toolkit
+ (GLUT) library. It is actively developed and maintained, while not being
+ restricted by its license.
+</longdescription>
</pkgmetadata>