summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2006-08-25 20:53:37 +0000
committerHanno Böck <hanno@gentoo.org>2006-08-25 20:53:37 +0000
commit2d620ec34d05e974d556e62576b4248b13e1cb2a (patch)
treea3b050669d7da908bf1f668675de578d4827d7a9 /media-libs
parentDisabled detection of CPU throttling and added a warning for the user. (diff)
downloadgentoo-2-2d620ec34d05e974d556e62576b4248b13e1cb2a.tar.gz
gentoo-2-2d620ec34d05e974d556e62576b4248b13e1cb2a.tar.bz2
gentoo-2-2d620ec34d05e974d556e62576b4248b13e1cb2a.zip
(hopefully) final fix for libGL.la
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/ChangeLog6
-rw-r--r--media-libs/mesa/files/lib/libGL.la4
-rw-r--r--media-libs/mesa/mesa-6.4.2-r2.ebuild6
-rw-r--r--media-libs/mesa/mesa-6.5-r3.ebuild6
-rw-r--r--media-libs/mesa/mesa-6.5-r4.ebuild6
5 files changed, 16 insertions, 12 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 3d192ce947dc..d79c92cd004c 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.104 2006/08/25 19:47:02 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.105 2006/08/25 20:53:37 hanno Exp $
+
+ 25 Aug 2006; Hanno Boeck <hanno@gentoo.org> files/lib/libGL.la,
+ mesa-6.4.2-r2.ebuild, mesa-6.5-r3.ebuild, mesa-6.5-r4.ebuild:
+ Really fix libGL.la, replace lib with get_libdir.
25 Aug 2006; Hanno Boeck <hanno@gentoo.org> files/lib/libGL.la:
Make libGL.la point to /usr/lib to let apps link against currently running
diff --git a/media-libs/mesa/files/lib/libGL.la b/media-libs/mesa/files/lib/libGL.la
index 573953319eaa..cc2fd24acd20 100644
--- a/media-libs/mesa/files/lib/libGL.la
+++ b/media-libs/mesa/files/lib/libGL.la
@@ -14,7 +14,7 @@ library_names='libGL.so.1.2 libGL.so.1 libGL.so'
old_library=''
# Libraries that this one depends upon.
-dependency_libs=' -L/usr/lib -lSM -lICE -lXmu -lXt -lXext -lXi -lX11 -ldl -lpthread '
+dependency_libs=' -L/usr/${libdir} -lSM -lICE -lXmu -lXt -lXext -lXi -lX11 -ldl -lpthread '
# Version information for libGL.
current=3
@@ -29,4 +29,4 @@ dlopen=''
dlpreopen=''
# Directory that this library needs to be installed in:
-libdir='/usr/lib'
+libdir='/usr/${libdir}'
diff --git a/media-libs/mesa/mesa-6.4.2-r2.ebuild b/media-libs/mesa/mesa-6.4.2-r2.ebuild
index b6e694e88932..6152690f5807 100644
--- a/media-libs/mesa/mesa-6.4.2-r2.ebuild
+++ b/media-libs/mesa/mesa-6.4.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.4.2-r2.ebuild,v 1.16 2006/07/12 21:10:03 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.4.2-r2.ebuild,v 1.17 2006/08/25 20:53:37 hanno Exp $
inherit eutils toolchain-funcs multilib flag-o-matic portability
@@ -267,8 +267,8 @@ src_install() {
insinto /usr/$(get_libdir)
# (#67729) Needs to be lib, not $(get_libdir)
doins ${FILESDIR}/lib/libGLU.la
- insinto /usr/$(get_libdir)/opengl/xorg-x11/lib
- doins ${FILESDIR}/lib/libGL.la
+ sed -e "s:\${libdir}:$(get_libdir):g" ${FILESDIR}/lib/libGL.la \
+ > ${D}/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.la
# On *BSD libcs dlopen() and similar functions are present directly in
# libc.so and does not require linking to libdl. portability eclass takes
diff --git a/media-libs/mesa/mesa-6.5-r3.ebuild b/media-libs/mesa/mesa-6.5-r3.ebuild
index c748effc4db8..b1690248eda0 100644
--- a/media-libs/mesa/mesa-6.5-r3.ebuild
+++ b/media-libs/mesa/mesa-6.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5-r3.ebuild,v 1.11 2006/07/19 14:34:47 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5-r3.ebuild,v 1.12 2006/08/25 20:53:37 hanno Exp $
inherit eutils toolchain-funcs multilib flag-o-matic portability
@@ -264,8 +264,8 @@ src_install() {
insinto /usr/$(get_libdir)
# (#67729) Needs to be lib, not $(get_libdir)
doins ${FILESDIR}/lib/libGLU.la
- insinto /usr/$(get_libdir)/opengl/xorg-x11/lib
- doins ${FILESDIR}/lib/libGL.la
+ sed -e "s:\${libdir}:$(get_libdir):g" ${FILESDIR}/lib/libGL.la \
+ > ${D}/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.la
# On *BSD libcs dlopen() and similar functions are present directly in
# libc.so and does not require linking to libdl. portability eclass takes
diff --git a/media-libs/mesa/mesa-6.5-r4.ebuild b/media-libs/mesa/mesa-6.5-r4.ebuild
index 35bef43ddea8..12973d5726b6 100644
--- a/media-libs/mesa/mesa-6.5-r4.ebuild
+++ b/media-libs/mesa/mesa-6.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5-r4.ebuild,v 1.1 2006/07/29 18:28:06 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5-r4.ebuild,v 1.2 2006/08/25 20:53:37 hanno Exp $
inherit eutils toolchain-funcs multilib flag-o-matic portability
@@ -265,8 +265,8 @@ src_install() {
insinto /usr/$(get_libdir)
# (#67729) Needs to be lib, not $(get_libdir)
doins ${FILESDIR}/lib/libGLU.la
- insinto /usr/$(get_libdir)/opengl/xorg-x11/lib
- doins ${FILESDIR}/lib/libGL.la
+ sed -e "s:\${libdir}:$(get_libdir):g" ${FILESDIR}/lib/libGL.la \
+ > ${D}/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.la
# On *BSD libcs dlopen() and similar functions are present directly in
# libc.so and does not require linking to libdl. portability eclass takes