summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-07-03 20:19:00 +0000
committerMichał Górny <mgorny@gentoo.org>2014-07-03 20:19:00 +0000
commit27814c3a846671b03e1c48c534656060c02f35ca (patch)
treeff93b529b1e7e38edce701cf9aa097d57c7ef414 /media-libs
parentStable on amd64. bug #512178. Mark also stable on x86. Tested by Myckel Habets. (diff)
downloadgentoo-2-27814c3a846671b03e1c48c534656060c02f35ca.tar.gz
gentoo-2-27814c3a846671b03e1c48c534656060c02f35ca.tar.bz2
gentoo-2-27814c3a846671b03e1c48c534656060c02f35ca.zip
Backport the multilib support to giflib-4.1.6 to ease stabilization.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/giflib/ChangeLog7
-rw-r--r--media-libs/giflib/giflib-4.1.6-r3.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/media-libs/giflib/ChangeLog b/media-libs/giflib/ChangeLog
index 6458096c957d..c1ebae85fd9e 100644
--- a/media-libs/giflib/ChangeLog
+++ b/media-libs/giflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/giflib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/ChangeLog,v 1.77 2014/06/18 19:30:10 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/ChangeLog,v 1.78 2014/07/03 20:19:00 mgorny Exp $
+
+*giflib-4.1.6-r3 (03 Jul 2014)
+
+ 03 Jul 2014; Michał Górny <mgorny@gentoo.org> +giflib-4.1.6-r3.ebuild:
+ Backport the multilib support to giflib-4.1.6 to ease stabilization.
18 Jun 2014; Michał Górny <mgorny@gentoo.org> giflib-4.2.3-r1.ebuild:
Update dependencies to require guaranteed EAPI=5 or multilib ebuilds, bug
diff --git a/media-libs/giflib/giflib-4.1.6-r3.ebuild b/media-libs/giflib/giflib-4.1.6-r3.ebuild
new file mode 100644
index 000000000000..095511da6528
--- /dev/null
+++ b/media-libs/giflib/giflib-4.1.6-r3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/giflib-4.1.6-r3.ebuild,v 1.1 2014/07/03 20:19:00 mgorny Exp $
+
+EAPI=5
+
+inherit eutils libtool multilib-minimal
+
+DESCRIPTION="Library to handle, display and manipulate GIF images"
+HOMEPAGE="http://sourceforge.net/projects/giflib/"
+SRC_URI="mirror://sourceforge/giflib/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="rle static-libs X"
+
+RDEPEND="
+ rle? ( media-libs/urt )
+ X? ( >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140406-r1
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gif2rle.patch
+ epatch "${FILESDIR}"/${P}-giffix-null-Extension-fix.patch
+ elibtoolize
+ epunt_cxx
+}
+
+multilib_src_configure() {
+ local myconf=()
+
+ # prevent circular depend #111455
+ if multilib_is_native_abi && has_version media-libs/urt ; then
+ myconf+=( $(use_enable rle) )
+ else
+ myconf+=( --disable-rle )
+ fi
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-gl \
+ $(use_enable static-libs static) \
+ $(use_enable X x11) \
+ "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ # for static libs the .la file is required if build with +rle or +X
+ use static-libs || prune_libtool_files --all
+
+ dodoc AUTHORS BUGS ChangeLog NEWS ONEWS README TODO doc/*.txt
+ dohtml -r doc
+}