summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-11 09:54:19 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-11 09:54:19 +0000
commit95c056f25371983fbeaa5ea850a385bfd37e5755 (patch)
tree67bfe5942a852fa4ea8f45af72d1c2ce1f682986 /media-libs/taglib
parentDrop sparc keywords (diff)
downloadgentoo-2-95c056f25371983fbeaa5ea850a385bfd37e5755.tar.gz
gentoo-2-95c056f25371983fbeaa5ea850a385bfd37e5755.tar.bz2
gentoo-2-95c056f25371983fbeaa5ea850a385bfd37e5755.zip
Version bump wrt bug #434694.
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/taglib')
-rw-r--r--media-libs/taglib/ChangeLog8
-rw-r--r--media-libs/taglib/taglib-1.8.ebuild55
2 files changed, 61 insertions, 2 deletions
diff --git a/media-libs/taglib/ChangeLog b/media-libs/taglib/ChangeLog
index 173c05923132..b74f047b5f43 100644
--- a/media-libs/taglib/ChangeLog
+++ b/media-libs/taglib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/taglib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/ChangeLog,v 1.132 2012/05/26 18:04:57 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/ChangeLog,v 1.133 2012/09/11 09:54:19 johu Exp $
+
+*taglib-1.8 (11 Sep 2012)
+
+ 11 Sep 2012; Johannes Huber <johu@gentoo.org> +taglib-1.8.ebuild:
+ Version bump wrt bug #434694.
26 May 2012; Johannes Huber <johu@gentoo.org> -taglib-1.7.1.ebuild:
Remove old wrt bug #416143.
@@ -464,4 +469,3 @@
09 Dec 2003; Caleb Tennis <caleb@gentoo.org> metadata.xml, taglib-1.0_beta2.ebuild:
Initial import
-
diff --git a/media-libs/taglib/taglib-1.8.ebuild b/media-libs/taglib/taglib-1.8.ebuild
new file mode 100644
index 000000000000..cf6039c24bd9
--- /dev/null
+++ b/media-libs/taglib/taglib-1.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/taglib-1.8.ebuild,v 1.1 2012/09/11 09:54:19 johu Exp $
+
+EAPI=4
+CMAKE_IN_SOURCE_BUILD=1
+inherit cmake-utils
+
+DESCRIPTION="A library for reading and editing audio meta data"
+HOMEPAGE="http://developer.kde.org/~wheeler/taglib.html"
+SRC_URI="mirror://github/${PN}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 MPL-1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+SLOT="0"
+IUSE="+asf debug examples +mp4 test"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/cppunit )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-install-examples.patch
+)
+
+DOCS=( AUTHORS NEWS )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build examples)
+ $(cmake-utils_use_build test TESTS)
+ $(cmake-utils_use_with asf)
+ $(cmake-utils_use_with mp4)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # ctest does not work
+ default
+}
+
+pkg_postinst() {
+ if ! use asf; then
+ elog "You've chosen to disable the asf use flag, thus taglib won't include"
+ elog "support for Microsoft's 'advanced systems format' media container"
+ fi
+ if ! use mp4; then
+ elog "You've chosen to disable the mp4 use flag, thus taglib won't include"
+ elog "support for the MPEG-4 part 14 / MP4 media container"
+ fi
+}