summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2015-02-26 21:18:49 +0000
committerIan Stakenvicius <axs@gentoo.org>2015-02-26 21:18:49 +0000
commit72887379b7adb35f1e3b1059d0c3349ab8bbeeef (patch)
treeedd0121865078c2ebf3e91e030d26b5abbbe3c16 /media-libs/openh264
parentStable for arm64 (diff)
downloadgentoo-2-72887379b7adb35f1e3b1059d0c3349ab8bbeeef.tar.gz
gentoo-2-72887379b7adb35f1e3b1059d0c3349ab8bbeeef.tar.bz2
gentoo-2-72887379b7adb35f1e3b1059d0c3349ab8bbeeef.zip
version bump, supports firefox-36
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'media-libs/openh264')
-rw-r--r--media-libs/openh264/ChangeLog10
-rw-r--r--media-libs/openh264/openh264-1.3.1.ebuild78
2 files changed, 85 insertions, 3 deletions
diff --git a/media-libs/openh264/ChangeLog b/media-libs/openh264/ChangeLog
index d4240baabb01..d0432fb91117 100644
--- a/media-libs/openh264/ChangeLog
+++ b/media-libs/openh264/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/openh264
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openh264/ChangeLog,v 1.1 2014/12/04 04:01:03 axs Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openh264/ChangeLog,v 1.2 2015/02/26 21:18:49 axs Exp $
+
+*openh264-1.3.1 (26 Feb 2015)
+
+ 26 Feb 2015; Ian Stakenvicius (_AxS_) <axs@gentoo.org> +openh264-1.3.1.ebuild:
+ version bump, supports firefox-36
*openh264-1.2_p20141104 (04 Dec 2014)
@@ -11,4 +16,3 @@
for the time being. Note also that the mozilla prefs overrides will not
forcibly install at a later version, however a script needs to be written to
synchronize their installation.
-
diff --git a/media-libs/openh264/openh264-1.3.1.ebuild b/media-libs/openh264/openh264-1.3.1.ebuild
new file mode 100644
index 000000000000..231db244f090
--- /dev/null
+++ b/media-libs/openh264/openh264-1.3.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openh264/openh264-1.3.1.ebuild,v 1.1 2015/02/26 21:18:49 axs Exp $
+
+EAPI=5
+
+inherit nsplugins
+
+MOZVER=36
+DESCRIPTION="Cisco OpenH264 library and Gecko Media Plugin for mozilla packages"
+HOMEPAGE="http://www.openh264.org/"
+SRC_URI="https://github.com/cisco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/mozilla/gmp-api/archive/Firefox${MOZVER}.tar.gz -> gmp-api-Firefox${MOZVER}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+plugin"
+
+RESTRICT="bindist"
+
+RDEPEND="!<www-client/firefox-${MOZVER}"
+DEPEND="dev-lang/nasm"
+
+DOCS=( LICENSE CONTRIBUTORS README.md )
+
+src_prepare() {
+ ln -s ../gmp-api-Firefox${MOZVER} gmp-api
+}
+
+src_compile() {
+ local mybits="ENABLE64BIT=No"
+ case "${ABI}" in
+ s390x|alpha|*64) mybits="ENABLE64BIT=Yes";;
+ esac
+ emake V=Yes ${mybits}
+ use plugin && emake V=Yes ${mybits} plugin
+}
+
+src_install() {
+ emake PREFIX="${ED}usr" LIBPREFIX="${ED}usr/$(get_libdir)/" \
+ install-headers
+
+ dolib libopenh264.so
+
+ if use plugin; then
+ local plugpath="usr/$(get_libdir)/${PLUGINS_DIR}/gmp-gmp${PN}/system-installed"
+ insinto "/${plugpath}"
+ doins libgmpopenh264.so gmpopenh264.info
+ echo "MOZ_GMP_PATH=\"${EROOT}${plugpath}\"" >"${T}"/98-moz-gmp-${PN}
+ doenvd "${T}"/98-moz-gmp-${PN}
+
+ cat <<PREFEOF >"${T}"/${P}.js
+pref("media.gmp-gmp${PN}.autoupdate", false);
+pref("media.gmp-gmp${PN}.version", "system-installed");
+PREFEOF
+
+ insinto /usr/$(get_libdir)/firefox/defaults/pref
+ doins "${T}"/${P}.js
+
+ insinto /usr/$(get_libdir)/seamonkey/defaults/pref
+ doins "${T}"/${P}.js
+ fi
+}
+
+pkg_postinst() {
+ if use plugin; then
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please restart your login session, in order for the session's environment"
+ elog "to include the new MOZ_GMP_PATH variable."
+ elog ""
+ fi
+ elog "This package attempts to override the mozilla GMPInstaller auto-update process,"
+ elog "however even if it is not successful in doing so the profile-installed plugin"
+ elog "will not be used unless this package is removed. This package will take precedence"
+ elog "over any gmp-gmpopenh264 that may be installed in a user's profile."
+ elog ""
+ fi
+}