summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-24 22:57:47 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-24 22:57:47 +0000
commit0a6960c02c415e2c9e7630ebbd792bd873bd42cb (patch)
tree46c79042789db705a313be0ccfcc678926366e29 /media-libs/opencv
parentStable for HPPA (bug #413273). (diff)
downloadgentoo-2-0a6960c02c415e2c9e7630ebbd792bd873bd42cb.tar.gz
gentoo-2-0a6960c02c415e2c9e7630ebbd792bd873bd42cb.tar.bz2
gentoo-2-0a6960c02c415e2c9e7630ebbd792bd873bd42cb.zip
Drop -mfpmath=387 hardcode for x86 systems -- this breaks cross-compiling as the detection is uname based instead of target, and we really do not want to hardcode this anyways (let the user pick).
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/opencv')
-rw-r--r--media-libs/opencv/ChangeLog9
-rw-r--r--media-libs/opencv/files/opencv-2.3.0-convert_sets_to_options.patch35
-rw-r--r--media-libs/opencv/files/opencv-2.3.1a-convert_sets_to_options.patch20
3 files changed, 47 insertions, 17 deletions
diff --git a/media-libs/opencv/ChangeLog b/media-libs/opencv/ChangeLog
index cef1fed5b211..5191dac2c3e8 100644
--- a/media-libs/opencv/ChangeLog
+++ b/media-libs/opencv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/opencv
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opencv/ChangeLog,v 1.68 2012/04/22 16:41:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opencv/ChangeLog,v 1.69 2012/04/24 22:57:47 vapier Exp $
+
+ 24 Apr 2012; Mike Frysinger <vapier@gentoo.org>
+ files/opencv-2.3.0-convert_sets_to_options.patch,
+ files/opencv-2.3.1a-convert_sets_to_options.patch:
+ Drop -mfpmath=387 hardcode for x86 systems -- this breaks cross-compiling as
+ the detection is uname based instead of target, and we really do not want to
+ hardcode this anyways (let the user pick).
22 Apr 2012; Agostino Sarubbo <ago@gentoo.org> opencv-2.3.1a-r1.ebuild:
Stable for amd64, wrt bug #409733
diff --git a/media-libs/opencv/files/opencv-2.3.0-convert_sets_to_options.patch b/media-libs/opencv/files/opencv-2.3.0-convert_sets_to_options.patch
index 2f768bcd3355..7a794cd28a02 100644
--- a/media-libs/opencv/files/opencv-2.3.0-convert_sets_to_options.patch
+++ b/media-libs/opencv/files/opencv-2.3.0-convert_sets_to_options.patch
@@ -1,6 +1,5 @@
-diff -ruN OpenCV-2.3.0-0-vanilla/CMakeLists.txt OpenCV-2.3.0/CMakeLists.txt
---- OpenCV-2.3.0-0-vanilla/CMakeLists.txt 2011-07-04 06:21:50.000000000 +0200
-+++ OpenCV-2.3.0/CMakeLists.txt 2011-09-18 19:32:20.000000000 +0200
+--- OpenCV-2.3.0-0-vanilla/CMakeLists.txt
++++ OpenCV-2.3.0/CMakeLists.txt
@@ -14,7 +14,7 @@
# Add these standard paths to the search paths for FIND_LIBRARY
# to find libraries from these locations first
@@ -215,6 +214,21 @@ diff -ruN OpenCV-2.3.0-0-vanilla/CMakeLists.txt OpenCV-2.3.0/CMakeLists.txt
set(EXTRA_C_FLAGS "")
set(EXTRA_C_FLAGS_RELEASE "")
+@@ -1073,14 +1073,6 @@
+ endif()
+ endif()
+
+- if(X86 OR X86_64)
+- if(NOT APPLE)
+- if(${CMAKE_SIZEOF_VOID_P} EQUAL 4)
+- set(EXTRA_C_FLAGS_RELEASE "${EXTRA_C_FLAGS_RELEASE} -mfpmath=387")
+- endif()
+- endif()
+- endif()
+-
+ # Profiling?
+ if(ENABLE_PROFILING)
+ set(EXTRA_C_FLAGS_RELEASE "${EXTRA_C_FLAGS_RELEASE} -pg -g")
@@ -1197,7 +1197,7 @@
if(WIN32)
set(OPENCV_DOC_INSTALL_PATH doc)
@@ -259,9 +273,8 @@ diff -ruN OpenCV-2.3.0-0-vanilla/CMakeLists.txt OpenCV-2.3.0/CMakeLists.txt
if(BUILD_PACKAGE)
-diff -ruN OpenCV-2.3.0-0-vanilla/OpenCVModule.cmake OpenCV-2.3.0/OpenCVModule.cmake
---- OpenCV-2.3.0-0-vanilla/OpenCVModule.cmake 2011-07-04 06:21:59.000000000 +0200
-+++ OpenCV-2.3.0/OpenCVModule.cmake 2011-09-18 19:32:20.000000000 +0200
+--- OpenCV-2.3.0-0-vanilla/OpenCVModule.cmake
++++ OpenCV-2.3.0/OpenCVModule.cmake
@@ -63,7 +63,7 @@
DEBUG_POSTFIX "${OPENCV_DEBUG_POSTFIX}"
ARCHIVE_OUTPUT_DIRECTORY ${LIBRARY_OUTPUT_PATH}
@@ -282,9 +295,8 @@ diff -ruN OpenCV-2.3.0-0-vanilla/OpenCVModule.cmake OpenCV-2.3.0/OpenCVModule.cm
install(FILES ${lib_hdrs}
DESTINATION include/opencv2/${name}
-diff -ruN OpenCV-2.3.0-0-vanilla/modules/gpu/CMakeLists.txt OpenCV-2.3.0/modules/gpu/CMakeLists.txt
---- OpenCV-2.3.0-0-vanilla/modules/gpu/CMakeLists.txt 2011-07-04 06:21:58.000000000 +0200
-+++ OpenCV-2.3.0/modules/gpu/CMakeLists.txt 2011-09-18 19:32:20.000000000 +0200
+--- OpenCV-2.3.0-0-vanilla/modules/gpu/CMakeLists.txt
++++ OpenCV-2.3.0/modules/gpu/CMakeLists.txt
@@ -121,7 +121,7 @@
DEBUG_POSTFIX "${OPENCV_DEBUG_POSTFIX}"
ARCHIVE_OUTPUT_DIRECTORY ${LIBRARY_OUTPUT_PATH}
@@ -305,9 +317,8 @@ diff -ruN OpenCV-2.3.0-0-vanilla/modules/gpu/CMakeLists.txt OpenCV-2.3.0/modules
install(FILES ${lib_hdrs}
DESTINATION include/opencv2/${name}
-diff -ruN OpenCV-2.3.0-0-vanilla/modules/highgui/CMakeLists.txt OpenCV-2.3.0/modules/highgui/CMakeLists.txt
---- OpenCV-2.3.0-0-vanilla/modules/highgui/CMakeLists.txt 2011-07-04 06:21:58.000000000 +0200
-+++ OpenCV-2.3.0/modules/highgui/CMakeLists.txt 2011-09-18 19:32:20.000000000 +0200
+--- OpenCV-2.3.0-0-vanilla/modules/highgui/CMakeLists.txt
++++ OpenCV-2.3.0/modules/highgui/CMakeLists.txt
@@ -295,7 +295,7 @@
DEBUG_POSTFIX "${OPENCV_DEBUG_POSTFIX}"
ARCHIVE_OUTPUT_DIRECTORY ${LIBRARY_OUTPUT_PATH}
diff --git a/media-libs/opencv/files/opencv-2.3.1a-convert_sets_to_options.patch b/media-libs/opencv/files/opencv-2.3.1a-convert_sets_to_options.patch
index 174a1d68fdd1..522561bafbfc 100644
--- a/media-libs/opencv/files/opencv-2.3.1a-convert_sets_to_options.patch
+++ b/media-libs/opencv/files/opencv-2.3.1a-convert_sets_to_options.patch
@@ -1,6 +1,5 @@
-diff -ruN OpenCV-2.3.1-0-vanilla/CMakeLists.txt OpenCV-2.3.1-2-options/CMakeLists.txt
---- OpenCV-2.3.1-0-vanilla/CMakeLists.txt 2011-09-12 20:45:38.000000000 +0200
-+++ OpenCV-2.3.1-2-options/CMakeLists.txt 2011-11-13 14:11:45.000000000 +0100
+--- OpenCV-2.3.1-0-vanilla/CMakeLists.txt
++++ OpenCV-2.3.1-2-options/CMakeLists.txt
@@ -72,13 +72,13 @@
# Build static or dynamic libs?
# Default: dynamic libraries
@@ -206,7 +205,20 @@ diff -ruN OpenCV-2.3.1-0-vanilla/CMakeLists.txt OpenCV-2.3.1-2-options/CMakeList
if (WIN32 AND ${CMAKE_GENERATOR} MATCHES "(MinGW)|(MSYS)")
set(CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG" CACHE STRING "")
endif()
-@@ -1494,7 +1494,7 @@
+@@ -1222,12 +1222,6 @@ if(CMAKE_COMPILER_IS_GNUCXX)
+ endif()
+ endif()
+
+- if(X86 OR X86_64)
+- if(NOT APPLE AND CMAKE_SIZEOF_VOID_P EQUAL 4)
+- set(EXTRA_C_FLAGS_RELEASE "${EXTRA_C_FLAGS_RELEASE} -mfpmath=387")
+- endif()
+- endif()
+-
+ # Profiling?
+ if(ENABLE_PROFILING)
+ set(EXTRA_C_FLAGS_RELEASE "${EXTRA_C_FLAGS_RELEASE} -pg -g")
+@@@ -1494,7 +1494,7 @@
#-----------------------------------
# Source package:
#-----------------------------------