summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-01 08:35:09 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-01 08:35:09 +0000
commit5f1812f316bbaf4840f496d0c590b5425893d4c7 (patch)
treebcc06a14c97d88d44e05eed230e5f1ce9c940fd5 /media-libs/mesa
parentBump. xorg-server 1.5/mesa 7.1 will actually build against this one. TTM/GEM ... (diff)
downloadgentoo-2-5f1812f316bbaf4840f496d0c590b5425893d4c7.tar.gz
gentoo-2-5f1812f316bbaf4840f496d0c590b5425893d4c7.tar.bz2
gentoo-2-5f1812f316bbaf4840f496d0c590b5425893d4c7.zip
Fix build with libdrm 2.3.1.
(Portage version: 2.1.5.6)
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/ChangeLog7
-rw-r--r--media-libs/mesa/files/0001-dri-drop-asserts-to-make-build-against-stable-libdr.patch42
-rw-r--r--media-libs/mesa/mesa-7.1_rc1.ebuild8
3 files changed, 51 insertions, 6 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 52049eab00f1..a8acd532c3fa 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.176 2008/06/27 21:46:01 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.177 2008/07/01 08:35:09 dberkholz Exp $
+
+ 01 Jul 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/0001-dri-drop-asserts-to-make-build-against-stable-libdr.patch,
+ mesa-7.1_rc1.ebuild:
+ Fix build with libdrm 2.3.1.
27 Jun 2008; Donnie Berkholz <dberkholz@gentoo.org>; +files/version.mk:
Add missed file.
diff --git a/media-libs/mesa/files/0001-dri-drop-asserts-to-make-build-against-stable-libdr.patch b/media-libs/mesa/files/0001-dri-drop-asserts-to-make-build-against-stable-libdr.patch
new file mode 100644
index 000000000000..4e1ea8f33fab
--- /dev/null
+++ b/media-libs/mesa/files/0001-dri-drop-asserts-to-make-build-against-stable-libdr.patch
@@ -0,0 +1,42 @@
+From d3f7b463c3975c070503053e4ad70af99016a756 Mon Sep 17 00:00:00 2001
+From: Dave Airlie <airlied@linux.ie>
+Date: Tue, 1 Jul 2008 18:22:12 +1000
+Subject: [PATCH] dri: drop asserts to make build against stable libdrm
+
+These asserts are of questionable use at the moment with things in flux.
+---
+ src/mesa/drivers/dri/common/dri_bufmgr.c | 11 -----------
+ 1 files changed, 0 insertions(+), 11 deletions(-)
+
+diff --git a/src/mesa/drivers/dri/common/dri_bufmgr.c b/src/mesa/drivers/dri/common/dri_bufmgr.c
+index 4df006f..8b5cb76 100644
+--- a/src/mesa/drivers/dri/common/dri_bufmgr.c
++++ b/src/mesa/drivers/dri/common/dri_bufmgr.c
+@@ -40,11 +40,6 @@ dri_bo *
+ dri_bo_alloc(dri_bufmgr *bufmgr, const char *name, unsigned long size,
+ unsigned int alignment, uint64_t location_mask)
+ {
+- assert((location_mask & ~(DRM_BO_FLAG_MEM_LOCAL | DRM_BO_FLAG_MEM_TT |
+- DRM_BO_FLAG_MEM_VRAM | DRM_BO_FLAG_MEM_PRIV0 |
+- DRM_BO_FLAG_MEM_PRIV1 | DRM_BO_FLAG_MEM_PRIV2 |
+- DRM_BO_FLAG_MEM_PRIV3 | DRM_BO_FLAG_MEM_PRIV4 |
+- DRM_BO_FLAG_CACHED | DRM_BO_FLAG_CACHED_MAPPED)) == 0);
+ return bufmgr->bo_alloc(bufmgr, name, size, alignment, location_mask);
+ }
+
+@@ -53,12 +48,6 @@ dri_bo_alloc_static(dri_bufmgr *bufmgr, const char *name, unsigned long offset,
+ unsigned long size, void *virtual,
+ uint64_t location_mask)
+ {
+- assert((location_mask & ~(DRM_BO_FLAG_MEM_LOCAL | DRM_BO_FLAG_MEM_TT |
+- DRM_BO_FLAG_MEM_VRAM | DRM_BO_FLAG_MEM_PRIV0 |
+- DRM_BO_FLAG_MEM_PRIV1 | DRM_BO_FLAG_MEM_PRIV2 |
+- DRM_BO_FLAG_MEM_PRIV3 |
+- DRM_BO_FLAG_MEM_PRIV4)) == 0);
+-
+ return bufmgr->bo_alloc_static(bufmgr, name, offset, size, virtual,
+ location_mask);
+ }
+--
+1.5.5.4
+
diff --git a/media-libs/mesa/mesa-7.1_rc1.ebuild b/media-libs/mesa/mesa-7.1_rc1.ebuild
index 98ff347d0c80..baf88e9fe5b4 100644
--- a/media-libs/mesa/mesa-7.1_rc1.ebuild
+++ b/media-libs/mesa/mesa-7.1_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.1_rc1.ebuild,v 1.4 2008/06/27 21:42:38 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.1_rc1.ebuild,v 1.5 2008/07/01 08:35:09 dberkholz Exp $
EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/mesa"
@@ -54,7 +54,7 @@ RDEPEND="app-admin/eselect-opengl
x11-libs/libXi
x11-libs/libXmu
x11-libs/libXdamage
- >=x11-libs/libdrm-2.3.1_pre1
+ >=x11-libs/libdrm-2.3.1
x11-libs/libICE
motif? ( x11-libs/openmotif )
doc? ( app-doc/opengl-manpages )
@@ -103,6 +103,7 @@ src_unpack() {
# Disable TTM
epatch "${FILESDIR}/0001-mesa-drm-ttm-allow-build-against-non-TTM-aware-libd.patch"
+ epatch "${FILESDIR}/0001-dri-drop-asserts-to-make-build-against-stable-libdr.patch"
cp "${FILESDIR}/version.mk" bin/ || die
@@ -165,10 +166,7 @@ src_compile() {
myconf="${myconf} $(use_enable motif glw)"
- emake realclean || die
econf ${myconf} || die
- # So makedepend runs for header changes
- find src/mesa/drivers/dri/ | xargs touch
emake || die
}