summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-25 18:35:40 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-25 18:35:40 +0000
commit27bf3034ca476f14201653bae83525c5bff0087c (patch)
treeb061f5605e01ee4b6a37c6636521bfc1d36a17fc /media-libs/libvpx
parentRevision bump adds patch by SN (Enlik) <slawomir.nizio@sabayon.org> which fix... (diff)
downloadgentoo-2-27bf3034ca476f14201653bae83525c5bff0087c.tar.gz
gentoo-2-27bf3034ca476f14201653bae83525c5bff0087c.tar.bz2
gentoo-2-27bf3034ca476f14201653bae83525c5bff0087c.zip
do not mess with MAKEOPTS, pass it to emake directly
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libvpx')
-rw-r--r--media-libs/libvpx/ChangeLog5
-rw-r--r--media-libs/libvpx/libvpx-9999.ebuild18
2 files changed, 15 insertions, 8 deletions
diff --git a/media-libs/libvpx/ChangeLog b/media-libs/libvpx/ChangeLog
index 0ec41f356d05..6682d4241784 100644
--- a/media-libs/libvpx/ChangeLog
+++ b/media-libs/libvpx/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/libvpx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/ChangeLog,v 1.87 2013/06/25 18:27:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/ChangeLog,v 1.88 2013/06/25 18:35:40 aballier Exp $
+
+ 25 Jun 2013; Alexis Ballier <aballier@gentoo.org> libvpx-9999.ebuild:
+ do not mess with MAKEOPTS, pass it to emake directly
25 Jun 2013; Alexis Ballier <aballier@gentoo.org> libvpx-9999.ebuild:
dont build tests if they will not be ran
diff --git a/media-libs/libvpx/libvpx-9999.ebuild b/media-libs/libvpx/libvpx-9999.ebuild
index 8c97c9084c72..cda89a63111a 100644
--- a/media-libs/libvpx/libvpx-9999.ebuild
+++ b/media-libs/libvpx/libvpx-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-9999.ebuild,v 1.38 2013/06/25 18:27:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-9999.ebuild,v 1.39 2013/06/25 18:35:40 aballier Exp $
EAPI=4
inherit multilib toolchain-funcs multilib-minimal
@@ -52,12 +52,6 @@ multilib_src_configure() {
x86_64*) export AS=yasm;;
esac
- # build verbose by default
- MAKEOPTS="${MAKEOPTS} verbose=yes"
-
- # do not build examples that will not be installed
- MAKEOPTS="${MAKEOPTS} GEN_EXAMPLES="
-
# http://bugs.gentoo.org/show_bug.cgi?id=384585
addpredict /usr/share/snmp/mibs/.index
@@ -95,3 +89,13 @@ multilib_src_configure() {
${myconf} \
|| die
}
+
+multilib_src_compile() {
+ # build verbose by default and do not build examples that will not be installed
+ emake verbose=yes GEN_EXAMPLES=
+}
+
+multilib_src_install() {
+ emake verbose=yes GEN_EXAMPLES= DESTDIR="${D}" install
+}
+