summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-11 03:11:49 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-11 03:11:49 +0000
commit534c25390fbf42ca9a44b86e12b9a1b6bc14e7b0 (patch)
tree32b07b2a3bb85c5961c33f2967ae9277bd937f7a /media-libs/libvisual
parentjust updating heatclient, nothing to see here (diff)
downloadgentoo-2-534c25390fbf42ca9a44b86e12b9a1b6bc14e7b0.tar.gz
gentoo-2-534c25390fbf42ca9a44b86e12b9a1b6bc14e7b0.tar.bz2
gentoo-2-534c25390fbf42ca9a44b86e12b9a1b6bc14e7b0.zip
Fix broken cpp check, bug #431066. Fix amd64 detection. Fix broken threads AC_ARG_ENABLE.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libvisual')
-rw-r--r--media-libs/libvisual/ChangeLog8
-rw-r--r--media-libs/libvisual/files/libvisual-0.4.0-cond.patch15
-rw-r--r--media-libs/libvisual/files/libvisual-0.4.0-conditions.patch24
-rw-r--r--media-libs/libvisual/files/libvisual-0.4.0-detect_amd64.patch14
-rw-r--r--media-libs/libvisual/libvisual-0.4.0-r3.ebuild6
5 files changed, 65 insertions, 2 deletions
diff --git a/media-libs/libvisual/ChangeLog b/media-libs/libvisual/ChangeLog
index 7a605a97c579..b14db816fc2f 100644
--- a/media-libs/libvisual/ChangeLog
+++ b/media-libs/libvisual/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libvisual
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/ChangeLog,v 1.49 2013/08/10 20:36:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/ChangeLog,v 1.50 2013/08/11 03:11:49 aballier Exp $
+
+ 11 Aug 2013; Alexis Ballier <aballier@gentoo.org> libvisual-0.4.0-r3.ebuild,
+ +files/libvisual-0.4.0-cond.patch, +files/libvisual-0.4.0-conditions.patch,
+ +files/libvisual-0.4.0-detect_amd64.patch:
+ Fix broken cpp check, bug #431066. Fix amd64 detection. Fix broken threads
+ AC_ARG_ENABLE.
*libvisual-0.4.0-r3 (10 Aug 2013)
diff --git a/media-libs/libvisual/files/libvisual-0.4.0-cond.patch b/media-libs/libvisual/files/libvisual-0.4.0-cond.patch
new file mode 100644
index 000000000000..e1a3efd47418
--- /dev/null
+++ b/media-libs/libvisual/files/libvisual-0.4.0-cond.patch
@@ -0,0 +1,15 @@
+Broken --enable/disable condition.
+
+Index: libvisual-0.4.0/configure.ac
+===================================================================
+--- libvisual-0.4.0.orig/configure.ac
++++ libvisual-0.4.0/configure.ac
+@@ -191,7 +191,7 @@ AIX_COMPILE_INFO="AIX's C compiler needs
+ with the right compiler. Ususally just '_r' is appended
+ to the compiler name."
+
+-AC_ARG_ENABLE([enable_threads],
++AC_ARG_ENABLE([threads],
+ AC_HELP_STRING([--enable-threads],
+ [Turn on basic thread support @<:@default=enabled@:>@]),
+ [enable_threads=$enableval],
diff --git a/media-libs/libvisual/files/libvisual-0.4.0-conditions.patch b/media-libs/libvisual/files/libvisual-0.4.0-conditions.patch
new file mode 100644
index 000000000000..1520db2eac5e
--- /dev/null
+++ b/media-libs/libvisual/files/libvisual-0.4.0-conditions.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/show_bug.cgi?id=431066
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=456856
+
+diff -u libvisual-0.4.0/libvisual/lv_cpu.c libvisual-0.4.0/libvisual/lv_cpu.c
+--- libvisual-0.4.0/libvisual/lv_cpu.c
++++ libvisual-0.4.0/libvisual/lv_cpu.c
+@@ -76,7 +76,7 @@
+
+ /* The sigill handlers */
+ #if defined(VISUAL_ARCH_X86) //x86 (linux katmai handler check thing)
+-#if defined(VISUAL_OS_LINUX) && defined(_POSIX_SOURCE) && defined(X86_FXSR_MAGIC)
++#if defined(VISUAL_OS_LINUX) && defined(_POSIX_SOURCE)
+ static void sigill_handler_sse( int signal, struct sigcontext sc )
+ {
+ /* Both the "xorps %%xmm0,%%xmm0" and "divps %xmm0,%%xmm1"
+@@ -109,7 +109,7 @@
+ }
+ }
+ #endif
+-#endif /* VISUAL_OS_LINUX && _POSIX_SOURCE && X86_FXSR_MAGIC */
++#endif /* VISUAL_OS_LINUX && _POSIX_SOURCE */
+
+ #if defined(VISUAL_OS_WIN32)
+ LONG CALLBACK win32_sig_handler_sse(EXCEPTION_POINTERS* ep)
diff --git a/media-libs/libvisual/files/libvisual-0.4.0-detect_amd64.patch b/media-libs/libvisual/files/libvisual-0.4.0-detect_amd64.patch
new file mode 100644
index 000000000000..a796acce3b07
--- /dev/null
+++ b/media-libs/libvisual/files/libvisual-0.4.0-detect_amd64.patch
@@ -0,0 +1,14 @@
+Needed so that lvconfig.h gets the correct define for amd64.
+
+Index: libvisual-0.4.0/configure.ac
+===================================================================
+--- libvisual-0.4.0.orig/configure.ac
++++ libvisual-0.4.0/configure.ac
+@@ -780,6 +780,7 @@ echo >>$outfile
+ lv_alpha=$lv_alpha
+ lv_sparc=$lv_sparc
+ lv_ix86=$lv_ix86
++ lv_x86_64=$lv_x86_64
+ lv_powerpc=$lv_powerpc
+ lv_arch_unknown=$lv_arch_unknown
+
diff --git a/media-libs/libvisual/libvisual-0.4.0-r3.ebuild b/media-libs/libvisual/libvisual-0.4.0-r3.ebuild
index 051e0fbd4ac9..283fc34603a7 100644
--- a/media-libs/libvisual/libvisual-0.4.0-r3.ebuild
+++ b/media-libs/libvisual/libvisual-0.4.0-r3.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/libvisual-0.4.0-r3.ebuild,v 1.1 2013/08/10 20:36:40 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/libvisual-0.4.0-r3.ebuild,v 1.2 2013/08/11 03:11:49 aballier Exp $
EAPI=5
AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+AUTOTOOLS_AUTORECONF=1
inherit autotools-multilib
@@ -28,6 +29,9 @@ DOCS=( AUTHORS ChangeLog NEWS README TODO )
PATCHES=(
"${FILESDIR}"/${P}-better-altivec-detection.patch
"${FILESDIR}"/${P}-inlinedefineconflict.patch
+ "${FILESDIR}"/${P}-conditions.patch
+ "${FILESDIR}"/${P}-detect_amd64.patch
+ "${FILESDIR}"/${P}-cond.patch
)
MULTILIB_WRAPPED_HEADERS=(