summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-02 13:10:56 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-02 13:10:56 +0000
commite1089863f1d20130e7a3edb738c3d690c7244e99 (patch)
tree508bc0fb6c9653d90775b9ea79e39abcad54ca68 /media-libs/libsndfile/files
parentFix crash on first time run. (diff)
downloadgentoo-2-e1089863f1d20130e7a3edb738c3d690c7244e99.tar.gz
gentoo-2-e1089863f1d20130e7a3edb738c3d690c7244e99.tar.bz2
gentoo-2-e1089863f1d20130e7a3edb738c3d690c7244e99.zip
Added patch to make flac dependency optional. See bug #114228.
(Portage version: 2.0.53)
Diffstat (limited to 'media-libs/libsndfile/files')
-rw-r--r--media-libs/libsndfile/files/digest-libsndfile-1.0.12-r1 (renamed from media-libs/libsndfile/files/digest-libsndfile-1.0.12)0
-rw-r--r--media-libs/libsndfile/files/libsndfile-1.0.12-flac.patch30
2 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/libsndfile/files/digest-libsndfile-1.0.12 b/media-libs/libsndfile/files/digest-libsndfile-1.0.12-r1
index e71d343cc831..e71d343cc831 100644
--- a/media-libs/libsndfile/files/digest-libsndfile-1.0.12
+++ b/media-libs/libsndfile/files/digest-libsndfile-1.0.12-r1
diff --git a/media-libs/libsndfile/files/libsndfile-1.0.12-flac.patch b/media-libs/libsndfile/files/libsndfile-1.0.12-flac.patch
new file mode 100644
index 000000000000..38599e673ec3
--- /dev/null
+++ b/media-libs/libsndfile/files/libsndfile-1.0.12-flac.patch
@@ -0,0 +1,30 @@
+Make flac dependency optional by providing a --without-flac option, as
+requested in bug #114228.
+
+Index: libsndfile-1.0.12/configure.ac
+===================================================================
+--- libsndfile-1.0.12.orig/configure.ac
++++ libsndfile-1.0.12/configure.ac
+@@ -322,15 +322,19 @@ if test x$ac_cv_header_alsa_asoundlib_h
+ #====================================================================================
+ # Check for FLAC
+
+-FLAC_LIBS=""
+-AC_CHECK_HEADERS(FLAC/all.h)
+-if test x$ac_cv_header_FLAC_all_h = xyes ; then
++AC_ARG_WITH([flac], AC_HELP_STRING([--without-flac], [Disable FLAC support (default: check)]))
++
++if test "x$with_flac" != "xno"; then
++ FLAC_LIBS=""
++ AC_CHECK_HEADERS(FLAC/all.h)
++ if test x$ac_cv_header_FLAC_all_h = xyes ; then
+ AC_CHECK_LIB(FLAC, FLAC__seekable_stream_encoder_set_tell_callback, HAVE_FLAC_1_1_1="yes")
+ if test "x$HAVE_FLAC_1_1_1" = xyes ; then
+ AC_DEFINE(HAVE_FLAC_1_1_1, [1], [Define to 1 if you have libflac 1.1.1])
+ fi
+ FLAC_LIBS="-lFLAC"
+ fi
++fi
+
+ #====================================================================================
+ # Test for sanity when cross-compiling.