summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-31 13:50:03 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-31 13:50:03 +0000
commitb9d6c815aae922013fb8fa88556e5f8307dda09b (patch)
tree80c2b1f62ffa052108aa5265c3ea91735f68791b /media-libs/libshout/files
parentFix x11 dependencies, bug 157979 (diff)
downloadgentoo-2-b9d6c815aae922013fb8fa88556e5f8307dda09b.tar.gz
gentoo-2-b9d6c815aae922013fb8fa88556e5f8307dda09b.tar.bz2
gentoo-2-b9d6c815aae922013fb8fa88556e5f8307dda09b.zip
Version bump, bug #156211
(Portage version: 2.1.2.3)
Diffstat (limited to 'media-libs/libshout/files')
-rw-r--r--media-libs/libshout/files/digest-libshout-2.2.23
-rw-r--r--media-libs/libshout/files/libshout-2.2.2-asneeded.patch15
-rw-r--r--media-libs/libshout/files/libshout-2.2.2-automagic.patch42
3 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/libshout/files/digest-libshout-2.2.2 b/media-libs/libshout/files/digest-libshout-2.2.2
new file mode 100644
index 000000000000..d7f31a748e2c
--- /dev/null
+++ b/media-libs/libshout/files/digest-libshout-2.2.2
@@ -0,0 +1,3 @@
+MD5 4f75fc9901c724b712c371c9a1e782d3 libshout-2.2.2.tar.gz 476564
+RMD160 7ea5bc197953cfae6aff53876865909b2f6ac5f1 libshout-2.2.2.tar.gz 476564
+SHA256 912a1fdb12d31af757e7881db49321e5b5240bd8bd4199e9fb0ce16d66568160 libshout-2.2.2.tar.gz 476564
diff --git a/media-libs/libshout/files/libshout-2.2.2-asneeded.patch b/media-libs/libshout/files/libshout-2.2.2-asneeded.patch
new file mode 100644
index 000000000000..1655996ce0ad
--- /dev/null
+++ b/media-libs/libshout/files/libshout-2.2.2-asneeded.patch
@@ -0,0 +1,15 @@
+https://trac.xiph.org/ticket/1161
+
+Index: libshout-2.2.2/src/Makefile.am
+===================================================================
+--- libshout-2.2.2.orig/src/Makefile.am
++++ libshout-2.2.2/src/Makefile.am
+@@ -26,7 +26,7 @@ libshout_la_SOURCES = shout.c util.c ogg
+ AM_CFLAGS = @XIPH_CFLAGS@
+
+ libshout_la_LIBADD = net/libicenet.la timing/libicetiming.la avl/libiceavl.la\
+- httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(VORBIS_LIBS)
++ httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(VORBIS_LIBS) $(SPEEX_LIBS)
+
+ INCLUDES = -I$(top_builddir)/include
+
diff --git a/media-libs/libshout/files/libshout-2.2.2-automagic.patch b/media-libs/libshout/files/libshout-2.2.2-automagic.patch
new file mode 100644
index 000000000000..6dc28bf77454
--- /dev/null
+++ b/media-libs/libshout/files/libshout-2.2.2-automagic.patch
@@ -0,0 +1,42 @@
+https://trac.xiph.org/ticket/1162
+
+Index: libshout-2.2.2/configure.ac
+===================================================================
+--- libshout-2.2.2.orig/configure.ac
++++ libshout-2.2.2/configure.ac
+@@ -122,12 +122,17 @@ PKG_CHECK_MODULES(VORBIS, vorbis, [
+ VORBIS_LIBS="$VORBIS_LDFLAGS $VORBIS_LIBS"
+ XIPH_CFLAGS="$XIPH_CFLAGS $VORBIS_CFLAGS"
+
++AC_ARG_ENABLE([theora],
++ AC_HELP_STRING([--disable-theora],[do not build with theora support]))
++
++if test "x$enable_theora" != "xno"; then
+ PKG_CHECK_MODULES(THEORA, theora, [
+ HAVE_THEORA="yes"
+ SHOUT_REQUIRES="$SHOUT_REQUIRES, theora"
+ ], [
+ XIPH_PATH_THEORA(, [AC_MSG_WARN([Theora library not found, disabling])])
+ ])
++fi
+ XIPH_VAR_APPEND([XIPH_CPPFLAGS],[$THEORA_CFLAGS])
+ XIPH_VAR_PREPEND([XIPH_LIBS],[$THEORA LDFLAGS $THEORA_LIBS])
+ AM_CONDITIONAL([HAVE_THEORA], [test -n "$THEORA_LIBS"])
+@@ -136,12 +141,17 @@ then
+ AC_DEFINE([HAVE_THEORA], 1, [Define if you want theora streams supported])
+ fi
+
++AC_ARG_ENABLE([speex],
++ AC_HELP_STRING([--disable-speex],[do not build with speex support]))
++
++if test "x$enable_speex" != "xno"; then
+ PKG_CHECK_MODULES(SPEEX, speex, [
+ HAVE_SPEEX="yes"
+ SHOUT_REQUIRES="$SHOUT_REQUIRES, speex"
+ ], [
+ XIPH_PATH_SPEEX(, [AC_MSG_WARN([Speex library not found, disabling])])
+ ])
++fi
+ XIPH_VAR_APPEND([XIPH_CPPFLAGS],[$SPEEX_CFLAGS])
+ XIPH_VAR_PREPEND([XIPH_LIBS],[$SPEEX LDFLAGS $SPEEX_LIBS])
+ AM_CONDITIONAL([HAVE_SPEEX], [test -n "$SPEEX_LIBS"])