summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-26 22:34:26 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-26 22:34:26 +0000
commit6445ffe6a15151b5ffa3fd31766d36d9964de7ae (patch)
tree28ce9f908fdc1938b75b9e83ed1b5aa5fece90bb /media-libs/libmpeg3
parenttouchup (diff)
downloadgentoo-2-6445ffe6a15151b5ffa3fd31766d36d9964de7ae.tar.gz
gentoo-2-6445ffe6a15151b5ffa3fd31766d36d9964de7ae.tar.bz2
gentoo-2-6445ffe6a15151b5ffa3fd31766d36d9964de7ae.zip
version bump
Diffstat (limited to 'media-libs/libmpeg3')
-rw-r--r--media-libs/libmpeg3/ChangeLog7
-rw-r--r--media-libs/libmpeg3/files/1.5.1-gentoo-mpeg3split.patch75
-rw-r--r--media-libs/libmpeg3/files/1.5.1-gentoo-p1.patch53
-rw-r--r--media-libs/libmpeg3/files/1.5.1-gentoo-p2.patch119
-rw-r--r--media-libs/libmpeg3/files/1.5.1-pthread.patch11
-rw-r--r--media-libs/libmpeg3/files/digest-libmpeg3-1.5.11
-rw-r--r--media-libs/libmpeg3/libmpeg3-1.5.1.ebuild48
7 files changed, 313 insertions, 1 deletions
diff --git a/media-libs/libmpeg3/ChangeLog b/media-libs/libmpeg3/ChangeLog
index 13fb9363e012..69d949df6dc9 100644
--- a/media-libs/libmpeg3/ChangeLog
+++ b/media-libs/libmpeg3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libmpeg3
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/ChangeLog,v 1.11 2003/07/18 05:12:07 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/ChangeLog,v 1.12 2003/07/26 22:34:26 vapier Exp $
+
+*libmpeg3-1.5.1 (26 Jul 2003)
+
+ 26 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump + update patches + make sure quicktime4linux compiles.
*libmpeg3-1.5-r1 (15 Apr 2002)
diff --git a/media-libs/libmpeg3/files/1.5.1-gentoo-mpeg3split.patch b/media-libs/libmpeg3/files/1.5.1-gentoo-mpeg3split.patch
new file mode 100644
index 000000000000..2176eedaaed8
--- /dev/null
+++ b/media-libs/libmpeg3/files/1.5.1-gentoo-mpeg3split.patch
@@ -0,0 +1,75 @@
+--- Makefile 2003-07-26 17:53:04.000000000 -0400
++++ Makefile.blah 2003-07-26 17:50:44.000000000 -0400
+@@ -63,10 +63,9 @@
+ UTILOBJS = \
+ $(OBJDIR)/mpeg3cat.o \
+ $(OBJDIR)/mpeg3dump.o \
++ $(OBJDIR)/mpeg3split.o \
+ $(OBJDIR)/mpeg3toc.o
+
+-# $(OBJDIR)/mpeg3split.o \
+-
+
+
+
+@@ -152,9 +151,8 @@
+
+
+ OUTPUT = $(OBJDIR)/libmpeg3.a
+-UTILS = $(OBJDIR)/mpeg3dump $(OBJDIR)/mpeg3cat $(OBJDIR)/mpeg3toc
+-
+-#$(OBJDIR)/mpeg3split
++SHAREDOUTPUT = $(OBJDIR)/libmpeg3.so
++UTILS = $(OBJDIR)/mpeg3dump $(OBJDIR)/mpeg3cat $(OBJDIR)/mpeg3toc $(OBJDIR)/mpeg3split
+
+
+ LIBS = -lm -lpthread
+@@ -165,7 +163,7 @@
+ $(shell echo $(A52CFLAGS) > $(OBJDIR)/a52_flags)
+ $(shell echo $(OBJS) $(ASMOBJS) $(A52OBJS) $(NASMOBJS) > $(OBJDIR)/objs)
+
+-all: $(DIRS) $(OUTPUT) util
++all: $(DIRS) $(OUTPUT) $(SHAREDOUTPUT) util
+
+ $(DIRS):
+ if ! test -d $@ ; then mkdir -p $@ ; fi
+@@ -173,6 +171,9 @@
+ $(OUTPUT): $(OBJS) $(ASMOBJS) $(NASMOBJS) $(A52OBJS) $(UTILOBJS)
+ ar rcs $(OUTPUT) `cat $(OBJDIR)/objs`
+
++$(SHAREDOUTPUT): $(OBJS) $(ASMOBJS) $(NASMOBJS)
++ gcc -shared -o $(SHAREDOUTPUT) $(OBJS) $(ASMOBJS) $(NASMOBJS)
++
+ $(OBJDIR)/mpeg3dump: $(OUTPUT)
+ $(CC) `cat $(OBJDIR)/c_flags` -o $(OBJDIR)/mpeg3dump mpeg3dump.c $(OUTPUT) $(LIBS)
+
+@@ -182,8 +183,8 @@
+ $(OBJDIR)/mpeg3toc: $(OUTPUT)
+ $(CC) `cat $(OBJDIR)/c_flags` -o $(OBJDIR)/mpeg3toc mpeg3toc.c $(OUTPUT) $(LIBS)
+
+-#$(OBJDIR)/mpeg3split: $(OUTPUT)
+-# $(CC) `cat $(OBJDIR)/c_flags` -o $(OBJDIR)/mpeg3split mpeg3split.c $(OUTPUT) $(LIBS)
++$(OBJDIR)/mpeg3split: $(OUTPUT)
++ $(CC) `cat $(OBJDIR)/c_flags` -o $(OBJDIR)/mpeg3split mpeg3split.c $(OUTPUT) $(LIBS)
+
+ $(OBJDIR)/mpeg2qt: $(OUTPUT)
+ $(CC) `cat $(OBJDIR)/c_flags` -o $(OBJDIR)/mpeg2qt mpeg2qt.c \
+@@ -239,7 +239,7 @@
+ $(OBJDIR)/mpeg3demux.o: mpeg3demux.c
+ $(OBJDIR)/mpeg3ifo.o: mpeg3ifo.c
+ $(OBJDIR)/mpeg3io.o: mpeg3io.c
+-#$(OBJDIR)/mpeg3split.o: mpeg3split.c
++$(OBJDIR)/mpeg3split.o: mpeg3split.c
+ $(OBJDIR)/mpeg3title.o: mpeg3title.c
+ $(OBJDIR)/mpeg3toc.o: mpeg3toc.c
+ $(OBJDIR)/mpeg3toc3.o: mpeg3toc3.c
+--- mpeg3split.c.orig 2003-07-26 17:55:26.000000000 -0400
++++ mpeg3split.c 2003-07-26 17:51:28.000000000 -0400
+@@ -3,6 +3,7 @@
+ #include <string.h>
+
+ #include "mpeg3private.inc"
++#include "mpeg3private.h"
+
+ void copy_data(FILE *out, FILE *in, long bytes)
+ {
diff --git a/media-libs/libmpeg3/files/1.5.1-gentoo-p1.patch b/media-libs/libmpeg3/files/1.5.1-gentoo-p1.patch
new file mode 100644
index 000000000000..5a9013c6361e
--- /dev/null
+++ b/media-libs/libmpeg3/files/1.5.1-gentoo-p1.patch
@@ -0,0 +1,53 @@
+diff -urN libmpeg3.orig/Makefile libmpeg3/Makefile
+--- libmpeg3.orig/Makefile Wed Dec 26 07:40:52 2001
++++ libmpeg3/Makefile Mon Apr 15 13:54:22 2002
+@@ -105,6 +105,30 @@
+ $(OBJDIR)/video/vlc.o \
+ $(OBJDIR)/workarounds.o
+
++INSTALL_HEADERS = \
++ bitstream.h \
++ libmpeg3.h \
++ mpeg3atrack.h \
++ mpeg3css.h \
++ mpeg3demux.h \
++ mpeg3io.h \
++ mpeg3private.h \
++ mpeg3private.inc \
++ mpeg3protos.h \
++ mpeg3title.h \
++ mpeg3vtrack.h \
++ timecode.h \
++
++INSTALL_AHEADERS = \
++ audio/ac3.h \
++ audio/mpeg3audio.h \
++
++INSTALL_VHEADERS = \
++ video/idct.h \
++ video/slice.h \
++ video/mpeg3video.h
++
++
+ OUTPUT = $(OBJDIR)/libmpeg3.a
+ SHAREDOUTPUT = $(OBJDIR)/libmpeg3.so
+ UTILS = $(OBJDIR)/mpeg3dump $(OBJDIR)/mpeg3cat $(OBJDIR)/mpeg3toc $(OBJDIR)/mpeg3split
+@@ -148,7 +171,17 @@
+ util: $(UTILS)
+
+ install:
+- cp $(UTILS) /usr/bin
++ install -d $(DESTDIR)/bin
++ install -d $(DESTDIR)/include/libmpeg3
++ install -d $(DESTDIR)/include/libmpeg3/audio
++ install -d $(DESTDIR)/include/libmpeg3/video
++ install -d $(DESTDIR)/lib
++ install $(UTILS) $(DESTDIR)/bin
++ install -m 644 $(INSTALL_HEADERS) $(DESTDIR)/include/libmpeg3
++ install -m 644 $(INSTALL_AHEADERS) $(DESTDIR)/include/libmpeg3/audio
++ install -m 644 $(INSTALL_VHEADERS) $(DESTDIR)/include/libmpeg3/video
++ install -m 644 $(OUTPUT) $(DESTDIR)/lib
++ install -m 644 $(SHAREDOUTPUT) $(DESTDIR)/lib
+
+ clean:
+ rm -rf $(OBJDIR)
diff --git a/media-libs/libmpeg3/files/1.5.1-gentoo-p2.patch b/media-libs/libmpeg3/files/1.5.1-gentoo-p2.patch
new file mode 100644
index 000000000000..18e66dcca01b
--- /dev/null
+++ b/media-libs/libmpeg3/files/1.5.1-gentoo-p2.patch
@@ -0,0 +1,119 @@
+diff -urN libmpeg3.orig/bitstream.h libmpeg3/bitstream.h
+--- libmpeg3.orig/bitstream.h Fri Dec 21 14:00:01 2001
++++ libmpeg3/bitstream.h Mon Apr 15 14:13:12 2002
+@@ -1,7 +1,7 @@
+ #ifndef BITSTREAM_H
+ #define BITSTREAM_H
+
+-#include "mpeg3demux.h"
++#include <libmpeg3/mpeg3demux.h>
+ #include <sys/types.h>
+
+ // next bit in forward direction
+diff -urN libmpeg3.orig/libmpeg3.h libmpeg3/libmpeg3.h
+--- libmpeg3.orig/libmpeg3.h Fri Dec 21 10:48:14 2001
++++ libmpeg3/libmpeg3.h Mon Apr 15 14:13:12 2002
+@@ -5,7 +5,7 @@
+ extern "C" {
+ #endif
+
+-#include "mpeg3private.h"
++#include <libmpeg3/mpeg3private.h>
+
+
+ /* Supported color models for mpeg3_read_frame */
+diff -urN libmpeg3.orig/mpeg3css.h libmpeg3/mpeg3css.h
+--- libmpeg3.orig/mpeg3css.h Sun Sep 30 20:18:31 2001
++++ libmpeg3/mpeg3css.h Mon Apr 15 14:13:12 2002
+@@ -2,7 +2,7 @@
+ #define MPEG3CSS_H
+
+
+-#include "mpeg3private.inc"
++#include <libmpeg3/mpeg3private.inc>
+
+ struct mpeg3_block
+ {
+diff -urN libmpeg3.orig/mpeg3demux.h libmpeg3/mpeg3demux.h
+--- libmpeg3.orig/mpeg3demux.h Fri Dec 21 14:02:21 2001
++++ libmpeg3/mpeg3demux.h Mon Apr 15 14:13:12 2002
+@@ -1,7 +1,7 @@
+ #ifndef MPEG3DEMUX_H
+ #define MPEG3DEMUX_H
+
+-#include "mpeg3title.h"
++#include <libmpeg3/mpeg3title.h>
+ #include <stdio.h>
+
+ typedef struct
+diff -urN libmpeg3.orig/mpeg3io.h libmpeg3/mpeg3io.h
+--- libmpeg3.orig/mpeg3io.h Mon Dec 17 06:05:07 2001
++++ libmpeg3/mpeg3io.h Mon Apr 15 14:13:12 2002
+@@ -4,8 +4,8 @@
+
+ #include <stdio.h>
+ #include <stdint.h>
+-#include "mpeg3css.h"
+-#include "mpeg3private.inc"
++#include <libmpeg3/mpeg3css.h>
++#include <libmpeg3/mpeg3private.inc>
+
+ /* Filesystem structure */
+ /* We buffer in MPEG3_IO_SIZE buffers. Stream IO would require back */
+diff -urN libmpeg3.orig/mpeg3title.h libmpeg3/mpeg3title.h
+--- libmpeg3.orig/mpeg3title.h Wed Dec 19 06:28:25 2001
++++ libmpeg3/mpeg3title.h Mon Apr 15 14:13:12 2002
+@@ -1,7 +1,7 @@
+ #ifndef MPEG3TITLE_H
+ #define MPEG3TITLE_H
+
+-#include "mpeg3io.h"
++#include <libmpeg3/mpeg3io.h>
+
+ // May get rid of time values and rename to a cell offset table.
+ // May also get rid of end byte.
+diff -urN libmpeg3.orig/mpeg3vtrack.h libmpeg3/mpeg3vtrack.h
+--- libmpeg3.orig/mpeg3vtrack.h Thu Dec 20 08:19:18 2001
++++ libmpeg3/mpeg3vtrack.h Mon Apr 15 14:13:12 2002
+@@ -1,8 +1,8 @@
+ #ifndef MPEG3_VTRACK_H
+ #define MPEG3_VTRACK_H
+
+-#include "mpeg3demux.h"
+-#include "video/mpeg3video.h"
++#include <libmpeg3/mpeg3demux.h>
++#include <libmpeg3/video/mpeg3video.h>
+
+ typedef struct
+ {
+diff -urN libmpeg3.orig/video/mpeg3video.h libmpeg3/video/mpeg3video.h
+--- libmpeg3.orig/video/mpeg3video.h Sun Sep 30 20:18:31 2001
++++ libmpeg3/video/mpeg3video.h Mon Apr 15 14:13:12 2002
+@@ -1,9 +1,9 @@
+ #ifndef MPEGVIDEO_H
+ #define MPEGVIDEO_H
+
+-#include "../bitstream.h"
+-#include "../mpeg3private.inc"
+-#include "idct.h"
+-#include "slice.h"
+-#include "../timecode.h"
++#include <libmpeg3/bitstream.h>
++#include <libmpeg3/mpeg3private.inc>
++#include <libmpeg3/video/idct.h>
++#include <libmpeg3/video/slice.h>
++#include <libmpeg3/timecode.h>
+ #endif
+diff -urN libmpeg3.orig/mpeg3atrack.h libmpeg3/atrack.h
+--- libmpeg3.orig/mpeg3atrack.h 2003-07-26 17:31:58.000000000 -0400
++++ libmpeg3/mpeg3atrack.h 2003-07-26 17:32:27.000000000 -0400
+@@ -1,7 +1,7 @@
+ #ifndef MPEG3ATRACK_H
+ #define MPEG3ATRACK_H
+
+-#include "mpeg3demux.h"
+-#include "audio/mpeg3audio.h"
++#include <libmpeg3/mpeg3demux.h>
++#include <libmpeg3/audio/mpeg3audio.h>
+
+ #endif
diff --git a/media-libs/libmpeg3/files/1.5.1-pthread.patch b/media-libs/libmpeg3/files/1.5.1-pthread.patch
new file mode 100644
index 000000000000..2adeed9bab8c
--- /dev/null
+++ b/media-libs/libmpeg3/files/1.5.1-pthread.patch
@@ -0,0 +1,11 @@
+--- mpeg3private.h.orig 2003-07-26 17:18:33.000000000 -0400
++++ mpeg3private.h 2003-07-26 17:18:40.000000000 -0400
+@@ -3,7 +3,7 @@
+
+ #include <stdint.h>
+ #include <stdio.h>
+-
++#include <pthread.h>
+
+
+
diff --git a/media-libs/libmpeg3/files/digest-libmpeg3-1.5.1 b/media-libs/libmpeg3/files/digest-libmpeg3-1.5.1
new file mode 100644
index 000000000000..a6513bfd9e4f
--- /dev/null
+++ b/media-libs/libmpeg3/files/digest-libmpeg3-1.5.1
@@ -0,0 +1 @@
+MD5 8aec1ab57e0cd7f968b9398e206cb4d4 libmpeg3-1.5.1-src.tar.bz2 626532
diff --git a/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild b/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild
new file mode 100644
index 000000000000..c7ac83baf2be
--- /dev/null
+++ b/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild,v 1.1 2003/07/26 22:34:26 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="An mpeg library for linux"
+HOMEPAGE="http://heroinewarrior.com/libmpeg3.php3"
+SRC_URI="mirror://sourceforge/heroines/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+RDEPEND="sys-libs/zlib
+ media-libs/jpeg"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+filter-flags -fPIC
+filter-flags -fno-common
+[ ${ARCH} = alpha ] && append-flags -fPIC
+[ ${ARCH} = hppa ] && append-flags -fPIC
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # The Makefile is patched to install the header files as well.
+ # This patch was generated using the info in the src.rpm that
+ # SourceForge provides for this package.
+ epatch ${FILESDIR}/${PV}-gentoo-p1.patch
+ # Add in support for mpeg3split
+ epatch ${FILESDIR}/${PV}-gentoo-mpeg3split.patch
+ epatch ${FILESDIR}/${PV}-pthread.patch
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ # This patch patches the .h files that get installed into /usr/include
+ # to show the correct include syntax '<>' instead of '""' This patch
+ # was also generated using info from SF's src.rpm
+ epatch ${FILESDIR}/${PV}-gentoo-p2.patch
+ make DESTDIR=${D}/usr install || die
+ dohtml -r docs
+}