summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-11-30 13:36:09 +0000
committerMichał Górny <mgorny@gentoo.org>2014-11-30 13:36:09 +0000
commitf0bf4d2de3dde9fd04a5db44ad5d92584d167fc8 (patch)
treea41dbf4bb0e09da7ca011d1d9db5b578f45c2c70 /media-libs/libiptcdata
parentAdd missing REQUIRED_USE. (diff)
downloadgentoo-2-f0bf4d2de3dde9fd04a5db44ad5d92584d167fc8.tar.gz
gentoo-2-f0bf4d2de3dde9fd04a5db44ad5d92584d167fc8.tar.bz2
gentoo-2-f0bf4d2de3dde9fd04a5db44ad5d92584d167fc8.zip
Convert to python-single-r1.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs/libiptcdata')
-rw-r--r--media-libs/libiptcdata/ChangeLog7
-rw-r--r--media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/media-libs/libiptcdata/ChangeLog b/media-libs/libiptcdata/ChangeLog
index 42f6c48611bb..c482590feec2 100644
--- a/media-libs/libiptcdata/ChangeLog
+++ b/media-libs/libiptcdata/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libiptcdata
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libiptcdata/ChangeLog,v 1.27 2014/06/24 03:46:01 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libiptcdata/ChangeLog,v 1.28 2014/11/30 13:36:09 mgorny Exp $
+
+*libiptcdata-1.0.4-r1 (30 Nov 2014)
+
+ 30 Nov 2014; Michał Górny <mgorny@gentoo.org> +libiptcdata-1.0.4-r1.ebuild:
+ Convert to python-single-r1.
24 Jun 2014; Patrick Lauer <patrick@gentoo.org> libiptcdata-1.0.4.ebuild:
Remove obsolete lafilefixer message
diff --git a/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild b/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..1602aa15a36f
--- /dev/null
+++ b/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild,v 1.1 2014/11/30 13:36:09 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="library for manipulating the International Press Telecommunications
+Council (IPTC) metadata"
+HOMEPAGE="http://libiptcdata.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples nls python"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.13.1 )
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure () {
+ econf \
+ $(use_enable nls) \
+ $(use_enable python) \
+ $(use_enable doc gtk-doc)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed."
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/python
+ doins python/README || die "doins failed"
+ doins -r python/examples || die "doins 2 failed"
+ fi
+
+ find "${D}" -name '*.la' -delete || die "failed to remove *.la files"
+}