summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-03-16 19:43:35 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-03-16 19:43:35 +0000
commit4b01f8ecf381712916a0751605a691187d6724da (patch)
treee8b0ebf364bfec1cba7feed8a29f97cb463788fb /media-libs/libgpod
parentBump to 1.8.1, thanks to slepnoga (diff)
downloadgentoo-2-4b01f8ecf381712916a0751605a691187d6724da.tar.gz
gentoo-2-4b01f8ecf381712916a0751605a691187d6724da.tar.bz2
gentoo-2-4b01f8ecf381712916a0751605a691187d6724da.zip
Verbump.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libgpod')
-rw-r--r--media-libs/libgpod/ChangeLog7
-rw-r--r--media-libs/libgpod/libgpod-0.8.2.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/media-libs/libgpod/ChangeLog b/media-libs/libgpod/ChangeLog
index e01b875d8ad3..be4edc89bb45 100644
--- a/media-libs/libgpod/ChangeLog
+++ b/media-libs/libgpod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libgpod
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.88 2012/01/14 18:32:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.89 2012/03/16 19:43:35 robbat2 Exp $
+
+*libgpod-0.8.2 (16 Mar 2012)
+
+ 16 Mar 2012; Robin H. Johnson <robbat2@gentoo.org> +libgpod-0.8.2.ebuild:
+ Verbump.
14 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> libgpod-0.8.0.ebuild:
Remove now obsolete alternative <x11-libs/gtk+-2.22:2 depend for USE="gtk"
diff --git a/media-libs/libgpod/libgpod-0.8.2.ebuild b/media-libs/libgpod/libgpod-0.8.2.ebuild
new file mode 100644
index 000000000000..a750ade01e13
--- /dev/null
+++ b/media-libs/libgpod/libgpod-0.8.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.8.2.ebuild,v 1.1 2012/03/16 19:43:35 robbat2 Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit mono python
+
+DESCRIPTION="Shared library to access the contents of an iPod"
+HOMEPAGE="http://www.gtkpod.org/libgpod/"
+SRC_URI="mirror://sourceforge/gtkpod/libgpod/libgpod-0.8/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk python +udev ios mono static-libs"
+
+RDEPEND=">=app-pda/libplist-1.0
+ >=dev-db/sqlite-3
+ >=dev-libs/glib-2.16:2
+ dev-libs/libxml2
+ sys-apps/sg3_utils
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ ios? ( app-pda/libimobiledevice )
+ python? (
+ >=media-libs/mutagen-1.8
+ >=dev-python/pygobject-2.8:2
+ )
+ udev? ( sys-fs/udev )
+ mono? (
+ >=dev-lang/mono-1.9.1
+ >=dev-dotnet/gtk-sharp-2.12
+ )"
+DEPEND="${RDEPEND}
+ python? ( >=dev-lang/swig-1.3.24 )
+ dev-libs/libxslt
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ >py-compile
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable udev) \
+ $(use_enable gtk gdk-pixbuf) \
+ $(use_enable python pygobject) \
+ --without-hal \
+ $(use_with ios libimobiledevice) \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ $(use_with python) \
+ $(use_with mono)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README* TROUBLESHOOTING
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize gpod
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup gpod
+}