summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-04-06 20:15:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-04-06 20:15:24 +0000
commit6daf0528bd6ca95ec82f94047f336bf614d06933 (patch)
tree7492ceca00dcf4f4f6d2e31b568e2cf11e3c8d98 /media-libs/libfishsound
parentraise gettext dep on gimp (diff)
downloadgentoo-2-6daf0528bd6ca95ec82f94047f336bf614d06933.tar.gz
gentoo-2-6daf0528bd6ca95ec82f94047f336bf614d06933.tar.bz2
gentoo-2-6daf0528bd6ca95ec82f94047f336bf614d06933.zip
version bump with a patch for bug #216499
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'media-libs/libfishsound')
-rw-r--r--media-libs/libfishsound/ChangeLog8
-rw-r--r--media-libs/libfishsound/files/libfishsound-0.9.0-ocert-2008-2.patch11
-rw-r--r--media-libs/libfishsound/libfishsound-0.9.0.ebuild46
3 files changed, 64 insertions, 1 deletions
diff --git a/media-libs/libfishsound/ChangeLog b/media-libs/libfishsound/ChangeLog
index 7e70154af934..12a07288741d 100644
--- a/media-libs/libfishsound/ChangeLog
+++ b/media-libs/libfishsound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libfishsound
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/ChangeLog,v 1.2 2008/01/04 02:53:27 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/ChangeLog,v 1.3 2008/04/06 20:15:23 aballier Exp $
+
+*libfishsound-0.9.0 (06 Apr 2008)
+
+ 06 Apr 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/libfishsound-0.9.0-ocert-2008-2.patch, +libfishsound-0.9.0.ebuild:
+ version bump with a patch for bug #216499
04 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
libfishsound-0.8.1.ebuild:
diff --git a/media-libs/libfishsound/files/libfishsound-0.9.0-ocert-2008-2.patch b/media-libs/libfishsound/files/libfishsound-0.9.0-ocert-2008-2.patch
new file mode 100644
index 000000000000..aff099b483c2
--- /dev/null
+++ b/media-libs/libfishsound/files/libfishsound-0.9.0-ocert-2008-2.patch
@@ -0,0 +1,11 @@
+Index: /libfishsound/trunk/src/libfishsound/speex.c
+===================================================================
+--- /libfishsound/trunk/src/libfishsound/speex.c (revision 1298)
++++ /libfishsound/trunk/src/libfishsound/speex.c (revision 3536)
+@@ -179,5 +179,5 @@
+ }
+
+- if (header->mode >= SPEEX_NB_MODES) {
++ if (header->mode >= SPEEX_NB_MODES || header->mode < 0) {
+ /*
+ info_dialog_new ("Speex error", NULL,
diff --git a/media-libs/libfishsound/libfishsound-0.9.0.ebuild b/media-libs/libfishsound/libfishsound-0.9.0.ebuild
new file mode 100644
index 000000000000..8519b92f365b
--- /dev/null
+++ b/media-libs/libfishsound/libfishsound-0.9.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/libfishsound-0.9.0.ebuild,v 1.1 2008/04/06 20:15:23 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="Simple programming interface for decoding and encoding audio data using Xiph.Org codecs (Vorbis and Speex)"
+HOMEPAGE="http://www.annodex.net/software/libfishsound/html/"
+SRC_URI="http://www.annodex.net/software/libfishsound/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc vorbis"
+
+RDEPEND="vorbis? ( media-libs/libvorbis media-libs/libogg )
+ media-libs/speex"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen virtual/latex-base )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use doc || sed -i -e "s/doxygen/doxygen-dummy/" configure
+ rm -rf "${S}/doc/libfishsound"
+ epatch "${FILESDIR}/${P}-ocert-2008-2.patch"
+}
+
+src_compile() {
+ local myconf
+ use vorbis || myconf="--disable-vorbis"
+ econf $myconf
+
+ emake || die "emake failed"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ cd "${S}/doc/libfishsound/latex"
+ emake refman.ps || die "failed to create refman.ps"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+}