summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-11-27 11:58:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-11-27 11:58:35 +0000
commitc50ae39f1f215cc683e6ce66844a7d6fdd12180a (patch)
tree663d811160e2e5a1bccfba07d972524b0b7b440e /media-libs/ladspa-cmt
parentnone of the DEPEND are RDEPEND so set it empty (diff)
downloadgentoo-2-c50ae39f1f215cc683e6ce66844a7d6fdd12180a.tar.gz
gentoo-2-c50ae39f1f215cc683e6ce66844a7d6fdd12180a.tar.bz2
gentoo-2-c50ae39f1f215cc683e6ce66844a7d6fdd12180a.zip
Respect LDFLAGS, bug #334711, patch by Gavin Pryke
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/ladspa-cmt')
-rw-r--r--media-libs/ladspa-cmt/ChangeLog8
-rw-r--r--media-libs/ladspa-cmt/files/ladspa-cmt-1.16-respect-ldflags.patch14
-rw-r--r--media-libs/ladspa-cmt/ladspa-cmt-1.16-r1.ebuild56
3 files changed, 77 insertions, 1 deletions
diff --git a/media-libs/ladspa-cmt/ChangeLog b/media-libs/ladspa-cmt/ChangeLog
index 7e5cb3ad3a57..a2872849dfaf 100644
--- a/media-libs/ladspa-cmt/ChangeLog
+++ b/media-libs/ladspa-cmt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/ladspa-cmt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-cmt/ChangeLog,v 1.43 2012/11/27 11:55:17 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-cmt/ChangeLog,v 1.44 2012/11/27 11:58:34 aballier Exp $
+
+*ladspa-cmt-1.16-r1 (27 Nov 2012)
+
+ 27 Nov 2012; Alexis Ballier <aballier@gentoo.org> +ladspa-cmt-1.16-r1.ebuild,
+ +files/ladspa-cmt-1.16-respect-ldflags.patch:
+ Respect LDFLAGS, bug #334711, patch by Gavin Pryke
27 Nov 2012; Alexis Ballier <aballier@gentoo.org> ladspa-cmt-1.16.ebuild:
none of the DEPEND are RDEPEND so set it empty
diff --git a/media-libs/ladspa-cmt/files/ladspa-cmt-1.16-respect-ldflags.patch b/media-libs/ladspa-cmt/files/ladspa-cmt-1.16-respect-ldflags.patch
new file mode 100644
index 000000000000..e851c2a781ed
--- /dev/null
+++ b/media-libs/ladspa-cmt/files/ladspa-cmt-1.16-respect-ldflags.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/show_bug.cgi?id=334711
+
+--- cmt/src/makefile.old 2010-09-13 16:43:26.000000000 +0100
++++ cmt/src/makefile 2010-09-13 16:45:08.000000000 +0100
+@@ -66,7 +66,8 @@
+ targets: $(PLUGIN_LIB)
+
+ $(PLUGIN_LIB): $(PLUGIN_OBJECTS)
+- $(CXX) -shared \
++ $(CXX) $(LDFLAGS) \
++ -shared \
+ -o $(PLUGIN_LIB) \
+ $(PLUGIN_OBJECTS)
+
diff --git a/media-libs/ladspa-cmt/ladspa-cmt-1.16-r1.ebuild b/media-libs/ladspa-cmt/ladspa-cmt-1.16-r1.ebuild
new file mode 100644
index 000000000000..0a22b211c2bc
--- /dev/null
+++ b/media-libs/ladspa-cmt/ladspa-cmt-1.16-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-cmt/ladspa-cmt-1.16-r1.ebuild,v 1.1 2012/11/27 11:58:34 aballier Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+IUSE=""
+
+S="${WORKDIR}/cmt/src"
+MY_P="cmt_src_${PV}"
+
+DESCRIPTION="CMT (computer music toolkit) Lasdpa library plugins"
+HOMEPAGE="http://www.ladspa.org/"
+SRC_URI="http://www.ladspa.org/download/${MY_P}.tgz"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+DEPEND="media-libs/ladspa-sdk
+ >=sys-apps/sed-4"
+RDEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "/^CFLAGS/ s/-O3/${CFLAGS}/" \
+ -e 's|/usr/local/include||g' \
+ -e 's|/usr/local/lib||g' makefile \
+ || die "sed makefile failed"
+ sed -i -e "s/^CXXFLAGS*/CXXFLAGS = ${CXXFLAGS} \$(INCLUDES) -Wall -fPIC\n#/" \
+ "${S}/makefile" || die "sed makefile failed (CXXFLAGS)"
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-mallocstdlib.patch"
+ epatch "${FILESDIR}/${P}-respect-ldflags.patch"
+ use userland_Darwin && epatch "${FILESDIR}/${P}-darwin.patch"
+}
+
+src_compile() {
+ tc-export CXX
+ emake || die "emake failed"
+}
+
+src_install() {
+ insinto /usr/share/ladspa/rdf/
+ doins "${FILESDIR}/cmt.rdf"
+
+ insopts -m755
+ insinto /usr/$(get_libdir)/ladspa
+ doins ../plugins/*.so
+
+ dodoc ../README
+ dohtml ../doc/*
+}