summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-28 12:25:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-28 12:25:04 +0000
commit4c93c32608715d48397287341e1049c5755635ae (patch)
tree982d5929b268a339798a7fd74721f8814f2dd170 /media-libs/jpgalleg
parentRemoved old (5.4.0) ebuild (diff)
downloadgentoo-2-4c93c32608715d48397287341e1049c5755635ae.tar.gz
gentoo-2-4c93c32608715d48397287341e1049c5755635ae.tar.bz2
gentoo-2-4c93c32608715d48397287341e1049c5755635ae.zip
old, qa
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/jpgalleg')
-rw-r--r--media-libs/jpgalleg/jpgalleg-1.1-r1.ebuild60
-rw-r--r--media-libs/jpgalleg/jpgalleg-2.5.ebuild32
2 files changed, 12 insertions, 80 deletions
diff --git a/media-libs/jpgalleg/jpgalleg-1.1-r1.ebuild b/media-libs/jpgalleg/jpgalleg-1.1-r1.ebuild
deleted file mode 100644
index fc99f46e6a46..000000000000
--- a/media-libs/jpgalleg/jpgalleg-1.1-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpgalleg/jpgalleg-1.1-r1.ebuild,v 1.5 2004/06/24 23:04:21 agriffis Exp $
-
-inherit eutils
-
-DESCRIPTION="The jpeg loading routines are able to load almost any JPG image file with Allegro."
-HOMEPAGE="http://orbflux.com/jpgalleg/"
-SRC_URI="http://orbflux.com/jpgalleg/${PN}.zip
- http://www.dribin.org/dave/game_launcher/jpgal11b.zip"
-
-LICENSE="GPL-2"
-KEYWORDS="x86"
-SLOT="0"
-IUSE=""
-
-DEPEND=">=media-libs/allegro-4.0.0
- >=app-arch/unzip-5.50
- >=sys-apps/sed-4"
-S="${WORKDIR}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- sed -i \
- -e 's:jpgal11b/::' jpgal11b.pat || \
- die "sed jpgal11b.pat failed"
-
- edos2unix jpgal11b.pat
-
- epatch jpgal11b.pat || die
-
- sed -i \
- -e 's:allegro/aintern.h:allegro/internal/aintern.h:' jpeg.c || \
- die "sed jpeg.c failed"
-
- sed -i \
- -e "s/-O3/${CFLAGS}/" makefile.dj || \
- die "sed makefile.dj failed"
-}
-
-src_compile() {
- emake -f makefile.dj libjpgal.a || die "emake failed"
-}
-
-src_install() {
- cd ${S}/
-
- insinto /usr/include
- doins jpgalleg.h
-
- insinto /usr/lib
- doins libjpgal.a
-
- dodoc README
-
- insinto /usr/share/doc/${P}/examples
- doins *.jpg ex*.c jpeg{data,demo}* makefile*
-}
diff --git a/media-libs/jpgalleg/jpgalleg-2.5.ebuild b/media-libs/jpgalleg/jpgalleg-2.5.ebuild
index c7dbba426af8..ce649fe49672 100644
--- a/media-libs/jpgalleg/jpgalleg-2.5.ebuild
+++ b/media-libs/jpgalleg/jpgalleg-2.5.ebuild
@@ -1,41 +1,33 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpgalleg/jpgalleg-2.5.ebuild,v 1.2 2009/09/22 14:13:42 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpgalleg/jpgalleg-2.5.ebuild,v 1.3 2009/09/28 12:25:04 ssuominen Exp $
-inherit eutils
-
-DESCRIPTION="The jpeg loading routines are able to load almost any JPG image
-file with Allegro."
+DESCRIPTION="The jpeg loading routines are able to load almost any JPG image file with Allegro"
HOMEPAGE="http://www.ecplusplus.com/index.php?page=projects&pid=1"
-SRC_URI="http://www.ecplusplus.com/files/${PN}-${PV}.tar.gz"
+SRC_URI="http://www.ecplusplus.com/files/${P}.tar.gz"
LICENSE="ZLIB"
-KEYWORDS="x86"
SLOT="0"
+KEYWORDS="x86"
IUSE=""
-DEPEND=">=media-libs/allegro-4.0.0"
-S="${WORKDIR}/${PN}-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
+RDEPEND=">=media-libs/allegro-4"
+DEPEND="${RDEPEND}"
src_compile() {
./fix.sh unix --quick
- emake || die "emake failed"
+ emake || die
}
src_install() {
- mkdir ${D}usr
- mkdir ${D}usr/include
- mkdir ${D}usr/lib
+ dodir /usr
+ dodir /usr/include
+ dodir /usr/lib
- emake install INSTALL_BASE_PATH="${D}usr" || die "emake install failed"
+ emake install INSTALL_BASE_PATH="${D}usr" || die
dodoc readme.txt
- insinto /usr/share/doc/${P}/examples
+ insinto /usr/share/doc/${PF}/examples
doins examples/*
}