summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-06-24 22:16:33 +0000
committerSamuli Suominen <drac@gentoo.org>2007-06-24 22:16:33 +0000
commitd382728cafec91599fb9721645707713bdba6244 (patch)
tree0793366bf85b62ed287806700b4a04c597c80e5b /media-libs/imlib
parentarm/s390/sh stable (diff)
downloadgentoo-2-d382728cafec91599fb9721645707713bdba6244.tar.gz
gentoo-2-d382728cafec91599fb9721645707713bdba6244.tar.bz2
gentoo-2-d382728cafec91599fb9721645707713bdba6244.zip
old
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'media-libs/imlib')
-rw-r--r--media-libs/imlib/files/digest-imlib-1.9.14-r33
-rw-r--r--media-libs/imlib/files/imlib-1.9.14-bound.patch372
-rw-r--r--media-libs/imlib/files/imlib-1.9.14-m4.patch15
-rw-r--r--media-libs/imlib/imlib-1.9.14-r3.ebuild54
4 files changed, 0 insertions, 444 deletions
diff --git a/media-libs/imlib/files/digest-imlib-1.9.14-r3 b/media-libs/imlib/files/digest-imlib-1.9.14-r3
deleted file mode 100644
index 8e4091387052..000000000000
--- a/media-libs/imlib/files/digest-imlib-1.9.14-r3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a337643f75bb431034d7213ac74f13dc imlib-1.9.14.tar.bz2 587947
-RMD160 363a9ef22e533b8714dc72ac06a25314860b7c4c imlib-1.9.14.tar.bz2 587947
-SHA256 0bee75cf9e751953156e1b9b82aad27c349269206aa8b27b3c0145dbbc70d4a7 imlib-1.9.14.tar.bz2 587947
diff --git a/media-libs/imlib/files/imlib-1.9.14-bound.patch b/media-libs/imlib/files/imlib-1.9.14-bound.patch
deleted file mode 100644
index d2385e529392..000000000000
--- a/media-libs/imlib/files/imlib-1.9.14-bound.patch
+++ /dev/null
@@ -1,372 +0,0 @@
-diff -uprk.orig imlib-1.9.14.orig/gdk_imlib/io-bmp.c imlib-1.9.14/gdk_imlib/io-bmp.c
---- imlib-1.9.14.orig/gdk_imlib/io-bmp.c 2002-03-04 20:06:29 +0300
-+++ imlib-1.9.14/gdk_imlib/io-bmp.c 2004-09-02 16:36:16 +0400
-@@ -10,7 +10,7 @@ loader_bmp (FILE *file, int *w, int *h,
- linesize, linepos, rshift = 0, gshift = 0, bshift = 0;
- unsigned char byte;
- short int word;
-- long int dbuf[4], dword, rmask = 0, gmask = 0, bmask = 0, offset,
-+ long int dbuf[4], dword, rmask = 0xff, gmask = 0xff, bmask = 0xff, offset,
- size;
- signed char bbuf[4];
- struct _cmap
-@@ -32,7 +32,7 @@ loader_bmp (FILE *file, int *w, int *h,
- * Reading the bmp header
- */
-
-- fread(&bbuf, 1, 2, file);
-+ fread(bbuf, 1, 2, file);
-
- fread(dbuf, 4, 4, file);
-
-@@ -42,12 +42,12 @@ loader_bmp (FILE *file, int *w, int *h,
- fread(dbuf, 4, 2, file);
- *w = (int)dbuf[0];
- *h = (int)dbuf[1];
-- if (*w > 32767)
-+ if ((*w < 0) || (*w > 32767))
- {
- fprintf(stderr, "IMLIB ERROR: Image width > 32767 pixels for file\n");
- return NULL;
- }
-- if (*h > 32767)
-+ if ((*h < 0) || (*h > 32767))
- {
- fprintf(stderr, "IMLIB ERROR: Image height > 32767 pixels for file\n");
- return NULL;
-@@ -72,6 +72,9 @@ loader_bmp (FILE *file, int *w, int *h,
- ncolors = (int)dbuf[0];
- if (ncolors == 0)
- ncolors = 1 << bpp;
-+ if ((ncolors < 0) || (ncolors > (1 << bpp)))
-+ ncolors = 1 << bpp;
-+
- /* some more sanity checks */
- if (((comp == BI_RLE4) && (bpp != 4)) || ((comp == BI_RLE8) && (bpp != 8)) || ((comp == BI_BITFIELDS) && (bpp != 16 && bpp != 32)))
- {
-@@ -197,9 +200,13 @@ loader_bmp (FILE *file, int *w, int *h,
- for (bit = 0; bit < 8; bit++)
- {
- index = ((byte & (0x80 >> bit)) ? 1 : 0);
-- ptr[poffset] = cmap[index].r;
-- ptr[poffset + 1] = cmap[index].g;
-- ptr[poffset + 2] = cmap[index].b;
-+ /* possibly corrupted file? */
-+ if (index < ncolors && poffset < *w * *h * 3)
-+ {
-+ ptr[poffset] = cmap[index].r;
-+ ptr[poffset + 1] = cmap[index].g;
-+ ptr[poffset + 2] = cmap[index].b;
-+ }
- column++;
- }
- }
-@@ -221,9 +228,13 @@ loader_bmp (FILE *file, int *w, int *h,
- index = ((byte & (0xF0 >> nibble * 4)) >> (!nibble * 4));
- if (index >= 16)
- index = 15;
-- ptr[poffset] = cmap[index].r;
-- ptr[poffset + 1] = cmap[index].g;
-- ptr[poffset + 2] = cmap[index].b;
-+ /* possibly corrupted file? */
-+ if (index < ncolors && poffset < *w * *h * 3)
-+ {
-+ ptr[poffset] = cmap[index].r;
-+ ptr[poffset + 1] = cmap[index].g;
-+ ptr[poffset + 2] = cmap[index].b;
-+ }
- column++;
- }
- }
-@@ -263,9 +274,13 @@ loader_bmp (FILE *file, int *w, int *h,
- {
- linepos++;
- byte = getc(file);
-- ptr[poffset] = cmap[byte].r;
-- ptr[poffset + 1] = cmap[byte].g;
-- ptr[poffset + 2] = cmap[byte].b;
-+ /* possibly corrupted file? */
-+ if (byte < ncolors && poffset < *w * *h * 3)
-+ {
-+ ptr[poffset] = cmap[byte].r;
-+ ptr[poffset + 1] = cmap[byte].g;
-+ ptr[poffset + 2] = cmap[byte].b;
-+ }
- column++;
- }
- if (absolute & 0x01)
-@@ -276,9 +291,13 @@ loader_bmp (FILE *file, int *w, int *h,
- {
- for (i = 0; i < first; i++)
- {
-- ptr[poffset] = cmap[byte].r;
-- ptr[poffset + 1] = cmap[byte].g;
-- ptr[poffset + 2] = cmap[byte].b;
-+ /* possibly corrupted file? */
-+ if (byte < ncolors && poffset < *w * *h * 3)
-+ {
-+ ptr[poffset] = cmap[byte].r;
-+ ptr[poffset + 1] = cmap[byte].g;
-+ ptr[poffset + 2] = cmap[byte].b;
-+ }
- column++;
- linepos++;
- }
-@@ -286,20 +305,27 @@ loader_bmp (FILE *file, int *w, int *h,
- }
- else
- {
-- ptr[poffset] = cmap[byte].r;
-- ptr[poffset + 1] = cmap[byte].g;
-- ptr[poffset + 2] = cmap[byte].b;
-+ /* possibly corrupted file? */
-+ if (byte < ncolors && poffset < *w * *h * 3)
-+ {
-+ ptr[poffset] = cmap[byte].r;
-+ ptr[poffset + 1] = cmap[byte].g;
-+ ptr[poffset + 2] = cmap[byte].b;
-+ }
- column++;
-- linepos += size;
- }
- }
- }
- else if (bpp == 24)
- {
-- linepos += fread(&bbuf, 1, 3, file);
-- ptr[poffset] = (unsigned char)bbuf[2];
-- ptr[poffset + 1] = (unsigned char)bbuf[1];
-- ptr[poffset + 2] = (unsigned char)bbuf[0];
-+ linepos += fread(bbuf, 1, 3, file);
-+ /* possibly corrupted file? */
-+ if (poffset < *w * *h * 3)
-+ {
-+ ptr[poffset] = (unsigned char)bbuf[2];
-+ ptr[poffset + 1] = (unsigned char)bbuf[1];
-+ ptr[poffset + 2] = (unsigned char)bbuf[0];
-+ }
- column++;
- }
- else if (bpp == 16)
-@@ -307,12 +333,16 @@ loader_bmp (FILE *file, int *w, int *h,
- unsigned char temp;
-
- linepos += fread(&word, 2, 1, file);
-- temp = (word & rmask) >> rshift;
-- ptr[poffset] = temp;
-- temp = (word & gmask) >> gshift;
-- ptr[poffset + 1] = temp;
-- temp = (word & bmask) >> gshift;
-- ptr[poffset + 2] = temp;
-+ /* possibly corrupted file? */
-+ if (poffset < *w * *h * 3)
-+ {
-+ temp = (word & rmask) >> rshift;
-+ ptr[poffset] = temp;
-+ temp = (word & gmask) >> gshift;
-+ ptr[poffset + 1] = temp;
-+ temp = (word & bmask) >> gshift;
-+ ptr[poffset + 2] = temp;
-+ }
- column++;
- }
- else
-@@ -320,12 +350,16 @@ loader_bmp (FILE *file, int *w, int *h,
- unsigned char temp;
-
- linepos += fread(&dword, 4, 1, file);
-- temp = (dword & rmask) >> rshift;
-- ptr[poffset] = temp;
-- temp = (dword & gmask) >> gshift;
-- ptr[poffset + 1] = temp;
-- temp = (dword & bmask) >> bshift;
-- ptr[poffset + 2] = temp;
-+ /* possibly corrupted file? */
-+ if (poffset < *w * *h * 3)
-+ {
-+ temp = (dword & rmask) >> rshift;
-+ ptr[poffset] = temp;
-+ temp = (dword & gmask) >> gshift;
-+ ptr[poffset + 1] = temp;
-+ temp = (dword & bmask) >> bshift;
-+ ptr[poffset + 2] = temp;
-+ }
- column++;
- }
- }
-diff -uprk.orig imlib-1.9.14.orig/Imlib/load.c imlib-1.9.14/Imlib/load.c
---- imlib-1.9.14.orig/Imlib/load.c 2002-03-22 17:43:04 +0300
-+++ imlib-1.9.14/Imlib/load.c 2004-09-02 16:34:16 +0400
-@@ -631,12 +631,12 @@ _LoadBMP(ImlibData * id, FILE *file, int
- fread(dbuf, 4, 2, file);
- *w = (int)dbuf[0];
- *h = (int)dbuf[1];
-- if (*w > 32767)
-+ if ((*w < 0) || (*w > 32767))
- {
- fprintf(stderr, "IMLIB ERROR: Image width > 32767 pixels for file\n");
- return NULL;
- }
-- if (*h > 32767)
-+ if ((*h < 0) || (*h > 32767))
- {
- fprintf(stderr, "IMLIB ERROR: Image height > 32767 pixels for file\n");
- return NULL;
-@@ -661,6 +661,9 @@ _LoadBMP(ImlibData * id, FILE *file, int
- ncolors = (int)dbuf[0];
- if (ncolors == 0)
- ncolors = 1 << bpp;
-+ if ((ncolors < 0) || (ncolors > (1 << bpp)))
-+ ncolors = 1 << bpp;
-+
- /* some more sanity checks */
- if (((comp == BI_RLE4) && (bpp != 4)) || ((comp == BI_RLE8) && (bpp != 8)) || ((comp == BI_BITFIELDS) && (bpp != 16 && bpp != 32)))
- {
-@@ -786,9 +789,13 @@ _LoadBMP(ImlibData * id, FILE *file, int
- for (bit = 0; bit < 8; bit++)
- {
- index = ((byte & (0x80 >> bit)) ? 1 : 0);
-- ptr[poffset] = cmap[index].r;
-- ptr[poffset + 1] = cmap[index].g;
-- ptr[poffset + 2] = cmap[index].b;
-+ /* possibly corrupted file? */
-+ if (index < ncolors && poffset < *w * *h * 3)
-+ {
-+ ptr[poffset] = cmap[index].r;
-+ ptr[poffset + 1] = cmap[index].g;
-+ ptr[poffset + 2] = cmap[index].b;
-+ }
- column++;
- }
- }
-@@ -810,9 +817,13 @@ _LoadBMP(ImlibData * id, FILE *file, int
- index = ((byte & (0xF0 >> nibble * 4)) >> (!nibble * 4));
- if (index >= 16)
- index = 15;
-- ptr[poffset] = cmap[index].r;
-- ptr[poffset + 1] = cmap[index].g;
-- ptr[poffset + 2] = cmap[index].b;
-+ /* possibly corrupted file? */
-+ if (index < ncolors && poffset < *w * *h * 3)
-+ {
-+ ptr[poffset] = cmap[index].r;
-+ ptr[poffset + 1] = cmap[index].g;
-+ ptr[poffset + 2] = cmap[index].b;
-+ }
- column++;
- }
- }
-@@ -851,9 +862,13 @@ _LoadBMP(ImlibData * id, FILE *file, int
- {
- linepos++;
- byte = getc(file);
-- ptr[poffset] = cmap[byte].r;
-- ptr[poffset + 1] = cmap[byte].g;
-- ptr[poffset + 2] = cmap[byte].b;
-+ /* possibly corrupted file? */
-+ if (byte < ncolors && poffset < *w * *h * 3)
-+ {
-+ ptr[poffset] = cmap[byte].r;
-+ ptr[poffset + 1] = cmap[byte].g;
-+ ptr[poffset + 2] = cmap[byte].b;
-+ }
- column++;
- }
- if (absolute & 0x01)
-@@ -864,9 +879,13 @@ _LoadBMP(ImlibData * id, FILE *file, int
- {
- for (i = 0; i < first; i++)
- {
-- ptr[poffset] = cmap[byte].r;
-- ptr[poffset + 1] = cmap[byte].g;
-- ptr[poffset + 2] = cmap[byte].b;
-+ /* possibly corrupted file? */
-+ if (byte < ncolors && poffset < *w * *h * 3)
-+ {
-+ ptr[poffset] = cmap[byte].r;
-+ ptr[poffset + 1] = cmap[byte].g;
-+ ptr[poffset + 2] = cmap[byte].b;
-+ }
- column++;
- linepos++;
- }
-@@ -874,9 +893,13 @@ _LoadBMP(ImlibData * id, FILE *file, int
- }
- else
- {
-- ptr[poffset] = cmap[byte].r;
-- ptr[poffset + 1] = cmap[byte].g;
-- ptr[poffset + 2] = cmap[byte].b;
-+ /* possibly corrupted file? */
-+ if (byte < ncolors && poffset < *w * *h * 3)
-+ {
-+ ptr[poffset] = cmap[byte].r;
-+ ptr[poffset + 1] = cmap[byte].g;
-+ ptr[poffset + 2] = cmap[byte].b;
-+ }
- column++;
- }
- }
-@@ -884,9 +907,13 @@ _LoadBMP(ImlibData * id, FILE *file, int
- else if (bpp == 24)
- {
- linepos += fread(bbuf, 1, 3, file);
-- ptr[poffset] = (unsigned char)bbuf[2];
-- ptr[poffset + 1] = (unsigned char)bbuf[1];
-- ptr[poffset + 2] = (unsigned char)bbuf[0];
-+ /* possibly corrupted file? */
-+ if (poffset < *w * *h * 3)
-+ {
-+ ptr[poffset] = (unsigned char)bbuf[2];
-+ ptr[poffset + 1] = (unsigned char)bbuf[1];
-+ ptr[poffset + 2] = (unsigned char)bbuf[0];
-+ }
- column++;
- }
- else if (bpp == 16)
-@@ -894,12 +921,16 @@ _LoadBMP(ImlibData * id, FILE *file, int
- unsigned char temp;
-
- linepos += fread(&word, 2, 1, file);
-- temp = (word & rmask) >> rshift;
-- ptr[poffset] = temp;
-- temp = (word & gmask) >> gshift;
-- ptr[poffset + 1] = temp;
-- temp = (word & bmask) >> gshift;
-- ptr[poffset + 2] = temp;
-+ /* possibly corrupted file? */
-+ if (poffset < *w * *h * 3)
-+ {
-+ temp = (word & rmask) >> rshift;
-+ ptr[poffset] = temp;
-+ temp = (word & gmask) >> gshift;
-+ ptr[poffset + 1] = temp;
-+ temp = (word & bmask) >> gshift;
-+ ptr[poffset + 2] = temp;
-+ }
- column++;
- }
- else
-@@ -907,12 +938,16 @@ _LoadBMP(ImlibData * id, FILE *file, int
- unsigned char temp;
-
- linepos += fread(&dword, 4, 1, file);
-- temp = (dword & rmask) >> rshift;
-- ptr[poffset] = temp;
-- temp = (dword & gmask) >> gshift;
-- ptr[poffset + 1] = temp;
-- temp = (dword & bmask) >> bshift;
-- ptr[poffset + 2] = temp;
-+ /* possibly corrupted file? */
-+ if (poffset < *w * *h * 3)
-+ {
-+ temp = (dword & rmask) >> rshift;
-+ ptr[poffset] = temp;
-+ temp = (dword & gmask) >> gshift;
-+ ptr[poffset + 1] = temp;
-+ temp = (dword & bmask) >> bshift;
-+ ptr[poffset + 2] = temp;
-+ }
- column++;
- }
- }
diff --git a/media-libs/imlib/files/imlib-1.9.14-m4.patch b/media-libs/imlib/files/imlib-1.9.14-m4.patch
deleted file mode 100644
index cc7a1baaa03d..000000000000
--- a/media-libs/imlib/files/imlib-1.9.14-m4.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Get rid of aclocal warning:
-/usr/share/aclocal/imlib.m4:9: warning: underquoted definition of AM_PATH_IMLIB
-/usr/share/aclocal/imlib.m4:167: warning: underquoted definition of AM_PATH_GDK_IMLIB
---- imlib-1.9.14/imlib.m4
-+++ imlib-1.9.14/imlib.m4
-@@ -8,3 +8,3 @@
- dnl
--AC_DEFUN(AM_PATH_IMLIB,
-+AC_DEFUN([AM_PATH_IMLIB],
- [dnl
-@@ -166,3 +166,3 @@
- # Check for gdk-imlib
--AC_DEFUN(AM_PATH_GDK_IMLIB,
-+AC_DEFUN([AM_PATH_GDK_IMLIB],
- [dnl
diff --git a/media-libs/imlib/imlib-1.9.14-r3.ebuild b/media-libs/imlib/imlib-1.9.14-r3.ebuild
deleted file mode 100644
index 21d90cab3d5a..000000000000
--- a/media-libs/imlib/imlib-1.9.14-r3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib/imlib-1.9.14-r3.ebuild,v 1.14 2007/02/05 22:06:51 drac Exp $
-
-inherit gnome.org libtool eutils
-
-DESCRIPTION="Image loading and rendering library"
-HOMEPAGE="http://www.enlightenment.org/Libraries/Imlib.html"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="=x11-libs/gtk+-1.2*
- >=media-libs/tiff-3.5.5
- >=media-libs/giflib-4.1.0
- >=media-libs/libpng-1.2.1
- >=media-libs/jpeg-6b"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # fix config script #3425
- sed -i \
- -e "49,51D" \
- -e "55,57D" \
- imlib-config.in
-
- # Security fix per bug #62487
- epatch "${FILESDIR}"/${P}-bound.patch
- #Security fix for bug #72681
- epatch "${FILESDIR}"/${PN}-security.patch
- # shutup aclocal
- epatch "${FILESDIR}"/${P}-m4.patch
-
- elibtoolize
-}
-
-src_compile() {
- econf --sysconfdir=/etc/imlib || die
- emake || die
-}
-
-src_install() {
- einstall \
- includedir="${D}"/usr/include \
- sysconfdir="${D}"/etc/imlib \
- || die
-
- dodoc AUTHORS ChangeLog README NEWS
- dohtml -r doc
-}