summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-12-21 19:56:13 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-12-21 19:56:13 +0000
commit563174d9776a259a501e8408da1159398986cced (patch)
treeb6bc3f77cabc1d037702da4ddbbe050ffaf52632 /media-libs/hamlib
parentVersion bump, replaced numarray by numpy support (diff)
downloadgentoo-2-563174d9776a259a501e8408da1159398986cced.tar.gz
gentoo-2-563174d9776a259a501e8408da1159398986cced.tar.bz2
gentoo-2-563174d9776a259a501e8408da1159398986cced.zip
Drop unneeded .la files
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/ChangeLog7
-rw-r--r--media-libs/hamlib/hamlib-1.2.12-r1.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/media-libs/hamlib/ChangeLog b/media-libs/hamlib/ChangeLog
index 9d7b0e982473..c22f6e41dca7 100644
--- a/media-libs/hamlib/ChangeLog
+++ b/media-libs/hamlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/hamlib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.51 2010/10/10 20:37:11 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.52 2010/12/21 19:56:13 tomjbe Exp $
+
+*hamlib-1.2.12-r1 (21 Dec 2010)
+
+ 21 Dec 2010; Thomas Beierlein <tomjbe@gentoo.org> +hamlib-1.2.12-r1.ebuild:
+ Drop unneeded .la files
10 Oct 2010; Tobias Klausmann <klausman@gentoo.org> hamlib-1.2.11.ebuild:
Stable on alpha, bug #333603
diff --git a/media-libs/hamlib/hamlib-1.2.12-r1.ebuild b/media-libs/hamlib/hamlib-1.2.12-r1.ebuild
new file mode 100644
index 000000000000..8a5e616efc05
--- /dev/null
+++ b/media-libs/hamlib/hamlib-1.2.12-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.12-r1.ebuild,v 1.1 2010/12/21 19:56:13 tomjbe Exp $
+
+PYTHON_DEPEND="2"
+EAPI="2"
+inherit autotools-utils eutils multilib python
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="http://sourceforge.net/apps/mediawiki/hamlib"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ python? ( dev-lang/python )
+ tcl? ( dev-lang/tcl )"
+
+DEPEND=" ${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/swig
+ >=sys-devel/libtool-2.2
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # fix hardcoded libdir paths
+ sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
+ -e "s#fix}/include#fix}/include/hamlib#" \
+ hamlib.pc.in || die "sed failed"
+
+ # fix tcl lib path
+ epatch "${FILESDIR}"/${PN}-1.2.11-bindings.diff
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-rpc-backends \
+ --without-perl-binding \
+ $(use_with python python-binding) \
+ $(use_enable tcl tcl-binding)
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use doc ; then
+ cd doc && make doc || die "make doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ remove_libtool_files all
+
+ dodoc AUTHORS NEWS PLAN README README.betatester \
+ README.developer TODO || die "dodoc failed"
+
+ if use doc; then
+ dohtml doc/html/* || die "dohtml failed"
+ fi
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc || die "doins failed"
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib || die "doenvd failed"
+}