summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-07-30 21:41:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-07-30 21:41:35 +0000
commit25a30e532afad620a926035139fe2c67454b9800 (patch)
treee5f6d59fb91a77c03ed281bafa41cf8ea0765898 /media-libs/glew
parentDon't build demo that fails with newer mesa, bug #428382. (diff)
downloadgentoo-2-25a30e532afad620a926035139fe2c67454b9800.tar.gz
gentoo-2-25a30e532afad620a926035139fe2c67454b9800.tar.bz2
gentoo-2-25a30e532afad620a926035139fe2c67454b9800.zip
Version bump.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/glew')
-rw-r--r--media-libs/glew/ChangeLog7
-rw-r--r--media-libs/glew/glew-1.8.0.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/media-libs/glew/ChangeLog b/media-libs/glew/ChangeLog
index a8cbce194a75..f7edf7b65804 100644
--- a/media-libs/glew/ChangeLog
+++ b/media-libs/glew/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/glew
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/glew/ChangeLog,v 1.78 2012/05/29 13:57:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glew/ChangeLog,v 1.79 2012/07/30 21:41:35 ssuominen Exp $
+
+*glew-1.8.0 (30 Jul 2012)
+
+ 30 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +glew-1.8.0.ebuild:
+ Version bump.
29 May 2012; Alexis Ballier <aballier@gentoo.org> glew-1.7.0.ebuild:
build it the linux way (PIC and so on) on freebsd and keyword ~amd64-fbsd
diff --git a/media-libs/glew/glew-1.8.0.ebuild b/media-libs/glew/glew-1.8.0.ebuild
new file mode 100644
index 000000000000..4fc72007d2ac
--- /dev/null
+++ b/media-libs/glew/glew-1.8.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glew/glew-1.8.0.ebuild,v 1.1 2012/07/30 21:41:35 ssuominen Exp $
+
+EAPI=4
+inherit multilib toolchain-funcs
+
+DESCRIPTION="The OpenGL Extension Wrangler Library"
+HOMEPAGE="http://glew.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs"
+
+RDEPEND="virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu"
+DEPEND=${RDEPEND}
+
+pkg_setup() {
+ myglewopts=(
+ AR="$(tc-getAR)"
+ STRIP=true
+ CC="$(tc-getCC)"
+ LD="$(tc-getCC) ${LDFLAGS}"
+ M_ARCH=""
+ LDFLAGS.EXTRA=""
+ POPT="${CFLAGS}"
+ )
+}
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s:-s::' \
+ -e '/$(CC) $(CFLAGS) -o/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' \
+ Makefile || die
+
+ if ! use static-libs ; then
+ sed -i \
+ -e '/glew.lib:/s|lib/$(LIB.STATIC) ||' \
+ -e '/glew.lib.mx:/s|lib/$(LIB.STATIC.MX) ||' \
+ -e '/INSTALL.*LIB.STATIC/d' \
+ Makefile || die
+ fi
+
+ # don't do stupid Solaris specific stuff that won't work in Prefix
+ cp config/Makefile.linux config/Makefile.solaris || die
+ # and let freebsd be built as on linux too
+ cp config/Makefile.linux config/Makefile.freebsd || die
+}
+
+src_compile(){
+ emake "${myglewopts[@]}"
+}
+
+src_install() {
+ emake \
+ GLEW_DEST="${ED}/usr" \
+ LIBDIR="${ED}/usr/$(get_libdir)" \
+ "${myglewopts[@]}" \
+ install.all
+
+ dodoc TODO.txt
+ use doc && dohtml doc/*
+}