summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-04 13:17:52 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-04 13:17:52 +0000
commit3c0416b32681c94ca3e2c5c5e7ea4e0b29de6770 (patch)
tree5aeab018fddb570312bba6f5e0c12bd2d0622b48 /media-libs/gegl
parentdev-python/python-twitter: added comment about tests (diff)
downloadgentoo-2-3c0416b32681c94ca3e2c5c5e7ea4e0b29de6770.tar.gz
gentoo-2-3c0416b32681c94ca3e2c5c5e7ea4e0b29de6770.tar.bz2
gentoo-2-3c0416b32681c94ca3e2c5c5e7ea4e0b29de6770.zip
Update the gegl ffmpeg patch to be more correct.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gegl')
-rw-r--r--media-libs/gegl/ChangeLog6
-rw-r--r--media-libs/gegl/files/0.1.6-ffmpeg.patch63
2 files changed, 38 insertions, 31 deletions
diff --git a/media-libs/gegl/ChangeLog b/media-libs/gegl/ChangeLog
index 94eb63bf8e14..1c659d924ee5 100644
--- a/media-libs/gegl/ChangeLog
+++ b/media-libs/gegl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/gegl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/ChangeLog,v 1.52 2011/05/01 16:22:03 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/ChangeLog,v 1.53 2011/05/04 13:17:52 scarabeus Exp $
+
+ 04 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ files/0.1.6-ffmpeg.patch:
+ Update the gegl ffmpeg patch to be more correct.
01 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+files/0.1.6-ffmpeg.patch, gegl-0.1.6.ebuild:
diff --git a/media-libs/gegl/files/0.1.6-ffmpeg.patch b/media-libs/gegl/files/0.1.6-ffmpeg.patch
index 98169c721b0c..66730f286dc9 100644
--- a/media-libs/gegl/files/0.1.6-ffmpeg.patch
+++ b/media-libs/gegl/files/0.1.6-ffmpeg.patch
@@ -1,30 +1,33 @@
-diff -urN gegl-0.1.6.old/operations/external/ff-load.c gegl-0.1.6/operations/external/ff-load.c
---- gegl-0.1.6.old/operations/external/ff-load.c 2011-05-01 18:10:42.000000000 +0200
-+++ gegl-0.1.6/operations/external/ff-load.c 2011-05-01 18:15:58.000000000 +0200
-@@ -69,7 +69,7 @@
- {
- switch (err)
- {
-- case AVERROR_NUMEXPECTED:
-+ case AVERROR(EINVAL):
- g_warning ("%s: Incorrect image filename syntax.\n"
- "Use '%%d' to specify the image number:\n"
- " for img1.jpg, img2.jpg, ..., use 'img%%d.jpg';\n"
-@@ -79,7 +79,7 @@
- case AVERROR_INVALIDDATA:
- g_warning ("%s: Error while parsing header\n", filename);
- break;
-- case AVERROR_NOFMT:
-+ case AVERROR(EILSEQ):
- g_warning ("%s: Unknown format\n", filename);
- break;
- default:
-@@ -278,7 +278,7 @@
- for (i = 0; i< p->ic->nb_streams; i++)
- {
- AVCodecContext *c = p->ic->streams[i]->codec;
-- if (c->codec_type == CODEC_TYPE_VIDEO)
-+ if (c->codec_type == AVMEDIA_TYPE_VIDEO)
- {
- p->video_st = p->ic->streams[i];
- p->video_stream = i;
+diff -urN gegl-0.1.6.old//operations/external/ff-load.c gegl-0.1.6/operations/external/ff-load.c
+--- gegl-0.1.6.old//operations/external/ff-load.c 2011-01-24 19:03:30.000000000 -0300
++++ gegl-0.1.6/operations/external/ff-load.c 2011-05-04 09:59:48.910379742 -0300
+@@ -69,17 +69,17 @@
+ {
+ switch (err)
+ {
+- case AVERROR_NUMEXPECTED:
++ case AVERROR(EDOM):
+ g_warning ("%s: Incorrect image filename syntax.\n"
+ "Use '%%d' to specify the image number:\n"
+ " for img1.jpg, img2.jpg, ..., use 'img%%d.jpg';\n"
+ " for img001.jpg, img002.jpg, ..., use 'img%%03d.jpg'.\n",
+ filename);
+ break;
+- case AVERROR_INVALIDDATA:
++ case AVERROR(EINVAL):
+ g_warning ("%s: Error while parsing header\n", filename);
+ break;
+- case AVERROR_NOFMT:
++ case AVERROR(EILSEQ):
+ g_warning ("%s: Unknown format\n", filename);
+ break;
+ default:
+@@ -278,7 +278,7 @@
+ for (i = 0; i< p->ic->nb_streams; i++)
+ {
+ AVCodecContext *c = p->ic->streams[i]->codec;
+- if (c->codec_type == CODEC_TYPE_VIDEO)
++ if (c->codec_type == AVMEDIA_TYPE_VIDEO)
+ {
+ p->video_st = p->ic->streams[i];
+ p->video_stream = i;