summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-07-29 12:40:34 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-07-29 12:40:34 +0000
commitb4e53034e960eeece8cd040a653dc8f34b822d1a (patch)
tree71454d5008f2d776062e748721ce27ec62ab58a4 /media-libs/gdk-pixbuf
parentmoved to media-gfx, doesn't depend on GNOME, it will however install an icon ... (diff)
downloadgentoo-2-b4e53034e960eeece8cd040a653dc8f34b822d1a.tar.gz
gentoo-2-b4e53034e960eeece8cd040a653dc8f34b822d1a.tar.bz2
gentoo-2-b4e53034e960eeece8cd040a653dc8f34b822d1a.zip
fixed a mistake of mine
Diffstat (limited to 'media-libs/gdk-pixbuf')
-rw-r--r--media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild b/media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild
index d1a071dde4ee..e0c5ff96d4d7 100644
--- a/media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild
+++ b/media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild,v 1.3 2001/07/29 11:22:36 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild,v 1.4 2001/07/29 12:40:34 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,24 +11,24 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/"${A}
DEPEND=">=x11-libs/gtk+-1.2.0
gnome? ( >=gnome-base/gnome-libs-1.2.13 )"
+myprefix=
+mysysconfdir=
+
+if [ "`use gnome`" ] ; then
+ myprefix=/opt/gnome
+ mysysconfdir=/etc/opt/gnome
+else
+ myprefix=/usr/X11R6
+ mysysconfdir=/etc/X11/gdk-pixbuf
+fi
+
src_compile() {
- local myprefix
- local mysysconfdir
- if [ "`use gnome`" ] ; then
- myprefix=/opt/gnome
- mysysconfdir=/etc/opt/gnome
- else
- myprefix=/usr/X11R6
- mysysconfdir=/etc/X11/gdk-pixbuf
- fi
-
try ./configure --host=${CHOST} --prefix=${myprefix} --sysconfdir=${mysysconfdir}
try pmake
}
src_install() {
-
try make prefix=${D}${myprefix} sysconfdir=${D}${mysysconfdir} install
dodoc AUTHORS COPYING* ChangeLog INSTALL README NEWS TODO
}