summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-08 09:42:44 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-08 09:42:44 +0000
commitf6fd7006ecb36bb827e5f2cce3e08879b065b660 (patch)
treef8001d417fd687f580ffb3c52458fb5ee6453f7a /media-libs/gd
parentFix libpng14 detection wrt #305117 by Lars Wendler. (diff)
downloadgentoo-2-f6fd7006ecb36bb827e5f2cce3e08879b065b660.tar.gz
gentoo-2-f6fd7006ecb36bb827e5f2cce3e08879b065b660.tar.bz2
gentoo-2-f6fd7006ecb36bb827e5f2cce3e08879b065b660.zip
Fix building with libpng14 wrt #305101 by Lars Wendler.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gd')
-rw-r--r--media-libs/gd/ChangeLog8
-rw-r--r--media-libs/gd/files/gd-2.0.35-libpng14.patch14
-rw-r--r--media-libs/gd/gd-2.0.35-r1.ebuild8
3 files changed, 26 insertions, 4 deletions
diff --git a/media-libs/gd/ChangeLog b/media-libs/gd/ChangeLog
index 92bb5f58efbf..caded3be24c5 100644
--- a/media-libs/gd/ChangeLog
+++ b/media-libs/gd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/gd
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/ChangeLog,v 1.61 2009/11/21 20:08:13 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/ChangeLog,v 1.62 2010/03/08 09:42:43 ssuominen Exp $
+
+ 08 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> gd-2.0.35-r1.ebuild,
+ +files/gd-2.0.35-libpng14.patch:
+ Fix building with libpng14 wrt #305101 by Lars Wendler.
21 Nov 2009; nixnut <nixnut@gentoo.org> gd-2.0.35-r1.ebuild:
ppc stable #292130
diff --git a/media-libs/gd/files/gd-2.0.35-libpng14.patch b/media-libs/gd/files/gd-2.0.35-libpng14.patch
new file mode 100644
index 000000000000..98b6461267d9
--- /dev/null
+++ b/media-libs/gd/files/gd-2.0.35-libpng14.patch
@@ -0,0 +1,14 @@
+http://bugs.gentoo.org/show_bug.cgi?id=305101
+http://repos.archlinux.org/wsvn/packages/gd/trunk/libpng14.patch
+
+--- gd_png.c
++++ gd_png.c
+@@ -149,7 +149,7 @@
+ return NULL;
+ }
+
+- if (!png_check_sig (sig, 8)) { /* bad signature */
++ if (png_sig_cmp (sig, 0, 8)) { /* bad signature */
+ return NULL; /* bad signature */
+ }
+
diff --git a/media-libs/gd/gd-2.0.35-r1.ebuild b/media-libs/gd/gd-2.0.35-r1.ebuild
index c1f14276f921..866924b1f3e9 100644
--- a/media-libs/gd/gd-2.0.35-r1.ebuild
+++ b/media-libs/gd/gd-2.0.35-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/gd-2.0.35-r1.ebuild,v 1.7 2009/11/21 20:08:13 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/gd-2.0.35-r1.ebuild,v 1.8 2010/03/08 09:42:43 ssuominen Exp $
inherit autotools
@@ -23,6 +23,10 @@ DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
+
+ has_version ">=media-libs/libpng-1.4" && epatch \
+ "${FILESDIR}"/${P}-libpng14.patch
+
epatch "${FILESDIR}"/${P}-maxcolors.patch
eautoconf
find . -type f -print0 | xargs -0 touch -r configure