summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-21 22:06:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-21 22:06:39 +0000
commit864e7f3a9602c39039561872133c498bb5b153e1 (patch)
tree8a6d66d60b215cc71fa9e4bcafdbed9da968a793 /media-libs/fmod
parentForgot properties interative. (diff)
downloadgentoo-2-864e7f3a9602c39039561872133c498bb5b153e1.tar.gz
gentoo-2-864e7f3a9602c39039561872133c498bb5b153e1.tar.bz2
gentoo-2-864e7f3a9602c39039561872133c498bb5b153e1.zip
Version bump to latest development.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/fmod')
-rw-r--r--media-libs/fmod/ChangeLog7
-rw-r--r--media-libs/fmod/fmod-4.25.07.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/media-libs/fmod/ChangeLog b/media-libs/fmod/ChangeLog
index f6261ef46802..3fbcceb15bfa 100644
--- a/media-libs/fmod/ChangeLog
+++ b/media-libs/fmod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/fmod
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fmod/ChangeLog,v 1.28 2009/05/21 21:21:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fmod/ChangeLog,v 1.29 2009/05/21 22:06:39 ssuominen Exp $
+
+*fmod-4.25.07 (21 May 2009)
+
+ 21 May 2009; Samuli Suominen <ssuominen@gentoo.org> +fmod-4.25.07.ebuild:
+ Version bump to latest development.
*fmod-4.24.07 (21 May 2009)
diff --git a/media-libs/fmod/fmod-4.25.07.ebuild b/media-libs/fmod/fmod-4.25.07.ebuild
new file mode 100644
index 000000000000..4f2c0067cc80
--- /dev/null
+++ b/media-libs/fmod/fmod-4.25.07.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fmod/fmod-4.25.07.ebuild,v 1.1 2009/05/21 22:06:39 ssuominen Exp $
+
+inherit versionator
+
+MY_P=fmodapi$(delete_all_version_separators)linux
+
+DESCRIPTION="music and sound effects library, and a sound processing system"
+HOMEPAGE="http://www.fmod.org"
+SRC_URI="x86? ( http://www.fmod.org/index.php/release/version/${MY_P}.tar.gz )
+ multilib? ( http://www.fmod.org/index.php/release/version/${MY_P}.tar.gz )
+ amd64? ( http://www.fmod.org/index.php/release/version/${MY_P}64.tar.gz )"
+
+LICENSE="fmod"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+RESTRICT="strip test"
+
+if use amd64; then
+ S=${WORKDIR}/${MY_P}64
+else
+ S=${WORKDIR}/${MY_P}
+fi
+
+src_compile() { :; }
+
+src_install() {
+ dodir /opt/${MY_P}
+
+ cd "${S}"/api/lib
+
+ if use amd64; then
+ cp -f libfmodex64-${PV}.so libfmodex.so.${PV}
+ cp -f libfmodexp64-${PV}.so libfmodexp.so.${PV}
+ fi
+ if use x86; then
+ cp -f libfmodex-${PV}.so libfmodex.so.${PV}
+ cp -f libfmodexp-${PV}.so libfmodexp.so.${PV}
+ fi
+
+ ln -sf libfmodex.so.${PV} libfmodex.so
+ ln -sf libfmodex.so.${PV} libfmodex.so.4
+ ln -sf libfmodexp.so.${PV} libfmodexp.so
+ ln -sf libfmodexp.so.${PV} libfmodexp.so.4
+
+ cp -dpR "${S}"/* "${D}"/opt/${MY_P}
+
+ dosym /opt/${MY_P}/api/inc /usr/include/fmodex
+
+ insinto /usr/share/doc/${PF}
+ doins "${S}"/documentation/*.pdf
+ dodoc "${S}"/documentation/*.txt
+
+ rm -rf "${D}"/opt/${MY_P}/documentation
+
+ echo LDPATH="/opt/${MY_P}/api/lib" > "${T}"/65${MY_P}
+ doenvd "${T}"/65${MY_P}
+}