summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-09-27 22:16:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-09-27 22:16:22 +0000
commit02f09f577be9941f45b2bc7ac0d34093737f6da9 (patch)
treeb2177bba54ef041eabec5c5e1544d6380fcb3592 /media-libs/flac
parentVersion bump (diff)
downloadgentoo-2-02f09f577be9941f45b2bc7ac0d34093737f6da9.tar.gz
gentoo-2-02f09f577be9941f45b2bc7ac0d34093737f6da9.tar.bz2
gentoo-2-02f09f577be9941f45b2bc7ac0d34093737f6da9.zip
Apply upstream patch wrt #512432 by Jason Miller
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/flac')
-rw-r--r--media-libs/flac/ChangeLog8
-rw-r--r--media-libs/flac/files/flac-1.3.0-metaflac_strcat.patch15
-rw-r--r--media-libs/flac/flac-1.3.0-r1.ebuild66
3 files changed, 88 insertions, 1 deletions
diff --git a/media-libs/flac/ChangeLog b/media-libs/flac/ChangeLog
index cb8a4b9e5997..fa774816375d 100644
--- a/media-libs/flac/ChangeLog
+++ b/media-libs/flac/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/flac
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/ChangeLog,v 1.178 2014/06/18 19:27:19 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/ChangeLog,v 1.179 2014/09/27 22:16:21 ssuominen Exp $
+
+*flac-1.3.0-r1 (27 Sep 2014)
+
+ 27 Sep 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +files/flac-1.3.0-metaflac_strcat.patch, +flac-1.3.0-r1.ebuild:
+ Apply upstream patch wrt #512432 by Jason Miller
18 Jun 2014; Michał Górny <mgorny@gentoo.org> flac-1.2.1-r5.ebuild,
flac-1.3.0.ebuild:
diff --git a/media-libs/flac/files/flac-1.3.0-metaflac_strcat.patch b/media-libs/flac/files/flac-1.3.0-metaflac_strcat.patch
new file mode 100644
index 000000000000..848130173cb6
--- /dev/null
+++ b/media-libs/flac/files/flac-1.3.0-metaflac_strcat.patch
@@ -0,0 +1,15 @@
+From upstream:
+
+http://git.xiph.org/?p=flac.git;a=commit;h=606fdfcaece19d3e05434bde57c289102a369069
+
+--- src/metaflac/utils.c
++++ src/metaflac/utils.c
+@@ -75,7 +75,7 @@ void local_strcat(char **dest, const char *source)
+ *dest = safe_realloc_add_3op_(*dest, ndest, /*+*/nsource, /*+*/1);
+ if(0 == *dest)
+ die("out of memory growing string");
+- safe_strncpy((*dest)+ndest, source, ndest + nsource + 1);
++ safe_strncpy((*dest)+ndest, source, nsource + 1);
+ }
+
+ static inline int local_isprint(int c)
diff --git a/media-libs/flac/flac-1.3.0-r1.ebuild b/media-libs/flac/flac-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..7222ac3dea47
--- /dev/null
+++ b/media-libs/flac/flac-1.3.0-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.3.0-r1.ebuild,v 1.1 2014/09/27 22:16:21 ssuominen Exp $
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+inherit autotools-multilib
+
+DESCRIPTION="free lossless audio encoder and decoder"
+HOMEPAGE="http://flac.sourceforge.net"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.xz"
+
+LICENSE="BSD FDL-1.2 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="3dnow altivec +cxx debug ogg sse static-libs"
+
+RDEPEND="ogg? ( >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ abi_x86_32? ( dev-lang/nasm )
+ !elibc_uclibc? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${P}-asneeded.patch
+ "${FILESDIR}"/${P}-dontbuild-tests.patch
+ "${FILESDIR}"/${P}-dontbuild-examples.patch
+ "${FILESDIR}"/${P}-metaflac_strcat.patch
+ )
+
+ AT_M4DIR="m4" autotools-multilib_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable sse)
+ $(use_enable 3dnow)
+ $(use_enable altivec)
+ --disable-doxygen-docs
+ --disable-xmms-plugin
+ $(use_enable cxx cpplibs)
+ $(use_enable ogg)
+ --disable-examples
+ )
+ autotools-multilib_src_configure
+}
+
+src_test() {
+ if [[ ${UID} != 0 ]]; then
+ autotools-multilib_src_test -j1
+ else
+ ewarn "Tests will fail if ran as root, skipping."
+ fi
+}
+
+src_install() {
+ autotools-multilib_src_install \
+ docdir=/usr/share/doc/${PF}/html
+}