summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-12-17 23:26:40 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-12-17 23:26:40 +0000
commit9b0fbac3e77ca42ec222f17468736da8144ca76e (patch)
tree2a54a7d567092c28f3f588d4bf3f49a90d9ef37e /media-libs/avidemux-core
parentVersion bump. (diff)
downloadgentoo-2-9b0fbac3e77ca42ec222f17468736da8144ca76e.tar.gz
gentoo-2-9b0fbac3e77ca42ec222f17468736da8144ca76e.tar.bz2
gentoo-2-9b0fbac3e77ca42ec222f17468736da8144ca76e.zip
Version bump to 2.6.7, fixes bug #493730.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-libs/avidemux-core')
-rw-r--r--media-libs/avidemux-core/ChangeLog8
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.6.7.ebuild108
-rw-r--r--media-libs/avidemux-core/avidemux-core-9999.ebuild4
3 files changed, 117 insertions, 3 deletions
diff --git a/media-libs/avidemux-core/ChangeLog b/media-libs/avidemux-core/ChangeLog
index 9b7b54450fb8..b310cd86e4ca 100644
--- a/media-libs/avidemux-core/ChangeLog
+++ b/media-libs/avidemux-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/avidemux-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/ChangeLog,v 1.15 2013/09/01 11:53:12 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/ChangeLog,v 1.16 2013/12/17 23:26:40 tomwij Exp $
+
+*avidemux-core-2.6.7 (17 Dec 2013)
+
+ 17 Dec 2013; Tom Wijsman <TomWij@gentoo.org> +avidemux-core-2.6.7.ebuild,
+ avidemux-core-9999.ebuild:
+ Version bump to 2.6.7, fixes bug #493730.
*avidemux-core-2.6.5 (01 Sep 2013)
diff --git a/media-libs/avidemux-core/avidemux-core-2.6.7.ebuild b/media-libs/avidemux-core/avidemux-core-2.6.7.ebuild
new file mode 100644
index 000000000000..bd6be6861857
--- /dev/null
+++ b/media-libs/avidemux-core/avidemux-core-2.6.7.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/avidemux-core-2.6.7.ebuild,v 1.1 2013/12/17 23:26:40 tomwij Exp $
+
+EAPI="5"
+
+inherit cmake-utils eutils flag-o-matic
+
+SLOT="2.6"
+
+DESCRIPTION="Core libraries for a video editor designed for simple cutting, filtering and encoding tasks."
+HOMEPAGE="http://fixounet.free.fr/avidemux"
+
+# Multiple licenses because of all the bundled stuff.
+LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
+IUSE="debug nls sdl system-ffmpeg vaapi vdpau video_cards_fglrx xv"
+KEYWORDS="~amd64 ~x86"
+
+MY_PN="${PN/-core/}"
+if [[ ${PV} == *9999* ]] ; then
+ KEYWORDS=""
+ EGIT_REPO_URI="git://gitorious.org/${MY_PN}2-6/${MY_PN}2-6.git https://git.gitorious.org/${MY_PN}2-6/${MY_PN}2-6.git"
+
+ inherit git-2
+else
+ MY_P="${MY_PN}_${PV}"
+ SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
+fi
+
+# Trying to use virtual; ffmpeg misses aac,cpudetection USE flags now though, are they needed?
+DEPEND="
+ !<media-video/avidemux-${PV}:${SLOT}
+ dev-db/sqlite:3
+ nls? ( sys-devel/gettext:0 )
+ sdl? ( media-libs/libsdl:0 )
+ system-ffmpeg? ( >=virtual/ffmpeg-9:0[mp3,theora] )
+ xv? ( x11-libs/libXv:0 )
+ vaapi? ( x11-libs/libva:0 )
+ vdpau? ( x11-libs/libvdpau:0 )
+ video_cards_fglrx? ( x11-libs/xvba-video:0 )
+"
+RDEPEND="
+ $DEPEND
+"
+DEPEND="
+ $DEPEND
+ virtual/pkgconfig:0
+ !system-ffmpeg? ( dev-lang/yasm:0[nls=] )
+"
+
+S="${WORKDIR}/${MY_P}"
+BUILD_DIR="${S}/buildCore"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ mkdir "${BUILD_DIR}" || die "Can't create build folder."
+
+ cmake-utils_src_prepare
+
+ if use system-ffmpeg ; then
+ # Preparations to support the system ffmpeg. Currently fails because it depends on files the system ffmpeg doesn't install.
+ local error="Failed to remove ffmpeg."
+
+ rm -rf cmake/admFFmpeg* cmake/ffmpeg* avidemux_core/ffmpeg_package buildCore/ffmpeg || die "${error}"
+ sed -i -e 's/include(admFFmpegUtil)//g' avidemux/commonCmakeApplication.cmake || die "${error}"
+ sed -i -e '/registerFFmpeg/d' avidemux/commonCmakeApplication.cmake || die "${error}"
+ sed -i -e 's/include(admFFmpegBuild)//g' avidemux_core/CMakeLists.txt || die "${error}"
+ else
+ # Avoid existing avidemux installations from making the build process fail, bug #461496.
+ sed -i -e "s:getFfmpegLibNames(\"\${sourceDir}\"):getFfmpegLibNames(\"${S}/buildCore/ffmpeg/source/\"):g" cmake/admFFmpegUtil.cmake \
+ || die "Failed to avoid existing avidemux installation from making the build fail."
+ fi
+
+ # Add lax vector typing for PowerPC.
+ if use ppc || use ppc64 ; then
+ append-cflags -flax-vector-conversions
+ fi
+
+ # See bug 432322.
+ use x86 && replace-flags -O0 -O1
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DAVIDEMUX_SOURCE_DIR='${S}'
+ $(cmake-utils_use nls GETTEXT)
+ $(cmake-utils_use sdl SDL)
+ $(cmake-utils_use vaapi LIBVA)
+ $(cmake-utils_use vdpau VDPAU)
+ $(cmake-utils_use video_cards_fglrx XVBA)
+ $(cmake-utils_use xv XVIDEO)
+ "
+
+ if use debug ; then
+ mycmakeargs+=" -DVERBOSE=1 -DCMAKE_BUILD_TYPE=Debug -DADM_DEBUG=1"
+ fi
+
+ CMAKE_USE_DIR="${S}"/avidemux_core cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile -j1
+}
+
+src_install() {
+ cmake-utils_src_install -j1
+}
diff --git a/media-libs/avidemux-core/avidemux-core-9999.ebuild b/media-libs/avidemux-core/avidemux-core-9999.ebuild
index 3d29e08d2ce5..d851a490d4b0 100644
--- a/media-libs/avidemux-core/avidemux-core-9999.ebuild
+++ b/media-libs/avidemux-core/avidemux-core-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/avidemux-core-9999.ebuild,v 1.3 2013/08/31 09:29:52 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/avidemux-core-9999.ebuild,v 1.4 2013/12/17 23:26:40 tomwij Exp $
EAPI="5"
@@ -24,7 +24,7 @@ if [[ ${PV} == *9999* ]] ; then
inherit git-2
else
MY_P="${MY_PN}_${PV}"
- SRC_URI="mirror://sourceforge/${MY_PN}/${PV}/${MY_P}.tar.gz"
+ SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
fi
# Trying to use virtual; ffmpeg misses aac,cpudetection USE flags now though, are they needed?