summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Stadler <centic@gentoo.org>2007-06-01 06:49:17 +0000
committerDominik Stadler <centic@gentoo.org>2007-06-01 06:49:17 +0000
commitfed47dcfbb4dd3bebcf95a861b1689fbefc48b78 (patch)
tree040753861753e070a2bba65f268b2519e9a14367 /media-gfx
parentStable on amd64 for bug #180021. (diff)
downloadgentoo-2-fed47dcfbb4dd3bebcf95a861b1689fbefc48b78.tar.gz
gentoo-2-fed47dcfbb4dd3bebcf95a861b1689fbefc48b78.tar.bz2
gentoo-2-fed47dcfbb4dd3bebcf95a861b1689fbefc48b78.zip
Version bump to 1.29, fixes Bug 178464, thanks to Gerhard D and Neil Alldrin for providing the updated ebuilds.
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/asymptote/ChangeLog10
-rw-r--r--media-gfx/asymptote/asymptote-1.29.ebuild128
-rw-r--r--media-gfx/asymptote/files/asymptote-1.29-configure-ac.patch37
-rw-r--r--media-gfx/asymptote/files/asymptote-1.29-makefile.patch63
-rw-r--r--media-gfx/asymptote/files/digest-asymptote-1.293
5 files changed, 240 insertions, 1 deletions
diff --git a/media-gfx/asymptote/ChangeLog b/media-gfx/asymptote/ChangeLog
index 1f8c76806f65..6511d08f4be1 100644
--- a/media-gfx/asymptote/ChangeLog
+++ b/media-gfx/asymptote/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/asymptote
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/ChangeLog,v 1.8 2007/04/30 21:14:19 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/ChangeLog,v 1.9 2007/06/01 06:49:17 centic Exp $
+
+*asymptote-1.29 (01 Jun 2007)
+
+ 01 Jun 2007; <dstadler@gentoo.org>
+ +files/asymptote-1.29-configure-ac.patch,
+ +files/asymptote-1.29-makefile.patch, +asymptote-1.29.ebuild:
+ Version bump to 1.29, fixes Bug 178464, thanks to Gerhard D and Neil Alldrin
+ for providing the updated ebuilds
30 Apr 2007; Marius Mauch <genone@gentoo.org> asymptote-1.20.ebuild,
asymptote-1.21.ebuild, asymptote-1.26.ebuild:
diff --git a/media-gfx/asymptote/asymptote-1.29.ebuild b/media-gfx/asymptote/asymptote-1.29.ebuild
new file mode 100644
index 000000000000..4fd3a03df2c7
--- /dev/null
+++ b/media-gfx/asymptote/asymptote-1.29.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/asymptote-1.29.ebuild,v 1.1 2007/06/01 06:49:17 centic Exp $
+
+inherit eutils elisp-common
+
+DESCRIPTION="A vector graphics language that provides a framework for technical drawing"
+HOMEPAGE="http://asymptote.sourceforge.net"
+SRC_URI="mirror://sourceforge/asymptote/${P}.src.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="boehm-gc doc fftw emacs gsl vim-syntax"
+
+RDEPEND=">=sys-libs/readline-4.3-r5
+ >=sys-libs/ncurses-5.4-r5
+ dev-libs/libsigsegv
+ boehm-gc? ( >=dev-libs/boehm-gc-6.7 )
+ virtual/tetex
+ fftw? ( >=sci-libs/fftw-3.0.1 )
+ emacs? ( virtual/emacs )
+ gsl? ( sci-libs/gsl )
+ vim-syntax? ( app-editors/vim )"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.5
+ >=sys-devel/bison-1.875
+ >=sys-devel/flex-2.5.4a-r5
+ doc? ( >=media-gfx/imagemagick-6.1.3.2
+ virtual/ghostscript
+ >=sys-apps/texinfo-4.7-r1 )"
+
+pkg_setup() {
+ # checking if Boehm garbage collector was compiled with c++ support
+ if use boehm-gc ; then
+ if ! built_with_use dev-libs/boehm-gc nocxx ; then
+ einfo "dev-libs/boehm-gc has been compiled with nocxx use flag disabled"
+ else
+ echo
+ eerror "You have to rebuild dev-libs/boehm-gc enabling c++ support"
+ die
+ fi
+ fi
+
+ if ! built_with_use dev-lang/python tk; then
+ eerror "Please reemerge dev-lang/python with 'tk' support or xasy will"
+ eerror "not work. In order to fix this, execute the following:"
+ eerror "echo \"dev-lang/python tk\" >> /etc/portage/package.use"
+ eerror "and reemerge dev-lang/python before emerging asymptote."
+ die "requires dev-lang/python with use-flag 'tk'!!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Fixing fftw and gsl enabling
+ epatch ${FILESDIR}/${P}-configure-ac.patch
+ einfo "Patching configure.ac"
+ sed -i \
+ -e "s:Datadir/doc/asymptote:Datadir/doc/${PF}:" \
+ configure.ac || die "sed configure.ac failed"
+
+ einfo "Building configure"
+ WANT_AUTOCONF=2.5 autoconf
+
+ epatch ${FILESDIR}/${P}-makefile.patch
+}
+
+src_compile() {
+ for dir in `find /var/cache/fonts -type d`; do addwrite ${dir}; done
+
+ # for the CPPFLAGS see http://sourceforge.net/forum/forum.php?thread_id=1683277&forum_id=409349
+ myconf="--with-latex=/usr/share/texmf/tex/latex --disable-gc-debug CPPFLAGS=-DHAVE_SYS_TYPES_H"
+ if use boehm-gc; then
+ myconf="${myconf} --enable-gc=system"
+ else
+ myconf="${myconf} --disable-gc"
+ fi
+
+ econf ${myconf} $(use_with fftw) $(use_with gsl) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ for dir in `find /var/cache/fonts -type d`; do addwrite ${dir}; done
+
+ if use doc; then
+ target="install-all"
+ else
+ target="install"
+ fi
+
+ make DESTDIR=${D} ${target} || die "make install failed"
+
+ dodoc BUGS ChangeLog README ReleaseNotes TODO
+
+ if use emacs ; then
+ elisp-site-file-install base/asy-mode.el
+ elisp-site-file-install base/asy-keywords.el
+ elisp-site-file-install "${FILESDIR}"/64asy-gentoo.el
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins base/asy.vim
+ fi
+}
+
+pkg_postinst() {
+ einfo 'Updating TeX tree...'
+ texhash &> /dev/null
+
+ elog 'Use the variable ASYMPTOTE_PSVIEWER to set the postscript viewer'
+ elog 'Use the variable ASYMPTOTE_PDFVIEWER to set the PDF viewer'
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ einfo 'Updating TeX tree...'
+ texhash &> /dev/null
+
+ [ -f "${SITELISP}"/site-gentoo.el ] && elisp-site-regen
+}
diff --git a/media-gfx/asymptote/files/asymptote-1.29-configure-ac.patch b/media-gfx/asymptote/files/asymptote-1.29-configure-ac.patch
new file mode 100644
index 000000000000..dc13eec0cbff
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.29-configure-ac.patch
@@ -0,0 +1,37 @@
+--- configure.ac 2007-01-31 00:09:02.000000000 +0100
++++ configure.ac_new 2007-01-31 00:45:53.000000000 +0100
+@@ -73,10 +73,16 @@
+ fi
+ fi
+
++AC_ARG_WITH(fftw,
++ [ --with-fftw use fftw3],
++ [with_fftw=$withval],
++ [with_fftw="no"])
++if test "$with_fftw" = "yes"; then
+ AC_CHECK_HEADER(fftw3.h,
+ AC_CHECK_LIB([fftw3], fftw_execute,,
+ AC_MSG_NOTICE([*** Could not find libfftw3: will compile without optional fast Fourier transforms. ***])),
+ AC_MSG_NOTICE([*** Header file fftw3.h not found: will compile without optional fast Fourier transforms. ***]))
++fi
+
+ GCVERSION=6.8
+
+@@ -168,11 +174,17 @@
+ [Define if you have a working <rpc/rpc.h> header file])],
+ AC_MSG_WARN([*** Broken rpc headers; XDR support disabled ***]))
+
++AC_ARG_WITH(gsl,
++ [ --with-gsl use gsl libraries],
++ [with_gsl=$withval],
++ [with_gsl="no"])
++if test "$with_gsl" = "yes"; then
+ AC_CHECK_HEADER(gsl/gsl_sf.h,
+ AC_CHECK_LIB([gsl], gsl_sf_Si, [AC_DEFINE(HAVE_LIBGSL, 1,
+ [Define to 1 if you have the 'gsl' library (-lgsl). ]) LIBS=$LIBS"-lgsl -lgslcblas "],
+ AC_MSG_NOTICE([*** Could not find libgsl: will compile without optional special functions. ***]),[-lgslcblas]),
+ AC_MSG_NOTICE([*** Header file gsl_sf.h not found: will compile without optional special functions. ***]))
++fi
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_TYPE_PID_T
diff --git a/media-gfx/asymptote/files/asymptote-1.29-makefile.patch b/media-gfx/asymptote/files/asymptote-1.29-makefile.patch
new file mode 100644
index 000000000000..ec5f2a3ed3a2
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.29-makefile.patch
@@ -0,0 +1,63 @@
+--- Makefile.in 2006-12-29 06:16:42.000000000 +0100
++++ ../asymptote-1.20_new/Makefile.in 2007-02-02 22:21:54.000000000 +0100
+@@ -48,7 +48,7 @@
+ datadir = $(DESTDIR)@datadir@
+ asydir = $(datadir)/asymptote
+ docdir = $(DESTDIR)@docdir@
+-exampledir = $(docdir)/examples
++exampledir = $(asydir)/examples
+ animationsdir = $(exampledir)/animations
+ latexdir = $(DESTDIR)@latexdir@
+ INSTALL = @INSTALL@
+@@ -125,11 +125,8 @@
+ doc/*.asy doc/*.csv doc/*.dat doc/latexusage.tex $(exampledir)
+ ${INSTALL} -p -m 644 examples/animations/*.asy $(animationsdir)
+ -${INSTALL} -p -m 644 $(addprefix doc/,$(LATEXFILES)) $(latexdir)
+- -if test -z "$(DESTDIR)"; then \
+- texhash; \
+- fi
+
+-install-doc: doc
++install-doc:
+ cd doc; $(MAKE) install-all
+
+ install-man: man
+--- doc/Makefile 2007-02-02 20:17:18.000000000 +0100
++++ ../asymptote-1.20_new/doc/Makefile 2007-02-02 21:26:45.000000000 +0100
+@@ -4,11 +4,11 @@
+ ASY = ../asy -dir ../base
+ DOCFILES = asymptote.pdf CAD.pdf
+
+-doc: asymptote.dvi asymptote.info html man faq
++doc: $(DOCFILES) asymptote.info html man faq
+
+ html: asymptote/index.html
+
+-man: $(DOCFILES) asy.1
++man: $(MANFILES)
+
+ faq:
+ cd FAQ; $(MAKE) faq
+@@ -80,15 +80,15 @@
+ rm -f CAD.{aux,dvi,log,pdf,toc}
+ rm -rf asymptote
+
+-install: man faq
+- cd FAQ; $(MAKE) install
+- ${INSTALL} -d -m 755 $(docdir) $(mandir)/man1
+- ${INSTALL} -p -m 644 $(DOCFILES) $(docdir)
++install: man
++ ${INSTALL} -d -m 755 $(mandir)/man1
+ ${INSTALL} -p -m 644 $(MANFILES) $(mandir)/man1
+
+-install-all: doc install
+- cd FAQ; $(MAKE) install-info
+- ${INSTALL} -d -m 755 $(infodir)
++install-all: doc faq install
++ cd FAQ; $(MAKE) install-all
++ ${INSTALL} -d -m 755 $(infodir) $(docdir)/html/asymptote
++ ${INSTALL} -p -m 644 $(DOCFILES) $(docdir)
++ ${INSTALL} -p -m 644 asymptote/* $(docdir)/html/asymptote
+ ${INSTALL} -p -m 644 asymptote.info $(infodir)
+ -${INSTALL} -p -m 644 asymptote.info-* $(infodir)
+ -if test -z "$(DESTDIR)"; then \
diff --git a/media-gfx/asymptote/files/digest-asymptote-1.29 b/media-gfx/asymptote/files/digest-asymptote-1.29
new file mode 100644
index 000000000000..ad4773efb6f7
--- /dev/null
+++ b/media-gfx/asymptote/files/digest-asymptote-1.29
@@ -0,0 +1,3 @@
+MD5 455fc563c35e19dd99ba5e7e0281e637 asymptote-1.29.src.tgz 933266
+RMD160 013a5f8f706159ea564811cd044a12fe4b6e58da asymptote-1.29.src.tgz 933266
+SHA256 2b4eea7b3a016295b4543e3d3c9fca80fa278fc2fb7824306130a2c37e602366 asymptote-1.29.src.tgz 933266