summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-10 06:29:46 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-10 06:29:46 +0000
commitfa515a416e6697a6413fc6a2ca24354c9b61bfad (patch)
tree2c414d8441430ec20b19b233ddce54a665fa7c72 /media-gfx
parentQuoting (diff)
downloadgentoo-2-fa515a416e6697a6413fc6a2ca24354c9b61bfad.tar.gz
gentoo-2-fa515a416e6697a6413fc6a2ca24354c9b61bfad.tar.bz2
gentoo-2-fa515a416e6697a6413fc6a2ca24354c9b61bfad.zip
Version bump, add pptx and static-libs use flags.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/pstoedit/ChangeLog8
-rw-r--r--media-gfx/pstoedit/files/pstoedit-3.62-parallel.patch54
-rw-r--r--media-gfx/pstoedit/metadata.xml1
-rw-r--r--media-gfx/pstoedit/pstoedit-3.62.ebuild61
4 files changed, 123 insertions, 1 deletions
diff --git a/media-gfx/pstoedit/ChangeLog b/media-gfx/pstoedit/ChangeLog
index d05ff3576264..46708ce805f1 100644
--- a/media-gfx/pstoedit/ChangeLog
+++ b/media-gfx/pstoedit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/pstoedit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/ChangeLog,v 1.82 2013/02/20 13:16:51 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/ChangeLog,v 1.83 2013/05/10 06:29:46 radhermit Exp $
+
+*pstoedit-3.62 (10 May 2013)
+
+ 10 May 2013; Tim Harder <radhermit@gentoo.org> +pstoedit-3.62.ebuild,
+ +files/pstoedit-3.62-parallel.patch, metadata.xml:
+ Version bump, add pptx and static-libs use flags.
20 Feb 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
pstoedit-3.61.ebuild:
diff --git a/media-gfx/pstoedit/files/pstoedit-3.62-parallel.patch b/media-gfx/pstoedit/files/pstoedit-3.62-parallel.patch
new file mode 100644
index 000000000000..e20324e2fd81
--- /dev/null
+++ b/media-gfx/pstoedit/files/pstoedit-3.62-parallel.patch
@@ -0,0 +1,54 @@
+--- pstoedit-3.62.orig/src/Makefile.am
++++ pstoedit-3.62/src/Makefile.am
+@@ -92,6 +92,7 @@
+ $(sample_drivers_src)
+ libp2edrvstd_la_LIBADD=libpstoedit.la
+ libp2edrvstd_la_LDFLAGS=-no-undefined -module
++libp2edrvstd_la_DEPENDENCIES = libpstoedit.la
+
+ #libp2edrvplugins_la_SOURCES=drvmif.cpp drvcgm.cpp drvrtf.cpp drvwwmf.cpp
+ #libp2edrvplugins_la_LIBADD=
+@@ -101,29 +102,35 @@
+ libp2edrvlplot_la_SOURCES=drvlplot.cpp drvlplot.h initlibrary.cpp
+ libp2edrvlplot_la_LIBADD=$(LIBPLOTTER_LDFLAGS) libpstoedit.la
+ libp2edrvlplot_la_LDFLAGS=-no-undefined -module
++libp2edrvlplot_la_DEPENDENCIES = libpstoedit.la
+
+ libp2edrvpptx_la_SOURCES=drvpptx.cpp drvpptx.h initlibrary.cpp
+ libp2edrvpptx_la_LIBADD=$(LIBPPTX_LDFLAGS) libpstoedit.la
+ libp2edrvpptx_la_LDFLAGS=-no-undefined -module
++libp2edrvpptx_la_DEPENDENCIES = libpstoedit.la
+
+ libp2edrvswf_la_SOURCES=drvswf.cpp drvswf.h initlibrary.cpp
+ libp2edrvswf_la_LIBADD=$(LIBMING_LDFLAGS) libpstoedit.la
+ libp2edrvswf_la_LDFLAGS=-no-undefined -module
++libp2edrvswf_la_DEPENDENCIES = libpstoedit.la
+
+ # note the __ stand for ++ - automake treats all no alphanums chars as _
+ libp2edrvmagick___la_SOURCES=drvmagick++.cpp drvmagick++.h initlibrary.cpp
+ libp2edrvmagick___la_LIBADD=${LIBMAGICK_LDFLAGS} libpstoedit.la
+ libp2edrvmagick___la_LDFLAGS=-no-undefined -module
++libp2edrvmagick___la_DEPENDENCIES = libpstoedit.la
+ # moved to configure.ac because needed only for g++ libp2edrvmagick___la_CPPFLAGS=$(LIBMAGICK_CFLAGS) $(AM_CPPFLAGS) -Wno-long-long
+
+ if USE_EMFBYSOURCE
+ libp2edrvwmf_la_SOURCES=emflib.cpp drvwmf.cpp drvwmf.h initlibrary.cpp
+ libp2edrvwmf_la_LIBADD=libpstoedit.la
+ libp2edrvwmf_la_LDFLAGS=-no-undefined -module
++libp2edrvwmf_la_DEPENDENCIES = libpstoedit.la
+ else
+ libp2edrvwmf_la_SOURCES=drvwmf.cpp drvwmf.h initlibrary.cpp
+ libp2edrvwmf_la_LIBADD=$(LIBEMF_LDFLAGS) libpstoedit.la
+ libp2edrvwmf_la_LDFLAGS=-no-undefined -module
++libp2edrvwmf_la_DEPENDENCIES = libpstoedit.la
+ endif
+
+ libpstoedit_la_SOURCES = \
+@@ -148,6 +155,7 @@
+ pstoedit_SOURCES = cmdmain.cpp
+ pstoedit_LDADD = libpstoedit.la ${LIBLD_LDFLAGS}
+ pstoedit_LDFLAGS = -no-undefined
++pstoedit_DEPENDENCIES = libpstoedit.la
+
+ pkginclude_HEADERS = \
+ pstoedit.h \
diff --git a/media-gfx/pstoedit/metadata.xml b/media-gfx/pstoedit/metadata.xml
index 798d53450a33..e3a0e6b1c798 100644
--- a/media-gfx/pstoedit/metadata.xml
+++ b/media-gfx/pstoedit/metadata.xml
@@ -6,5 +6,6 @@
<use>
<flag name='emf'>Enable <pkg>media-libs/libemf</pkg> support</flag>
<flag name='flash'>Enable <pkg>media-libs/ming</pkg> SWF support</flag>
+ <flag name='pptx'>Enable support for generating PowerPoint pptx files</flag>
</use>
</pkgmetadata>
diff --git a/media-gfx/pstoedit/pstoedit-3.62.ebuild b/media-gfx/pstoedit/pstoedit-3.62.ebuild
new file mode 100644
index 000000000000..978c47a8cbbb
--- /dev/null
+++ b/media-gfx/pstoedit/pstoedit-3.62.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.62.ebuild,v 1.1 2013/05/10 06:29:46 radhermit Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Translate PostScript and PDF graphics into other vector formats"
+HOMEPAGE="http://sourceforge.net/projects/pstoedit/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="emf flash imagemagick plotutils pptx static-libs"
+
+RDEPEND="
+ >=media-libs/libpng-1.4.3
+ >=media-libs/gd-2.0.35-r1
+ >=app-text/ghostscript-gpl-8.71-r1
+ emf? ( >=media-libs/libemf-1.0.3 )
+ flash? ( >=media-libs/ming-0.4.3 )
+ imagemagick? ( >=media-gfx/imagemagick-6.6.1.2[cxx] )
+ plotutils? ( media-libs/plotutils )
+ pptx? ( dev-libs/libzip )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i \
+ -e '/CXXFLAGS="-g"/d' \
+ -e 's:-pedantic::' \
+ configure.ac || die
+
+ epatch "${FILESDIR}"/${PN}-3.62-parallel.patch
+ epatch "${FILESDIR}"/${PN}-3.60-libdl.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with emf) \
+ $(use_with imagemagick magick) \
+ $(use_with plotutils libplot) \
+ $(use_with flash swf) \
+ $(use_with pptx)
+}
+
+src_install() {
+ default
+ doman doc/pstoedit.1
+ dodoc doc/*.txt
+ dohtml doc/*.htm
+
+ prune_libtool_files
+}