summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2007-04-02 00:16:45 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2007-04-02 00:16:45 +0000
commitcd65c670583828153846c3cb5cada3beb472d8a5 (patch)
treea5abad26e3bea975036131b8a3dd8cb63e1c0634 /media-gfx
parentbump libcap to add audit capabilities (diff)
downloadgentoo-2-cd65c670583828153846c3cb5cada3beb472d8a5.tar.gz
gentoo-2-cd65c670583828153846c3cb5cada3beb472d8a5.tar.bz2
gentoo-2-cd65c670583828153846c3cb5cada3beb472d8a5.zip
Add 0.7_beta4 for bug 141617. In package.mask for now. Thanks again to people who contributed in the bug.
(Portage version: 2.1.2.2)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hugin/ChangeLog8
-rw-r--r--media-gfx/hugin/files/digest-hugin-0.7_beta43
-rw-r--r--media-gfx/hugin/hugin-0.7_beta4.ebuild69
3 files changed, 79 insertions, 1 deletions
diff --git a/media-gfx/hugin/ChangeLog b/media-gfx/hugin/ChangeLog
index dd7e10c37f47..0240478db975 100644
--- a/media-gfx/hugin/ChangeLog
+++ b/media-gfx/hugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/hugin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.17 2007/03/03 17:21:51 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.18 2007/04/02 00:16:45 vanquirius Exp $
+
+*hugin-0.7_beta4 (02 Apr 2007)
+
+ 02 Apr 2007; Marcelo Goes <vanquirius@gentoo.org> +hugin-0.7_beta4.ebuild:
+ Add 0.7_beta4 for bug 141617. In package.mask for now. Thanks again to
+ people who contributed in the bug.
03 Mar 2007; Marcelo Goes <vanquirius@gentoo.org> hugin-0.6.1.ebuild:
Improve einfo explanation for enblend and sift USE flags for bug 141617.
diff --git a/media-gfx/hugin/files/digest-hugin-0.7_beta4 b/media-gfx/hugin/files/digest-hugin-0.7_beta4
new file mode 100644
index 000000000000..a0dd7890de4e
--- /dev/null
+++ b/media-gfx/hugin/files/digest-hugin-0.7_beta4
@@ -0,0 +1,3 @@
+MD5 28b69d85ae06a22fe9514f7f77e6dddb hugin-0.7_beta4.tar.bz2 2319243
+RMD160 a46390111a0b47a05f3091549ca0523c7e867ae2 hugin-0.7_beta4.tar.bz2 2319243
+SHA256 4527d40ae56a6ef67583a350ab67505e86054c0b297b2d18cf892c2751cabcfd hugin-0.7_beta4.tar.bz2 2319243
diff --git a/media-gfx/hugin/hugin-0.7_beta4.ebuild b/media-gfx/hugin/hugin-0.7_beta4.ebuild
new file mode 100644
index 000000000000..305fed40b437
--- /dev/null
+++ b/media-gfx/hugin/hugin-0.7_beta4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-0.7_beta4.ebuild,v 1.1 2007/04/02 00:16:45 vanquirius Exp $
+
+inherit wxwidgets eutils
+
+DESCRIPTION="GUI for the creation & processing of panoramic images"
+HOMEPAGE="http://hugin.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2 SIFT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="unicode debug enblend sift"
+
+DEPEND=">=media-libs/libpano12-2.8.4
+ >=dev-libs/boost-1.30.0
+ >=x11-libs/wxGTK-2.6.2
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ enblend? ( media-gfx/enblend )
+ sift? ( media-gfx/autopano-sift )"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/boost threads ; then
+ local msg="Build dev-libs/boost with USE=threads"
+ eerror "$msg"
+ die "$msg"
+ fi
+ if ! use enblend; then
+ einfo "It is recommended to emerge this package with the"
+ einfo "enblend use flag to install media-gfx/enblend"
+ einfo "that blends the seams between images in a panorama."
+ fi
+ if ! use sift; then
+ einfo "It is recommended to emerge this package with the"
+ einfo "sift use flag to install media-gfx/autopano-sift"
+ einfo "that produces control points between images in a"
+ einfo "panorama."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e 's/autopanog\.exe/autopanog/' "${S}"/src/include/hugin/config_defaults.h
+}
+
+src_compile() {
+ export WX_GTK_VER="2.6"
+
+ if use unicode; then
+ need-wxwidgets unicode || die "Emerge wxGTK with unicode in USE"
+ else
+ need-wxwidgets gtk2 || die "Emerge wxGTK with gtk2 in USE"
+ fi
+
+ myconf="`use_with unicode`
+ `use_enable debug`"
+
+ econf --with-wx-config="${WX_CONFIG}" ${myconf} || die "configure failed"
+ emake || die "compiling failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS BUGS README TODO
+}