summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-08-02 19:03:10 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-08-02 19:03:10 +0000
commit4f24b0366db5ebaa517e14eddf783d714862ff64 (patch)
treefe98e34d557ca4f4a6d177688fdbe4b7bef3fa0f /media-gfx
parentAdded support for libdvbpsi. (diff)
downloadgentoo-2-4f24b0366db5ebaa517e14eddf783d714862ff64.tar.gz
gentoo-2-4f24b0366db5ebaa517e14eddf783d714862ff64.tar.bz2
gentoo-2-4f24b0366db5ebaa517e14eddf783d714862ff64.zip
new povray ebuild -- masked until a few bugs are fixed
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/povray/ChangeLog8
-rw-r--r--media-gfx/povray/files/digest-povray-3.5a2
-rw-r--r--media-gfx/povray/files/gentoo-3.50a.patch12
-rw-r--r--media-gfx/povray/povray-3.50a.ebuild98
4 files changed, 119 insertions, 1 deletions
diff --git a/media-gfx/povray/ChangeLog b/media-gfx/povray/ChangeLog
index 27aad77b0a6f..908c9a8b0e90 100644
--- a/media-gfx/povray/ChangeLog
+++ b/media-gfx/povray/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.7 2002/06/26 08:47:52 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.8 2002/08/02 19:03:10 rphillips Exp $
+*povray-3.5a (2 Aug 2002)
+
+ 2 Aug 2002; Ryan Phillips <rphillips@gentoo.org> povray-3.5a.ebuild :
+
+ Preliminary ebuild for povray 3.5. The application errors out with an
+ I/O error looking for povray.ini... I or someone will look into this.
*povray-3.1g-r5 (27 Jun 2002)
27 Jun 2002; Spider <spider@gentoo.org> povray-3.1g-r5.ebuild :
diff --git a/media-gfx/povray/files/digest-povray-3.5a b/media-gfx/povray/files/digest-povray-3.5a
new file mode 100644
index 000000000000..8ffe6ea2e30f
--- /dev/null
+++ b/media-gfx/povray/files/digest-povray-3.5a
@@ -0,0 +1,2 @@
+MD5 4df1711c15d39ee6265ada8ceff78f52 povuni_s.tgz 6732280
+MD5 dff3b8f3bc2a6dd131a9d008d0f46295 povuni_d.tgz 913748
diff --git a/media-gfx/povray/files/gentoo-3.50a.patch b/media-gfx/povray/files/gentoo-3.50a.patch
new file mode 100644
index 000000000000..384a1dab304b
--- /dev/null
+++ b/media-gfx/povray/files/gentoo-3.50a.patch
@@ -0,0 +1,12 @@
+--- src/config.orig Fri Aug 2 10:34:25 2002
++++ src/config.h Fri Aug 2 10:34:46 2002
+@@ -234,6 +234,9 @@
+
+ static uid_t euid;
+
++using std::max;
++using std::min;
++
+ /*
+ * These handle the parsing of the usual X Windows command-line args.
+ */
diff --git a/media-gfx/povray/povray-3.50a.ebuild b/media-gfx/povray/povray-3.50a.ebuild
new file mode 100644
index 000000000000..ca2ddef187d2
--- /dev/null
+++ b/media-gfx/povray/povray-3.50a.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.50a.ebuild,v 1.1 2002/08/02 19:03:10 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="POV Ray- The Persistance of Vision Ray Tracer"
+SRC_URI="ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz"
+# ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_d.tgz"
+HOMEPAGE="http://www.povray.org/"
+
+SLOT="0"
+LICENSE="povlegal-3.50a"
+KEYWORDS="x86 ppc"
+
+
+DEPEND="media-libs/libpng
+ sys-libs/zlib
+ X? ( virtual/x11 )
+ icc? ( dev-lang/icc )
+ svga? ( media-libs/svgalib )"
+
+src_compile() {
+
+ econf || die
+
+ # fix system default povray.ini to point to install directory
+ cp povray.ini povray.ini.orig
+ sed -e "s:\(/usr/\)local/\(share\):\1\2:" povray.ini.orig > povray.ini
+
+ cd src
+ cp Makefile makefile.orig
+
+ DCPU=`echo ${CPPFLAGS} | sed -e "s/.*i\(.86\).*/\\1/"`
+ echo "s/^CPPFLAGS.*-DCPU=686/CPPFLAGS = -DCPU=${DCPU}/" > makefile.sed
+
+ # Change the header file with the banner when you start povray
+ cp optout.h optout.h.orig
+ sed -e "s/DISTRIBUTION_MESSAGE_2.*$/DISTRIBUTION_MESSAGE_2 \"Gentoo Linux - `uname -n` - ${USER}\"/" optout.h.orig > optout.h
+ cp optout.h optout.h.orig
+ sed -e "s/#error You must complete the following DISTRIBUTION_MESSAGE macro//" optout.h.orig > optout.h
+
+ echo "s/^CPPFLAGS =/CPPFLAGS = -ansi -c/" >> makefile.sed
+
+ if [ "`use icc`" ]; then
+ # ICC CPPFLAGS
+ echo "s/gcc/icc/" >> makefile.sed
+
+ # Should pull from /etc/make.conf
+ # If you have a P4 add -tpp7 after the -O3
+ # If you want lean/mean replace -axiMKW with -x? (see icc docs for -x)
+ # Note: -ipo breaks povray
+ # Note: -ip breaks povray on a P3
+ echo "s/^CPPFLAGS =/CPPFLAGS = -O3 -axiMKW /" >> makefile.sed
+ # This is optimized for my Pentium 2:
+ #echo "s/^CPPFLAGS =/CPPFLAGS = -O3 -xM -ip /" >> makefile.sed
+ # This is optimized for Pentium 3 (semi-untested, I don't own one):
+ #echo "s/^CPPFLAGS =/CPPFLAGS = -O3 -xK /" >> makefile.sed
+ # This is optimized for Pentium 4 (untested, I don't own one):
+ #echo "s/^CPPFLAGS =/CPPFLAGS = -O3 -xW -ip -tpp7 /" >> makefile.sed
+
+ if [ "`use icc-pgo`" ]; then
+ IPD=${BUILDDIR}/icc-pgo
+ echo "s:^CPPFLAGS =:CPPFLAGS = -prof_dir ${IPD} :" >> makefile.sed
+ if [ ! -d "${IPD}" ]; then
+ mkdir -m 777 -p ${IPD}
+ echo "s/^CPPFLAGS =/CPPFLAGS = -prof_gen /" >> makefile.sed
+ einfo Building PGO prof_gen version.
+ else
+ einfo Building PGO prof_use version.
+ echo "s/^CPPFLAGS =/CPPFLAGS = -prof_use /" >> makefile.sed
+ fi
+ fi
+ else
+ # GCC CPPFLAGS
+ echo "s/^CPPFLAGS =/CPPFLAGS = -finline-functions -ffast-math /" >> makefile.sed
+ echo "s/^CPPFLAGS =/CPPFLAGS = ${CFLAGS} /" >> makefile.sed
+ fi
+
+ # fix library dependency
+ echo 's/LIBS = \(.*\)/LIBS = \1 -ldl/' >> makefile.sed
+
+ cp Makefile Makefile.orig
+ sed -f makefile.sed Makefile.orig > Makefile
+
+ cd ${P}
+
+ # stl compatibility
+ patch -f -p1 < ${FILESDIR}/gentoo-3.50a.patch
+
+ einfo Building povray
+ emake || die
+}
+
+src_install ()
+{
+ emake DESTDIR=${D} install || die
+ ln -s /usr/share/povray-3.5/povray.ini /etc/povray.ini
+}