summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-25 20:51:13 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-25 20:51:13 +0000
commit29b6f7b27f879fb6838fa47599df099c8b03a43c (patch)
treec725b12da59e4c7706827e5f0472fe2a7142f47b /media-gfx/xloadimage
parentarm stable, bug #377593 (diff)
downloadgentoo-2-29b6f7b27f879fb6838fa47599df099c8b03a43c.tar.gz
gentoo-2-29b6f7b27f879fb6838fa47599df099c8b03a43c.tar.bz2
gentoo-2-29b6f7b27f879fb6838fa47599df099c8b03a43c.zip
Work around mis-placed bracket problem, bug 361993
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/xloadimage')
-rw-r--r--media-gfx/xloadimage/ChangeLog9
-rw-r--r--media-gfx/xloadimage/files/xloadimage-4.1-bracket.patch13
-rw-r--r--media-gfx/xloadimage/xloadimage-4.1-r10.ebuild7
-rw-r--r--media-gfx/xloadimage/xloadimage-4.1-r11.ebuild7
4 files changed, 30 insertions, 6 deletions
diff --git a/media-gfx/xloadimage/ChangeLog b/media-gfx/xloadimage/ChangeLog
index dc2a0f29fc8a..0ae0740a5ca3 100644
--- a/media-gfx/xloadimage/ChangeLog
+++ b/media-gfx/xloadimage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/xloadimage
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/ChangeLog,v 1.53 2010/11/08 23:07:20 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/ChangeLog,v 1.54 2011/08/25 20:51:13 dilfridge Exp $
+
+ 25 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ xloadimage-4.1-r10.ebuild, xloadimage-4.1-r11.ebuild,
+ +files/xloadimage-4.1-bracket.patch:
+ Work around mis-placed bracket problem, bug 361993
08 Nov 2010; Markus Meier <maekke@gentoo.org> xloadimage-4.1-r10.ebuild,
xloadimage-4.1-r11.ebuild:
diff --git a/media-gfx/xloadimage/files/xloadimage-4.1-bracket.patch b/media-gfx/xloadimage/files/xloadimage-4.1-bracket.patch
new file mode 100644
index 000000000000..5d71028652da
--- /dev/null
+++ b/media-gfx/xloadimage/files/xloadimage-4.1-bracket.patch
@@ -0,0 +1,13 @@
+diff -ruN xloadimage.4.1.patched/jpeg.c xloadimage.4.1/jpeg.c
+--- xloadimage.4.1.patched/jpeg.c 2011-08-25 22:44:04.835308001 +0200
++++ xloadimage.4.1/jpeg.c 2011-08-25 22:45:57.391307973 +0200
+@@ -321,8 +321,8 @@
+ cinfo->arith_code = TRUE;
+ #else
+ fprintf(stderr, "jpegDump: sorry, arithmetic coding not supported\n");
+- }
+ #endif
++ }
+ else if (!strncmp("grayscale", name, strlen(name)) ||
+ !strncmp("greyscale", name, strlen(name)) ||
+ !strncmp("monochrome", name, strlen(name))) {
diff --git a/media-gfx/xloadimage/xloadimage-4.1-r10.ebuild b/media-gfx/xloadimage/xloadimage-4.1-r10.ebuild
index 8b7b42389c07..ae9e23ec02d7 100644
--- a/media-gfx/xloadimage/xloadimage-4.1-r10.ebuild
+++ b/media-gfx/xloadimage/xloadimage-4.1-r10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r10.ebuild,v 1.11 2010/11/08 23:07:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r10.ebuild,v 1.12 2011/08/25 20:51:13 dilfridge Exp $
EAPI=2
inherit eutils toolchain-funcs
@@ -50,6 +50,9 @@ src_prepare() {
-e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:' \
png.c || die
+ # One of the previous patches screws up a bracket...
+ epatch "${FILESDIR}"/${P}-bracket.patch
+
chmod +x configure
}
diff --git a/media-gfx/xloadimage/xloadimage-4.1-r11.ebuild b/media-gfx/xloadimage/xloadimage-4.1-r11.ebuild
index d0345d454500..338957a0dccc 100644
--- a/media-gfx/xloadimage/xloadimage-4.1-r11.ebuild
+++ b/media-gfx/xloadimage/xloadimage-4.1-r11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r11.ebuild,v 1.2 2010/11/08 23:07:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r11.ebuild,v 1.3 2011/08/25 20:51:13 dilfridge Exp $
EAPI=2
inherit autotools eutils toolchain-funcs
@@ -50,6 +50,9 @@ src_prepare() {
-e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:' \
png.c || die
+ # One of the previous patches screws up a bracket...
+ epatch "${FILESDIR}"/${P}-bracket.patch
+
chmod +x configure
eautoreconf
}