summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-01 23:24:41 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-01 23:24:41 +0000
commitf06bf1bb14f66a4f9427b670ce592d0bbbfa74b6 (patch)
treecf21d8c55e03c4db68e64e679dffde40694087fd /media-gfx/sxiv
parentUse zeroconf useflag instead of avahi; clean up (diff)
downloadgentoo-2-f06bf1bb14f66a4f9427b670ce592d0bbbfa74b6.tar.gz
gentoo-2-f06bf1bb14f66a4f9427b670ce592d0bbbfa74b6.tar.bz2
gentoo-2-f06bf1bb14f66a4f9427b670ce592d0bbbfa74b6.zip
Version bump.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-gfx/sxiv')
-rw-r--r--media-gfx/sxiv/ChangeLog10
-rw-r--r--media-gfx/sxiv/files/sxiv-1.1-makefile.patch14
-rw-r--r--media-gfx/sxiv/sxiv-1.1.ebuild34
3 files changed, 56 insertions, 2 deletions
diff --git a/media-gfx/sxiv/ChangeLog b/media-gfx/sxiv/ChangeLog
index cfe03819b876..29fe54bd10b5 100644
--- a/media-gfx/sxiv/ChangeLog
+++ b/media-gfx/sxiv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/sxiv
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sxiv/ChangeLog,v 1.10 2012/10/24 03:30:29 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sxiv/ChangeLog,v 1.11 2013/04/01 23:24:40 radhermit Exp $
+
+*sxiv-1.1 (01 Apr 2013)
+
+ 01 Apr 2013; Tim Harder <radhermit@gentoo.org> +sxiv-1.1.ebuild,
+ +files/sxiv-1.1-makefile.patch:
+ Version bump.
*sxiv-1.0-r1 (24 Oct 2012)
diff --git a/media-gfx/sxiv/files/sxiv-1.1-makefile.patch b/media-gfx/sxiv/files/sxiv-1.1-makefile.patch
new file mode 100644
index 000000000000..159173d2ff81
--- /dev/null
+++ b/media-gfx/sxiv/files/sxiv-1.1-makefile.patch
@@ -0,0 +1,14 @@
+--- sxiv-1.1/Makefile
++++ sxiv-1.1/Makefile
+@@ -3,9 +3,8 @@
+ PREFIX = /usr/local
+ MANPREFIX = $(PREFIX)/share/man
+
+-CC = gcc
+-CFLAGS = -std=c99 -Wall -pedantic -O2 -I$(PREFIX)/include -DHAVE_GIFLIB
+-LDFLAGS = -L$(PREFIX)/lib
++CC ?= gcc
++CFLAGS += -std=c99 -Wall -pedantic -DHAVE_GIFLIB
+ LIBS = -lX11 -lImlib2 -lgif
+
+ SRC = commands.c exif.c image.c main.c options.c thumbs.c util.c window.c
diff --git a/media-gfx/sxiv/sxiv-1.1.ebuild b/media-gfx/sxiv/sxiv-1.1.ebuild
new file mode 100644
index 000000000000..1830f8da8cf9
--- /dev/null
+++ b/media-gfx/sxiv/sxiv-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sxiv/sxiv-1.1.ebuild,v 1.1 2013/04/01 23:24:40 radhermit Exp $
+
+EAPI=5
+
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="Simple (or small or suckless) X Image Viewer"
+HOMEPAGE="https://github.com/muennich/sxiv/"
+SRC_URI="https://github.com/muennich/sxiv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-libs/giflib
+ media-libs/imlib2[X]
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ tc-export CC
+
+ restore_config config.h
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX=/usr install
+ dodoc README.md
+
+ save_config config.h
+}