summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Marlowe <mattm@gentoo.org>2012-08-02 12:55:45 +0000
committerMatthew Marlowe <mattm@gentoo.org>2012-08-02 12:55:45 +0000
commit1c47f7c83e1e9dc72658e19ef3807a951ee46ba4 (patch)
tree8158faeeb4501967526ecec04666598e54410e48 /media-gfx/replicatorg
parentremove old (diff)
downloadgentoo-2-1c47f7c83e1e9dc72658e19ef3807a951ee46ba4.tar.gz
gentoo-2-1c47f7c83e1e9dc72658e19ef3807a951ee46ba4.tar.bz2
gentoo-2-1c47f7c83e1e9dc72658e19ef3807a951ee46ba4.zip
Initial commit of basic printing software for the makerbot replicator 3d printer.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/replicatorg')
-rw-r--r--media-gfx/replicatorg/ChangeLog13
-rwxr-xr-xmedia-gfx/replicatorg/files/replicatorg2
-rw-r--r--media-gfx/replicatorg/metadata.xml13
-rw-r--r--media-gfx/replicatorg/replicatorg-37.ebuild83
4 files changed, 111 insertions, 0 deletions
diff --git a/media-gfx/replicatorg/ChangeLog b/media-gfx/replicatorg/ChangeLog
new file mode 100644
index 000000000000..5ca03265a734
--- /dev/null
+++ b/media-gfx/replicatorg/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-gfx/replicatorg
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/replicatorg/ChangeLog,v 1.1 2012/08/02 12:55:44 mattm Exp $
+
+*replicatorg-37 (02 Aug 2012)
+
+ 02 Aug 2012; Matthew Marlowe <mattm@gentoo.org> +replicatorg-37.ebuild,
+ +files/replicatorg, +metadata.xml:
+ Initial Commit - replicatorg is open source software and a required tool when
+ working with common 3d printers such as the makerbot replicator.
+ Unfortunately it is based on java and focused on cross platform binaries. But
+ the initial install here does work and isnt that bad for what it is.
+
diff --git a/media-gfx/replicatorg/files/replicatorg b/media-gfx/replicatorg/files/replicatorg
new file mode 100755
index 000000000000..2c91bf254346
--- /dev/null
+++ b/media-gfx/replicatorg/files/replicatorg
@@ -0,0 +1,2 @@
+#!/bin/bash
+( cd /opt/replicatorg ; ./replicatorg )
diff --git a/media-gfx/replicatorg/metadata.xml b/media-gfx/replicatorg/metadata.xml
new file mode 100644
index 000000000000..b32219d4b98d
--- /dev/null
+++ b/media-gfx/replicatorg/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>mattm@gentoo.org</email>
+<name>Matthew Marlowe</name>
+</maintainer>
+<longdescription>
+This is the software that will drive your MakerBot Replicator, Thing-O-Matic, CupCake CNC, RepRap machine, or generic CNC machine. You can give it a GCode or STL file to process, and it takes it from there. It's cross platform, easily installed, and is based on the familiar Arduino / Processing environments. ReplicatorG is used by thousands of MakerBot Operators, and has printed tens of thousands of objects and counting.
+</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/media-gfx/replicatorg/replicatorg-37.ebuild b/media-gfx/replicatorg/replicatorg-37.ebuild
new file mode 100644
index 000000000000..bc95115fddb1
--- /dev/null
+++ b/media-gfx/replicatorg/replicatorg-37.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/replicatorg/replicatorg-37.ebuild,v 1.1 2012/08/02 12:55:44 mattm Exp $
+
+EAPI="3"
+
+inherit eutils versionator
+
+MY_P="${PN}-00${PV}"
+
+DESCRIPTION="ReplicatorG is a simple, open source 3D printing program"
+HOMEPAGE="http://replicat.org/start"
+SRC_URI="http://replicatorg.googlecode.com/files/${MY_P}-linux.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=""
+
+IUSE=""
+
+COMMON_DEPEND="dev-java/sun-jre-bin"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup replicator
+}
+
+pkg_postinst() {
+ elog "Replicatorg requires Sun/Oracle JRE and will not work with OpenJDK."
+ elog
+ elog "Ensure that your user account has permissions to access serial port,"
+ elog "if you plan to connect directly to a 3d printer. Saving gcode"
+ elog "to a flash card is currently the preferred printing method."
+ elog
+ elog "Note that replicatorg includes its own version of skeinforge."
+ elog "There doesn't seem to be a simple way to depend on an external"
+ elog "version."
+ elog
+ elog "Replicatorg users should add themselves to the replicator group"
+ elog "to avoid upstream warnings about not being able to modify shared"
+ elog "skeinforge scripts."
+ elog
+ chmod 0775 "${ROOT}"/opt/replicatorg
+ chown root:replicator "${ROOT}"/opt/replicatorg
+}
+
+src_install() {
+ dodir \
+ /opt/replicatorg \
+ /usr/share/replicatorg
+
+ keepdir \
+ /opt/relicatorg \
+ /usr/share/replicatorg
+
+ dobin "${FILESDIR}"/replicatorg
+
+ /bin/cp -R --preserve=mode \
+ docs \
+ examples \
+ lib \
+ lib-i686 \
+ lib-x86_64 \
+ machines \
+ scripts \
+ replicatorg \
+ skein_engines \
+ tools \
+ "${D}"/opt/replicatorg/
+
+ fowners -R root:replicator /opt/replicatorg
+
+ insinto /usr/share/replicatorg
+ doins -r \
+ contributors.txt \
+ license.txt \
+ readme.txt \
+ todo.txt
+
+}