summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-09-06 09:00:43 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-09-06 09:00:43 +0000
commit560f184cf5eb8fcca15ad4c896525b602b0fd21c (patch)
tree4f94580336978262cad285b7d5af98d8e1f13850 /media-gfx/pencil
parentVersion bump, bug #379221. (diff)
downloadgentoo-2-560f184cf5eb8fcca15ad4c896525b602b0fd21c.tar.gz
gentoo-2-560f184cf5eb8fcca15ad4c896525b602b0fd21c.tar.bz2
gentoo-2-560f184cf5eb8fcca15ad4c896525b602b0fd21c.zip
Add patch for gcc-4.6.1. Bug #381063. Thanks to Helmut Jarausch <jarausch@igpm.rwth-aachen.de>
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/pencil')
-rw-r--r--media-gfx/pencil/ChangeLog7
-rw-r--r--media-gfx/pencil/files/pencil-0.4.4_beta-gcc461.patch14
-rw-r--r--media-gfx/pencil/pencil-0.4.4_beta.ebuild7
3 files changed, 24 insertions, 4 deletions
diff --git a/media-gfx/pencil/ChangeLog b/media-gfx/pencil/ChangeLog
index a526933cb31e..cc081a5bdfb3 100644
--- a/media-gfx/pencil/ChangeLog
+++ b/media-gfx/pencil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/pencil
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pencil/ChangeLog,v 1.2 2011/08/28 10:49:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pencil/ChangeLog,v 1.3 2011/09/06 09:00:43 hwoarang Exp $
+
+ 06 Sep 2011; Markos Chandras <hwoarang@gentoo.org> pencil-0.4.4_beta.ebuild,
+ +files/pencil-0.4.4_beta-gcc461.patch:
+ Add patch for gcc-4.6.1. Bug #381063. Thanks to Helmut Jarausch
+ <jarausch@igpm.rwth-aachen.de>
28 Aug 2011; Markos Chandras <hwoarang@gentoo.org> pencil-0.4.4_beta.ebuild:
Add missing qt-opengl dependency
diff --git a/media-gfx/pencil/files/pencil-0.4.4_beta-gcc461.patch b/media-gfx/pencil/files/pencil-0.4.4_beta-gcc461.patch
new file mode 100644
index 000000000000..d0aa8936b8fd
--- /dev/null
+++ b/media-gfx/pencil/files/pencil-0.4.4_beta-gcc461.patch
@@ -0,0 +1,14 @@
+--- src/graphics/vector/beziercurve.cpp 2007-07-14 21:41:33.000000000 +0200
++++ src/graphics/vector/beziercurve.cpp 2011-08-29 16:19:08.930675072 +0200
+@@ -700,9 +700,9 @@
+ R1.setTopLeft(P1); R1.setBottomRight(Q1);
+ R2.setTopLeft(P2); R2.setBottomRight(Q2);
+
+- //QPointF intersectionPoint = QPointF(50.0, 50.0); // bogus point
++ QPointF intersectionPoint = QPointF(50.0, 50.0); // bogus point
+ //QPointF* intersection = &intersectionPoint;
+- QPointF* cubicIntersection = &QPointF(50.0, 50.0); // bogus point
++ QPointF* cubicIntersection = &intersectionPoint; // bogus point
+ if( R1.intersects(R2) || L2.intersect(L1, cubicIntersection) == QLineF::BoundedIntersection ) {
+ //if(L2.intersect(L1, intersection) == QLineF::BoundedIntersection) {
+ //qDebug() << " FOUND rectangle intersection ";
diff --git a/media-gfx/pencil/pencil-0.4.4_beta.ebuild b/media-gfx/pencil/pencil-0.4.4_beta.ebuild
index 205eab33ae21..c2f43268367a 100644
--- a/media-gfx/pencil/pencil-0.4.4_beta.ebuild
+++ b/media-gfx/pencil/pencil-0.4.4_beta.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pencil/pencil-0.4.4_beta.ebuild,v 1.2 2011/08/28 10:49:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pencil/pencil-0.4.4_beta.ebuild,v 1.3 2011/09/06 09:00:43 hwoarang Exp $
EAPI=2
-inherit qt4-r2
+inherit eutils qt4-r2
MY_P=${P/_beta/b}
@@ -25,7 +25,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}-source
src_prepare() {
- sed -i s:SWFSprite:SWFMovieClip:g src/external/flash/flash.{cpp,h}
+ epatch "${FILESDIR}"/${P}-gcc461.patch
+ sed -i s:SWFSprite:SWFMovieClip:g src/external/flash/flash.{cpp,h} || die
}
src_install() {