summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-05-13 16:44:52 +0000
committerJeroen Roovers <jer@gentoo.org>2010-05-13 16:44:52 +0000
commit7ed3346e1efc8d00a3dd9ce6f90aa80dddfe14a4 (patch)
treec9ab50b3948e7ead55b1c922945f3bdab93cab16 /media-gfx/icoutils
parentMarked ~ppc for bug #309783. (diff)
downloadgentoo-2-7ed3346e1efc8d00a3dd9ce6f90aa80dddfe14a4.tar.gz
gentoo-2-7ed3346e1efc8d00a3dd9ce6f90aa80dddfe14a4.tar.bz2
gentoo-2-7ed3346e1efc8d00a3dd9ce6f90aa80dddfe14a4.zip
Fix compiling with -O0 thanks to Lee Leahu (bug #319559).
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'media-gfx/icoutils')
-rw-r--r--media-gfx/icoutils/ChangeLog8
-rw-r--r--media-gfx/icoutils/files/icoutils-0.29.1-locale.patch39
-rw-r--r--media-gfx/icoutils/icoutils-0.29.1-r1.ebuild40
3 files changed, 86 insertions, 1 deletions
diff --git a/media-gfx/icoutils/ChangeLog b/media-gfx/icoutils/ChangeLog
index 471b4b091400..cfd33e1e2cf8 100644
--- a/media-gfx/icoutils/ChangeLog
+++ b/media-gfx/icoutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/icoutils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/icoutils/ChangeLog,v 1.21 2010/03/06 09:33:05 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/icoutils/ChangeLog,v 1.22 2010/05/13 16:44:52 jer Exp $
+
+*icoutils-0.29.1-r1 (13 May 2010)
+
+ 13 May 2010; Jeroen Roovers <jer@gentoo.org> +icoutils-0.29.1-r1.ebuild,
+ +files/icoutils-0.29.1-locale.patch:
+ Fix compiling with -O0 thanks to Lee Leahu (bug #319559).
*icoutils-0.29.1 (06 Mar 2010)
diff --git a/media-gfx/icoutils/files/icoutils-0.29.1-locale.patch b/media-gfx/icoutils/files/icoutils-0.29.1-locale.patch
new file mode 100644
index 000000000000..d73ae119ea5e
--- /dev/null
+++ b/media-gfx/icoutils/files/icoutils-0.29.1-locale.patch
@@ -0,0 +1,39 @@
+Fix compiling with -O0 (see <https://bugs.gentoo.org/show_bug.cgi?id=319559>)
+
+
+--- a/wrestool/main.c
++++ b/wrestool/main.c
+@@ -32,6 +32,10 @@
+ #include "common/string-utils.h"
+ #include "wrestool.h"
+
++#ifdef HAVE_LOCALE_H
++#include <locale.h>
++#endif
++
+ #define PROGRAM "wrestool"
+
+
+--- a/icotool/main.c
++++ b/icotool/main.c
+@@ -37,6 +37,10 @@
+ #include "common/io-utils.h"
+ #include "icotool.h"
+
++#ifdef HAVE_LOCALE_H
++#include <locale.h>
++#endif
++
+ #define PROGRAM "icotool"
+
+ static int32_t image_index = -1;
+--- a/configure.ac
++++ b/configure.ac
+@@ -34,6 +34,7 @@
+ AC_HEADER_SYS_WAIT
+ AC_HEADER_TIME
+ #AC_CHECK_HEADERS([byteswap.h errno.h fcntl.h getopt.h limits.h sys/stat.h sys/time.h sys/types.h unistd.h])
++AC_CHECK_HEADERS([locale.h])
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_INLINE
diff --git a/media-gfx/icoutils/icoutils-0.29.1-r1.ebuild b/media-gfx/icoutils/icoutils-0.29.1-r1.ebuild
new file mode 100644
index 000000000000..8caccbcd22a5
--- /dev/null
+++ b/media-gfx/icoutils/icoutils-0.29.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/icoutils/icoutils-0.29.1-r1.ebuild,v 1.1 2010/05/13 16:44:52 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="A set of programs for extracting and converting images in Microsoft Windows icon and cursor files (.ico, .cur)."
+HOMEPAGE="http://www.nongnu.org/icoutils/"
+SRC_URI="http://savannah.nongnu.org/download/icoutils/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls"
+
+RDEPEND="media-libs/libpng
+ nls? ( virtual/libintl )
+ >=dev-lang/perl-5.6
+ >=dev-perl/libwww-perl-5.64"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-locale.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ `use_enable nls` \
+ --disable-dependency-tracking || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}