summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2013-09-19 19:07:16 +0000
committerMarkus Meier <maekke@gentoo.org>2013-09-19 19:07:16 +0000
commitea2f49b33c14bb00df0f20478009de51387218be (patch)
tree3df15656eb9f35546e4d16fa1ce3b73e0f3631c4 /media-gfx/hugin
parentmoving gcc checks to src_prepare to avoid affecting binpkgs (diff)
downloadgentoo-2-ea2f49b33c14bb00df0f20478009de51387218be.tar.gz
gentoo-2-ea2f49b33c14bb00df0f20478009de51387218be.tar.bz2
gentoo-2-ea2f49b33c14bb00df0f20478009de51387218be.zip
version bump: migrate to python-single-r1.eclass and use subslot operator deps
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 072AD062)
Diffstat (limited to 'media-gfx/hugin')
-rw-r--r--media-gfx/hugin/ChangeLog8
-rw-r--r--media-gfx/hugin/hugin-2013.0.0_rc2.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/media-gfx/hugin/ChangeLog b/media-gfx/hugin/ChangeLog
index b150cb1de52a..d6d687107d18 100644
--- a/media-gfx/hugin/ChangeLog
+++ b/media-gfx/hugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/hugin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.129 2013/01/04 10:58:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.130 2013/09/19 19:07:16 maekke Exp $
+
+*hugin-2013.0.0_rc2 (19 Sep 2013)
+
+ 19 Sep 2013; Markus Meier <maekke@gentoo.org> +hugin-2013.0.0_rc2.ebuild:
+ version bump: migrate to python-single-r1.eclass and use subslot operator
+ deps
04 Jan 2013; Markus Meier <maekke@gentoo.org>
-files/hugin-2011.0.0_rc1-libpng15.patch:
diff --git a/media-gfx/hugin/hugin-2013.0.0_rc2.ebuild b/media-gfx/hugin/hugin-2013.0.0_rc2.ebuild
new file mode 100644
index 000000000000..5f0a1c65da18
--- /dev/null
+++ b/media-gfx/hugin/hugin-2013.0.0_rc2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-2013.0.0_rc2.ebuild,v 1.1 2013/09/19 19:07:16 maekke Exp $
+
+EAPI=5
+WX_GTK_VER="2.8"
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit base python-single-r1 wxwidgets versionator cmake-utils
+
+DESCRIPTION="GUI for the creation & processing of panoramic images"
+HOMEPAGE="http://hugin.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2 SIFT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+LANGS=" bg ca cs da de en_GB es eu fi fr hu it ja ko nl pl pt_BR ro ru sk sl sv uk zh_CN zh_TW"
+IUSE="lapack python sift $(echo ${LANGS//\ /\ linguas_})"
+
+CDEPEND="
+ !!dev-util/cocom
+ app-arch/zip
+ dev-cpp/tclap
+ >=dev-libs/boost-1.49.0-r1:=
+ dev-libs/zthread
+ >=media-gfx/enblend-4.0
+ media-gfx/exiv2
+ media-libs/freeglut
+ media-libs/glew:=
+ media-libs/lensfun
+ >=media-libs/libpano13-2.9.18
+ media-libs/libpng:0=
+ media-libs/openexr:=
+ media-libs/tiff
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/wxGTK:2.8=[X,opengl,-odbc]
+ lapack? ( virtual/lapack )
+ sift? ( media-gfx/autopano-sift-C )"
+RDEPEND="${CDEPEND}
+ media-libs/exiftool"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ python? ( ${PYTHON_DEPS} >=dev-lang/swig-2.0.4 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+pkg_setup() {
+ DOCS="authors.txt README TODO"
+ mycmakeargs=(
+ $(cmake-utils_use_enable lapack LAPACK)
+ $(cmake-utils_use_build python HSI)
+ )
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_optimize
+
+ for lang in ${LANGS} ; do
+ case ${lang} in
+ ca) dir=ca_ES;;
+ cs) dir=cs_CZ;;
+ *) dir=${lang};;
+ esac
+ use linguas_${lang} || rm -r "${D}"/usr/share/locale/${dir}
+ done
+}