summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-05 04:13:49 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-05 04:13:49 +0000
commit27fd6a14dfba76c7ac3e4a85c3074a40af6322c1 (patch)
treeb1cb499b96754226ad7f6581950fd84ac6b91bfd /media-gfx/graphviz
parentupdated, A=, try, space fixes (diff)
downloadgentoo-2-27fd6a14dfba76c7ac3e4a85c3074a40af6322c1.tar.gz
gentoo-2-27fd6a14dfba76c7ac3e4a85c3074a40af6322c1.tar.bz2
gentoo-2-27fd6a14dfba76c7ac3e4a85c3074a40af6322c1.zip
updated to new version from Tod
Diffstat (limited to 'media-gfx/graphviz')
-rw-r--r--media-gfx/graphviz/files/digest-graphviz-1.7.151
-rw-r--r--media-gfx/graphviz/graphviz-1.7.15.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-gfx/graphviz/files/digest-graphviz-1.7.15 b/media-gfx/graphviz/files/digest-graphviz-1.7.15
new file mode 100644
index 000000000000..83930f74fc2c
--- /dev/null
+++ b/media-gfx/graphviz/files/digest-graphviz-1.7.15
@@ -0,0 +1 @@
+MD5 067848c829d159be81cbca8607ac7f30 graphviz-1.7.15.tgz 6033408
diff --git a/media-gfx/graphviz/graphviz-1.7.15.ebuild b/media-gfx/graphviz/graphviz-1.7.15.ebuild
new file mode 100644
index 000000000000..8978f0972415
--- /dev/null
+++ b/media-gfx/graphviz/graphviz-1.7.15.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Aron Griffis <agriffis@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.7.7.ebuild,v 1.1 2001/10/19 17:03:38 agriffis Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="open source graph drawing software"
+SRC_URI="http://www.research.att.com/sw/tools/graphviz/dist/$P.tgz"
+HOMEPAGE="http://www.research.att.com/sw/tools/graphviz/"
+
+#Can use freetype-1.3 or 2.0, but not both
+DEPEND=">=sys-libs/zlib-1.1.3
+ >=media-libs/libpng-1.0.6
+ >=media-libs/jpeg-6b
+ media-libs/freetype
+ tcltk? ( =dev-lang/tcltk-8.3* )"
+# tcltk? ( =dev-tcltk/tk-8.3* )" If my tcltk fixes are accepted.
+
+src_compile() {
+
+ local myconf
+ #if no tcltk, this will generate configure warnings, but will
+ #compile without tcltk support
+ use tcltk || myconf="$myconf --without-tcl --without-tk"
+
+ #They seem to have forgot configure when packaging 1.7.15
+ ./autogen.sh --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ make || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog FAQ.txt INSTALL MINTERMS.txt \
+ NEWS README
+
+ insinto /usr/share/doc/${P}/html
+ doins LICENSE.html doc/*.html
+
+
+ insinto /usr/share/doc/${P}/pdf
+ doins doc/*.pdf
+
+}