summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2009-08-11 12:52:18 +0000
committerJim Ramsay <lack@gentoo.org>2009-08-11 12:52:18 +0000
commit61306c85f240c77731ec1309be7dc49817f136e3 (patch)
treec2ce64d89d522b411131e20e4d8fcc86b7880a52 /media-gfx/f-spot/files
parentVersion bump. (diff)
downloadgentoo-2-61306c85f240c77731ec1309be7dc49817f136e3.tar.gz
gentoo-2-61306c85f240c77731ec1309be7dc49817f136e3.tar.bz2
gentoo-2-61306c85f240c77731ec1309be7dc49817f136e3.zip
Version bump: f-spot-0.6.0.0 is released
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/f-spot/files')
-rw-r--r--media-gfx/f-spot/files/f-spot-0.6.0.0-parallel-build.patch76
-rw-r--r--media-gfx/f-spot/files/f-spot-0.6.0.0-sandbox-violation.patch67
2 files changed, 143 insertions, 0 deletions
diff --git a/media-gfx/f-spot/files/f-spot-0.6.0.0-parallel-build.patch b/media-gfx/f-spot/files/f-spot-0.6.0.0-parallel-build.patch
new file mode 100644
index 000000000000..68cae604adfe
--- /dev/null
+++ b/media-gfx/f-spot/files/f-spot-0.6.0.0-parallel-build.patch
@@ -0,0 +1,76 @@
+From be3757a0924a4f56390e979e7feed7c163779f6a Mon Sep 17 00:00:00 2001
+From: Bertrand Lorentz <bertrand.lorentz@gmail.com>
+Date: Sat, 8 Aug 2009 13:03:56 +0200
+Subject: [PATCH 03/19] Fix parallel build issue, "make -j2" now works
+
+---
+ src/Makefile.am | 18 ++++++++++++++++++
+ 1 files changed, 18 insertions(+), 0 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index dc2f8ea..5bafde7 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -473,30 +473,44 @@ NULL_PLATFORM_CSFILES = $(NULL_PLATFROM_CSDISTFILES)
+ F_SPOT_CSFILES = $(F_SPOT_CSDISTFILES) \
+ AssemblyInfo.cs
+
++Cms.dll.mdb: Cms.dll
++
+ Cms.dll: $(CMS_CSFILES)
+ @echo -e "\n*** Compiling $@"
+ $(CSC_LIB) -out:$@ $(EXTRAFLAGS) $(UNSAFE) $(CMS_CSFILES) $(CMS_ASSEMBLIES)
+
++FSpot.Core.dll.mdb: FSpot.Core.dll
++
+ FSpot.Core.dll: $(CORE_CSFILES) FSpot.Utils.dll Cms.dll
+ @echo -e "\n*** Compiling $@"
+ $(CSC_LIB) -out:$@ $(EXTRAFLAGS) $(CORE_CSFILES) $(CORE_ASSEMBLIES)
+
++FSpot.Query.dll.mdb: FSpot.Query.dll
++
+ FSpot.Query.dll: $(QUERY_CSFILES) FSpot.Utils.dll FSpot.Core.dll
+ @echo -e "\n*** Compiling $@"
+ $(CSC_LIB) -out:$@ $(EXTRAFLAGS) $(QUERY_CSFILES) $(QUERY_ASSEMBLIES)
+
++FSpot.Utils.dll.mdb: FSpot.Utils.dll
++
+ FSpot.Utils.dll: $(UTILS_CSFILES)
+ @echo -e "\n*** Compiling $@"
+ $(CSC_LIB) -out:$@ $(EXTRAFLAGS) $(UTILS_CSFILES) $(UTILS_ASSEMBLIES)
+
++FSpot.JobScheduler.dll.mdb: FSpot.JobScheduler.dll
++
+ FSpot.JobScheduler.dll: $(JOBSCHEDULER_CSFILES) FSpot.Utils.dll
+ @echo -e "\n*** Compiling $@"
+ $(CSC_LIB) -out:$@ $(EXTRAFLAGS) $(JOBSCHEDULER_CSFILES) $(JOBSCHEDULER_ASSEMBLIES)
+
++FSpot.Bling.dll.mdb: FSpot.Bling.dll
++
+ FSpot.Bling.dll: $(BLING_CSFILES)
+ @echo -e "\n*** Compiling $@"
+ $(CSC_LIB) -out:$@ $(EXTRAFLAGS) $(BLING_CSFILES) $(BLING_ASSEMBLIES)
+
++FSpot.Widgets.dll.mdb: FSpot.Widgets.dll
++
+ FSpot.Widgets.dll: $(WIDGETS_CSFILES) FSpot.Utils.dll FSpot.Core.dll
+ @echo -e "\n*** Compiling $@"
+ $(CSC_LIB) -out:$@ $(EXTRAFLAGS) $(WIDGETS_CSFILES) $(WIDGETS_ASSEMBLIES)
+@@ -504,10 +518,14 @@ FSpot.Widgets.dll: $(WIDGETS_CSFILES) FSpot.Utils.dll FSpot.Core.dll
+ PLATFORM_CSFILES = $(GNOME_PLATFORM_CSFILES)
+ PLATFORM_ASSEMBLIES = $(GNOME_PLATFORM_ASSEMBLIES)
+
++FSpot.Platform.dll.mdb: FSpot.Platform.dll
++
+ FSpot.Platform.dll: $(PLATFORM_CSFILES) FSpot.Utils.dll
+ @echo -e "\n*** Compiling $@"
+ $(CSC_LIB) -out:$@ $(EXTRAFLAGS) $(PLATFORM_CSFILES) $(PLATFORM_ASSEMBLIES)
+
++f-spot.exe.mdb: f-spot.exe
++
+ f-spot.exe: $(F_SPOT_CSFILES) FSpot.Utils.dll FSpot.Core.dll FSpot.Query.dll FSpot.JobScheduler.dll FSpot.Bling.dll FSpot.Widgets.dll Cms.dll FSpot.Platform.dll $(F_SPOT_RESOURCES)
+ @echo -e "\n*** Compiling $@"
+ $(CSC) -target:winexe -out:$@ $(EXTRAFLAGS) $(UNSAFE) $(NOWARN) $(NUNIT_DEFINES) $(F_SPOT_CSFILES) $(F_SPOT_ASSEMBLIES) $(RESOURCES)
+--
+1.6.3.3
+
diff --git a/media-gfx/f-spot/files/f-spot-0.6.0.0-sandbox-violation.patch b/media-gfx/f-spot/files/f-spot-0.6.0.0-sandbox-violation.patch
new file mode 100644
index 000000000000..73469dca89de
--- /dev/null
+++ b/media-gfx/f-spot/files/f-spot-0.6.0.0-sandbox-violation.patch
@@ -0,0 +1,67 @@
+From 82322bb8461eca5a06e2ec05a5705bc52fada244 Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <i.am@jimramsay.com>
+Date: Mon, 10 Aug 2009 14:03:38 -0400
+Subject: [PATCH 19/19] Make install-data-hook respect DESTDIR
+
+---
+ extensions/Exporters/FlickrExport/Makefile.am | 2 +-
+ extensions/Exporters/PicasaWebExport/Makefile.am | 2 +-
+ extensions/Exporters/SmugMugExport/Makefile.am | 2 +-
+ extensions/Exporters/TabbloExport/Makefile.am | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/extensions/Exporters/FlickrExport/Makefile.am b/extensions/Exporters/FlickrExport/Makefile.am
+index 2535352..46c70e6 100644
+--- a/extensions/Exporters/FlickrExport/Makefile.am
++++ b/extensions/Exporters/FlickrExport/Makefile.am
+@@ -45,7 +45,7 @@ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+ plugindir = $(pkglibdir)/extensions
+
+ install-data-hook:
+- rm -f $(plugindir)/$(PLUGIN_NAME).addin.xml
++ -rm -f "$(DESTDIR)$(plugindir)/$(PLUGIN_NAME).addin.xml"
+
+ plugin_DATA = \
+ $(PLUGIN_ASSEMBLY)
+diff --git a/extensions/Exporters/PicasaWebExport/Makefile.am b/extensions/Exporters/PicasaWebExport/Makefile.am
+index 4b39ee2..25d0322 100644
+--- a/extensions/Exporters/PicasaWebExport/Makefile.am
++++ b/extensions/Exporters/PicasaWebExport/Makefile.am
+@@ -46,7 +46,7 @@ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+ plugindir = $(pkglibdir)/extensions
+
+ install-data-hook:
+- rm -f $(plugindir)/$(PLUGIN_NAME).addin.xml
++ -rm -f "$(DESTDIR)$(plugindir)/$(PLUGIN_NAME).addin.xml"
+
+ plugin_DATA = \
+ $(PLUGIN_ASSEMBLY)
+diff --git a/extensions/Exporters/SmugMugExport/Makefile.am b/extensions/Exporters/SmugMugExport/Makefile.am
+index 5e2d8b6..bed9b68 100644
+--- a/extensions/Exporters/SmugMugExport/Makefile.am
++++ b/extensions/Exporters/SmugMugExport/Makefile.am
+@@ -46,7 +46,7 @@ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+ plugindir = $(pkglibdir)/extensions
+
+ install-data-hook:
+- rm -f $(plugindir)/$(PLUGIN_NAME).addin.xml
++ -rm -f "$(DESTDIR)$(plugindir)/$(PLUGIN_NAME).addin.xml"
+
+ plugin_DATA = \
+ $(PLUGIN_ASSEMBLY)
+diff --git a/extensions/Exporters/TabbloExport/Makefile.am b/extensions/Exporters/TabbloExport/Makefile.am
+index b4ffd33..233ba73 100644
+--- a/extensions/Exporters/TabbloExport/Makefile.am
++++ b/extensions/Exporters/TabbloExport/Makefile.am
+@@ -55,7 +55,7 @@ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+ plugindir = $(pkglibdir)/extensions
+
+ install-data-hook:
+- rm -f $(plugindir)/$(PLUGIN_NAME).addin.xml
++ -rm -f "$(DESTDIR)$(plugindir)/$(PLUGIN_NAME).addin.xml"
+
+ plugin_DATA = \
+ $(PLUGIN_ASSEMBLY)
+--
+1.6.3.3
+