summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-21 20:47:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-21 20:47:39 +0000
commitb79def6acd6029b8b1f1e0a745be236f1019f627 (patch)
tree9d5a69bfcfae3bd4bec4b2081cd9781db1d512b6 /media-gfx/exact-image
parentStable for HPPA PPC (bug #324003). (diff)
downloadgentoo-2-b79def6acd6029b8b1f1e0a745be236f1019f627.tar.gz
gentoo-2-b79def6acd6029b8b1f1e0a745be236f1019f627.tar.bz2
gentoo-2-b79def6acd6029b8b1f1e0a745be236f1019f627.zip
Version bump wrt #319411. Fix automagic libpng and zlib depend wrt #319409. Restrict lcms depend to old version.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/exact-image')
-rw-r--r--media-gfx/exact-image/ChangeLog9
-rw-r--r--media-gfx/exact-image/exact-image-0.8.1.ebuild (renamed from media-gfx/exact-image/exact-image-0.7.5.ebuild)77
2 files changed, 52 insertions, 34 deletions
diff --git a/media-gfx/exact-image/ChangeLog b/media-gfx/exact-image/ChangeLog
index a8b361de68f6..6bcbc9092745 100644
--- a/media-gfx/exact-image/ChangeLog
+++ b/media-gfx/exact-image/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/exact-image
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exact-image/ChangeLog,v 1.2 2010/05/12 12:03:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exact-image/ChangeLog,v 1.3 2010/06/21 20:47:39 ssuominen Exp $
+
+*exact-image-0.8.1 (21 Jun 2010)
+
+ 21 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +exact-image-0.8.1.ebuild:
+ Version bump wrt #319411. Fix automagic libpng and zlib depend wrt
+ #319409. Restrict lcms depend to old version.
12 May 2010; Samuli Suominen <ssuominen@gentoo.org>
exact-image-0.7.5.ebuild, +files/exact-image-0.7.5-libpng14.patch:
diff --git a/media-gfx/exact-image/exact-image-0.7.5.ebuild b/media-gfx/exact-image/exact-image-0.8.1.ebuild
index a2b55388e834..7fe104c45a85 100644
--- a/media-gfx/exact-image/exact-image-0.7.5.ebuild
+++ b/media-gfx/exact-image/exact-image-0.8.1.ebuild
@@ -1,9 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exact-image/exact-image-0.7.5.ebuild,v 1.2 2010/05/12 12:03:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exact-image/exact-image-0.8.1.ebuild,v 1.1 2010/06/21 20:47:39 ssuominen Exp $
-EAPI="2"
-inherit eutils
+EAPI=2
+
+PYTHON_DEPEND="python? 2:2.5"
+
+inherit eutils python
DESCRIPTION="A fast, modern and generic image processing library"
HOMEPAGE="http://www.exactcode.de/site/open_source/exactimage/"
@@ -12,18 +15,19 @@ SRC_URI="http://dl.exactcode.de/oss/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="agg expat jpeg jpeg2k lcms lua openexr php perl python ruby swig tiff truetype X"
+IUSE="expat jpeg jpeg2k lcms lua openexr php perl png python ruby swig tiff truetype X"
-RDEPEND="agg? ( x11-libs/agg[truetype] )
+RDEPEND="x11-libs/agg[truetype]
+ sys-libs/zlib
expat? ( dev-libs/expat )
jpeg2k? ( media-libs/jasper )
- jpeg? ( media-libs/jpeg )
- lcms? ( media-libs/lcms )
+ jpeg? ( >=media-libs/jpeg-8a )
+ lcms? ( =media-libs/lcms-1* )
lua? ( dev-lang/lua )
openexr? ( media-libs/openexr )
php? ( dev-lang/php )
perl? ( sys-devel/libperl )
- python? ( dev-lang/python )
+ png? ( >=media-libs/libpng-1.2.43 )
ruby? ( dev-lang/ruby )
tiff? ( media-libs/tiff )
truetype? ( >=media-libs/freetype-2 )
@@ -33,41 +37,48 @@ RDEPEND="agg? ( x11-libs/agg[truetype] )
x11-libs/libICE
x11-libs/libSM
)"
-
DEPEND="${RDEPEND}
+ dev-util/pkgconfig
swig? ( dev-lang/swig )"
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ fi
+}
+
src_prepare() {
- # this is broken ebuild: automagic libpng depend.
- epatch "${FILESDIR}"/${P}-libpng14.patch
+ epatch "${FILESDIR}"/${PN}-0.7.5-libpng14.patch
}
src_configure() {
- # evas support is disabled since evas is not on main tree. You can find it
- # on enlightenment overlay
- # bardecode is disabled since it is protected by custom licence
- # libungif is disabled as it is not supported anymore
- myconf=" --without-libungif --without-evas \
- --without-bardecode --prefix=/usr
- $(use_with jpeg libjpeg)\
- $(use_with lua) \
- $(use_with php) \
- $(use_with ruby) \
- $(use_with python) \
- $(use_with swig) \
- $(use_with agg libagg) \
- $(use_with lcms) \
- $(use_with tiff libtiff) \
+ # evas -> enlightenment overlay
+ # bardecode -> protected by custom license
+ # libungif -> not supported anymore
+
+ ./configure \
+ --prefix=/usr \
+ $(use_with X x11) \
$(use_with truetype freetype) \
- $(use_with expat) \
- $(use_with openexr) \
+ --without-evas \
+ $(use_with jpeg libjpeg) \
+ $(use_with tiff libtiff) \
+ $(use_with png libpng) \
+ --without-libungif \
$(use_with jpeg2k jasper) \
- $(use_with X x11)"
- #econf fails
- ./configure ${myconf} || die "configure failed"
+ $(use_with openexr) \
+ $(use_with expat) \
+ $(use_with lcms) \
+ --without-bardecode \
+ $(use_with lua) \
+ $(use_with swig) \
+ $(use_with perl) \
+ $(use_with python) \
+ $(use_with php) \
+ $(use_with ruby) || die
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README || die "dodoc failed"
+ emake DESTDIR="${D}" install || die
+ dodoc README TODO || die
}