summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-23 21:14:28 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-23 21:14:28 +0000
commit66e10fb21c73afdd3f4c7019d15200e0cdc25e29 (patch)
treee89e0b556c8cc6b4a96fc59455a4e2e9e732b72b /media-gfx/eog
parentffmpeg2theora bump (diff)
downloadgentoo-2-66e10fb21c73afdd3f4c7019d15200e0cdc25e29.tar.gz
gentoo-2-66e10fb21c73afdd3f4c7019d15200e0cdc25e29.tar.bz2
gentoo-2-66e10fb21c73afdd3f4c7019d15200e0cdc25e29.zip
Bump to 2.24.1. Various bug fixes, also fix bug #242868.
(Portage version: 2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'media-gfx/eog')
-rw-r--r--media-gfx/eog/ChangeLog7
-rw-r--r--media-gfx/eog/eog-2.24.1.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/media-gfx/eog/ChangeLog b/media-gfx/eog/ChangeLog
index 916eb71422c9..d3a26ff5b454 100644
--- a/media-gfx/eog/ChangeLog
+++ b/media-gfx/eog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/eog
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.214 2008/10/19 18:57:26 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.215 2008/10/23 21:14:28 eva Exp $
+
+*eog-2.24.1 (23 Oct 2008)
+
+ 23 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org> +eog-2.24.1.ebuild:
+ Bump to 2.24.1. Various bug fixes, also fix bug #242868.
*eog-2.24.0 (19 Oct 2008)
diff --git a/media-gfx/eog/eog-2.24.1.ebuild b/media-gfx/eog/eog-2.24.1.ebuild
new file mode 100644
index 000000000000..10f49faee6c3
--- /dev/null
+++ b/media-gfx/eog/eog-2.24.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.24.1.ebuild,v 1.1 2008/10/23 21:14:28 eva Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="The Eye of GNOME image viewer"
+HOMEPAGE="http://www.gnome.org/projects/eog/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus doc exif lcms python xmp"
+
+RDEPEND=">=x11-libs/gtk+-2.13.1
+ >=dev-libs/glib-2.15.3
+ >=gnome-base/libgnomeui-2.10
+ >=gnome-base/libglade-2.3.6
+ >=gnome-base/gconf-2.5.90
+ >=media-libs/libart_lgpl-2.3.16
+ >=gnome-base/gnome-desktop-2.10
+ >=x11-themes/gnome-icon-theme-2.19.1
+ >=x11-misc/shared-mime-info-0.20
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ exif? (
+ >=media-libs/libexif-0.6.14
+ media-libs/jpeg )
+ lcms? ( media-libs/lcms )
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygobject-2.11.5
+ >=dev-python/pygtk-2.9.7
+ >=dev-python/gnome-python-2.18.2 )
+ xmp? ( >=media-libs/exempi-2 )"
+
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.17
+ doc? ( >=dev-util/gtk-doc-1.10 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README THANKS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with exif libjpeg)
+ $(use_with exif libexif)
+ $(use_with dbus dbus-glib-1)
+ $(use_with lcms cms)
+ $(use_enable python)
+ $(use_with xmp)
+ --disable-scrollkeeper
+ --disable-schemas-install"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix documentation with USE="-exif doc"
+ sed 's:-I$(top_srcdir)/plugins \\:\\:g' -i doc/references/Makefile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! built_with_use =x11-libs/gtk+-2* jpeg; then
+ ewarn "For JPEG file support to work, x11-libs/gtk+ must be rebuilt"
+ ewarn "with the 'jpeg' USE flag enabled."
+ fi
+
+ if ! built_with_use =x11-libs/gtk+-2* tiff; then
+ ewarn "For TIFF file support to work, x11-libs/gtk+ must be rebuilt"
+ ewarn "with the 'tiff' USE flag enabled."
+ fi
+}