summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-12-26 22:03:16 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-12-26 22:03:16 +0000
commit62e2a0093775f24800130108b4371b65e6a1a962 (patch)
tree791a2a9ed0ec68183bef014e905699d907997c72 /media-gfx/eog-plugins
parentRemoved old. (diff)
downloadgentoo-2-62e2a0093775f24800130108b4371b65e6a1a962.tar.gz
gentoo-2-62e2a0093775f24800130108b4371b65e6a1a962.tar.bz2
gentoo-2-62e2a0093775f24800130108b4371b65e6a1a962.zip
Version bump for Gnome 3.6. Switch to EAPI=5 and python-single-r1.eclass. Clean up old revision.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/ChangeLog9
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.6.1-r1.ebuild (renamed from media-gfx/eog-plugins/eog-plugins-3.4.0.ebuild)71
2 files changed, 34 insertions, 46 deletions
diff --git a/media-gfx/eog-plugins/ChangeLog b/media-gfx/eog-plugins/ChangeLog
index 1a226f91074d..92f1d0c72501 100644
--- a/media-gfx/eog-plugins/ChangeLog
+++ b/media-gfx/eog-plugins/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/eog-plugins
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/ChangeLog,v 1.2 2012/07/16 06:51:53 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/ChangeLog,v 1.3 2012/12/26 22:03:15 eva Exp $
+
+*eog-plugins-3.6.1-r1 (26 Dec 2012)
+
+ 26 Dec 2012; Gilles Dartiguelongue <eva@gentoo.org>
+ -eog-plugins-3.4.0.ebuild, +eog-plugins-3.6.1-r1.ebuild:
+ Version bump for Gnome 3.6. Switch to EAPI=5 and python-single-r1.eclass.
+ Clean up old revision.
*eog-plugins-3.4.1 (16 Jul 2012)
diff --git a/media-gfx/eog-plugins/eog-plugins-3.4.0.ebuild b/media-gfx/eog-plugins/eog-plugins-3.6.1-r1.ebuild
index 15e6ed20966b..5a547a47cf85 100644
--- a/media-gfx/eog-plugins/eog-plugins-3.4.0.ebuild
+++ b/media-gfx/eog-plugins/eog-plugins-3.6.1-r1.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/eog-plugins-3.4.0.ebuild,v 1.1 2012/05/14 04:21:49 tetromino Exp $
-
-EAPI="4"
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/eog-plugins-3.6.1-r1.ebuild,v 1.1 2012/12/26 22:03:16 eva Exp $
+EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_{6,7} )
-PYTHON_DEPEND="2"
-
-inherit gnome2 python
+inherit gnome2 python-single-r1
DESCRIPTION="Eye of GNOME plugins"
HOMEPAGE="https://live.gnome.org/EyeOfGnome/Plugins"
@@ -17,26 +15,25 @@ HOMEPAGE="https://live.gnome.org/EyeOfGnome/Plugins"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+flickr map +picasa +python"
+IUSE="+exif +flickr map +picasa +python"
+REQUIRED_USE="map? ( exif )"
-RDEPEND=">=dev-libs/glib-2.26:2
- >=dev-libs/libpeas-0.7.4[python?]
- >=media-gfx/eog-3.3.6
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.5.5
x11-libs/gtk+:3
-
- >=media-libs/libexif-0.6.16
-
+ exif? ( >=media-libs/libexif-0.6.16 )
flickr? ( media-gfx/postr )
map? (
media-libs/libchamplain:0.12[gtk]
>=media-libs/clutter-1.9.4:1.0
>=media-libs/clutter-gtk-1.1.2:1.0 )
- picasa? ( >=dev-libs/libgdata-0.9.1 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
python? (
- dev-libs/libpeas[gtk,python]
- dev-python/pygobject:3
+ ${PYTHON_DEPS}
+ dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
gnome-base/gsettings-desktop-schemas
media-gfx/eog[introspection]
x11-libs/gtk+:3[introspection]
@@ -49,36 +46,20 @@ DEPEND="${RDEPEND}
"
pkg_setup() {
- local plugins="fit-to-width,exif-display,send-by-mail"
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
use flickr && plugins="${plugins},postr"
use map && plugins="${plugins},map"
use picasa && plugins="${plugins},postasa"
- use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder"
G2CONF="${G2CONF}
$(use_enable python)
- --with-plugins=${plugins}
- PYTHON=${EPREFIX}/usr/bin/python2"
-
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- gnome2_src_prepare
- use python && python_clean_py-compile_files
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- if use python; then
- python_need_rebuild
- python_mod_optimize /usr/$(get_libdir)/eog/plugins
- fi
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- use python && python_mod_cleanup /usr/$(get_libdir)/eog/plugins
+ --with-plugins=${plugins}"
+ gnome2_src_configure
}