summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-23 07:57:17 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-23 07:57:17 +0000
commit5468a42e8e2ea6a5548c911f1e2b851cfef98fc9 (patch)
treedd52b7eca6a9b3fea9bd34298969012475052d77 /media-gfx/apngasm
parentRemove old. (diff)
downloadgentoo-2-5468a42e8e2ea6a5548c911f1e2b851cfef98fc9.tar.gz
gentoo-2-5468a42e8e2ea6a5548c911f1e2b851cfef98fc9.tar.bz2
gentoo-2-5468a42e8e2ea6a5548c911f1e2b851cfef98fc9.zip
Version bump.
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/apngasm')
-rw-r--r--media-gfx/apngasm/ChangeLog7
-rw-r--r--media-gfx/apngasm/apngasm-2.6.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/media-gfx/apngasm/ChangeLog b/media-gfx/apngasm/ChangeLog
index eb424a53c38b..3b15da181539 100644
--- a/media-gfx/apngasm/ChangeLog
+++ b/media-gfx/apngasm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/apngasm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/ChangeLog,v 1.4 2012/01/11 23:13:07 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/ChangeLog,v 1.5 2012/02/23 07:57:17 radhermit Exp $
+
+*apngasm-2.6 (23 Feb 2012)
+
+ 23 Feb 2012; Tim Harder <radhermit@gentoo.org> +apngasm-2.6.ebuild:
+ Version bump.
*apngasm-2.5 (11 Jan 2012)
diff --git a/media-gfx/apngasm/apngasm-2.6.ebuild b/media-gfx/apngasm/apngasm-2.6.ebuild
new file mode 100644
index 000000000000..ea120210e287
--- /dev/null
+++ b/media-gfx/apngasm/apngasm-2.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/apngasm-2.6.ebuild,v 1.1 2012/02/23 07:57:17 radhermit Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="create an APNG from multiple PNG files"
+HOMEPAGE="http://sourceforge.net/projects/apngasm/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng[apng]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) --libs libpng --libs zlib)" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}