summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2014-06-07 19:57:41 +0000
committerEray Aslan <eras@gentoo.org>2014-06-07 19:57:41 +0000
commitd004769a8dec0481638be7e48d9fa903a1e6545f (patch)
tree3de0aa13addc1f3da68e9a03073d9e7d7dc90c0e /mail-mta
parentStable for HPPA (bug #512648). (diff)
downloadgentoo-2-d004769a8dec0481638be7e48d9fa903a1e6545f.tar.gz
gentoo-2-d004769a8dec0481638be7e48d9fa903a1e6545f.tar.bz2
gentoo-2-d004769a8dec0481638be7e48d9fa903a1e6545f.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/postfix/ChangeLog8
-rw-r--r--mail-mta/postfix/postfix-2.12_pre20140531.ebuild (renamed from mail-mta/postfix/postfix-2.12_pre20140516.ebuild)56
2 files changed, 31 insertions, 33 deletions
diff --git a/mail-mta/postfix/ChangeLog b/mail-mta/postfix/ChangeLog
index ef45f0102102..d2a1ecc955a4 100644
--- a/mail-mta/postfix/ChangeLog
+++ b/mail-mta/postfix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-mta/postfix
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/ChangeLog,v 1.504 2014/05/17 05:03:27 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/ChangeLog,v 1.505 2014/06/07 19:57:41 eras Exp $
+
+*postfix-2.12_pre20140531 (07 Jun 2014)
+
+ 07 Jun 2014; Eray Aslan <eras@gentoo.org> +postfix-2.12_pre20140531.ebuild,
+ -postfix-2.12_pre20140516.ebuild:
+ Version bump
*postfix-2.12_pre20140516 (17 May 2014)
diff --git a/mail-mta/postfix/postfix-2.12_pre20140516.ebuild b/mail-mta/postfix/postfix-2.12_pre20140531.ebuild
index 3ba7f6fe2afe..4eaef350602a 100644
--- a/mail-mta/postfix/postfix-2.12_pre20140516.ebuild
+++ b/mail-mta/postfix/postfix-2.12_pre20140531.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.12_pre20140516.ebuild,v 1.1 2014/05/17 05:03:27 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.12_pre20140531.ebuild,v 1.1 2014/06/07 19:57:41 eras Exp $
EAPI=5
inherit eutils flag-o-matic multilib pam ssl-cert systemd toolchain-funcs user versionator
@@ -79,29 +79,35 @@ src_prepare() {
}
src_configure() {
+ for name in CDB LDAP LMDB MYSQL PCRE PGSQL SDBM SQLITE
+ do
+ local AUXLIBS_${name}=""
+ done
+
# Make sure LDFLAGS get passed down to the executables.
- local mycc="-DHAS_PCRE" mylibs="${LDFLAGS} -lpcre -lcrypt -lpthread"
+ local mycc="-DHAS_PCRE" mylibs="${LDFLAGS} -ldl"
+ AUXLIBS_PCRE="$(pcre-config --libs)"
use pam && mylibs="${mylibs} -lpam"
if use ldap; then
mycc="${mycc} -DHAS_LDAP"
- mylibs="${mylibs} -lldap -llber"
+ AUXLIBS_LDAP="-lldap -llber"
fi
if use mysql; then
mycc="${mycc} -DHAS_MYSQL $(mysql_config --include)"
- mylibs="${mylibs} $(mysql_config --libs)"
+ AUXLIBS_MYSQL="$(mysql_config --libs)"
fi
if use postgres; then
mycc="${mycc} -DHAS_PGSQL -I$(pg_config --includedir)"
- mylibs="${mylibs} -lpq -L$(pg_config --libdir)"
+ AUXLIBS_PGSQL="-L$(pg_config --libdir) -lpq"
fi
if use sqlite; then
mycc="${mycc} -DHAS_SQLITE"
- mylibs="${mylibs} -lsqlite3"
+ AUXLIBS_SQLITE="-lsqlite3 -lpthread"
fi
if use ssl; then
@@ -111,7 +117,7 @@ src_configure() {
if use lmdb; then
mycc="${mycc} -DHAS_LMDB"
- mylibs="${mylibs} -llmdb"
+ AUXLIBS_LMDB="-llmdb -lpthread"
fi
# broken. and "in other words, not supported" by upstream.
@@ -148,19 +154,17 @@ src_configure() {
if use cdb; then
mycc="${mycc} -DHAS_CDB -I/usr/include/cdb"
- CDB_LIBS=""
# Tinycdb is preferred.
if has_version dev-db/tinycdb ; then
einfo "Building with dev-db/tinycdb"
- CDB_LIBS="-lcdb"
+ AUXLIBS_CDB="-lcdb"
else
einfo "Building with dev-db/cdb"
CDB_PATH="/usr/$(get_libdir)"
for i in cdb.a alloc.a buffer.a unix.a byte.a ; do
- CDB_LIBS="${CDB_LIBS} ${CDB_PATH}/${i}"
+ AUXLIBS_CDB="${AUXLIBS_CDB} ${CDB_PATH}/${i}"
done
fi
- mylibs="${mylibs} ${CDB_LIBS}"
fi
# Robin H. Johnson <robbat2@gentoo.org> 17/Nov/2006
@@ -178,7 +182,13 @@ src_configure() {
sed -i -e "/^RANLIB/s/ranlib/$(tc-getRANLIB)/g" "${S}"/makedefs
sed -i -e "/^AR/s/ar/$(tc-getAR)/g" "${S}"/makedefs
- emake DEBUG="" CC="$(tc-getCC)" OPT="${CFLAGS}" CCARGS="${mycc}" AUXLIBS="${mylibs}" makefiles
+
+ emake makefiles shared=yes shlib_directory="/usr/$(get_libdir)" dynamicmaps=no \
+ DEBUG="" CC="$(tc-getCC)" OPT="${CFLAGS}" CCARGS="${mycc}" AUXLIBS="${mylibs}" \
+ AUXLIBS_CDB="${AUXLIBS_CDB}" AUXLIBS_LDAP="${AUXLIBS_LDAP}" \
+ AUXLIBS_LMDB="${AUXLIBS_LMDB}" AUXLIBS_MYSQL="${AUXLIBS_MYSQL}" \
+ AUXLIBS_PCRE="${AUXLIBS_PCRE}" AUXLIBS_PGSQL="${AUXLIBS_PGSQL}" \
+ AUXLIBS_SQLITE="${AUXLIBS_SQLITE}"
}
src_install () {
@@ -186,6 +196,7 @@ src_install () {
use doc && myconf="readme_directory=\"/usr/share/doc/${PF}/readme\" \
html_directory=\"/usr/share/doc/${PF}/html\""
+ LD_LIBRARY_PATH="${S}/lib" \
/bin/sh postfix-install \
-non-interactive \
install_root="${D}" \
@@ -232,6 +243,7 @@ src_install () {
else
mypostconf="home_mailbox=.maildir/"
fi
+ LD_LIBRARY_PATH="${S}/lib" \
"${D}"/usr/sbin/postconf -c "${D}"/etc/postfix \
-e ${mypostconf} || die "postconf failed"
@@ -266,26 +278,6 @@ src_install () {
systemd_dounit "${FILESDIR}/${PN}.service"
}
-pkg_preinst() {
- # Postfix 2.9.
- # default for inet_protocols changed from ipv4 to all in postfix-2.9.
- # check inet_protocols setting in main.cf and modify if necessary to prevent
- # performance loss with useless DNS lookups and useless connection attempts.
- [[ -d ${ROOT}/etc/postfix ]] && {
- if [[ "$(${D}/usr/sbin/postconf -dh inet_protocols)" != "ipv4" ]]; then
- if [[ ! -n "$(${D}/usr/sbin/postconf -c ${ROOT}/etc/postfix -n inet_protocols)" ]];
- then
- ewarn "\nCOMPATIBILITY: adding inet_protocols=ipv4 to main.cf."
- ewarn "That will keep the same behaviour as previous postfix versions."
- ewarn "Specify inet_protocols explicitly if you want to enable IPv6.\n"
- else
- # delete inet_protocols setting. there is already one in /etc/postfix
- sed -i -e /inet_protocols/d "${D}"/etc/postfix/main.cf || die
- fi
- fi
- }
-}
-
pkg_postinst() {
# Do not install server.{key,pem) SSL certificates if they already exist
if use ssl && [[ ! -f "${ROOT}"/etc/ssl/postfix/server.key \