summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-12 17:33:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-12 17:33:10 +0000
commitc21d7faa3f8daedc9336ac17dbd5a73383b82ce2 (patch)
tree1dfc10e8cf228878b703f0b953e49f3364e12061 /mail-mta
parentstable x86, bug 327279 (diff)
downloadgentoo-2-c21d7faa3f8daedc9336ac17dbd5a73383b82ce2.tar.gz
gentoo-2-c21d7faa3f8daedc9336ac17dbd5a73383b82ce2.tar.bz2
gentoo-2-c21d7faa3f8daedc9336ac17dbd5a73383b82ce2.zip
Fix building with OpenSSL >= 1.0.0 wrt #327955 by Alec M.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/msmtp/ChangeLog6
-rw-r--r--mail-mta/msmtp/files/msmtp-1.4.20-openssl-1.patch22
-rw-r--r--mail-mta/msmtp/msmtp-1.4.20.ebuild11
3 files changed, 35 insertions, 4 deletions
diff --git a/mail-mta/msmtp/ChangeLog b/mail-mta/msmtp/ChangeLog
index f15682e60f29..bb5f7c6d85f8 100644
--- a/mail-mta/msmtp/ChangeLog
+++ b/mail-mta/msmtp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-mta/msmtp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/ChangeLog,v 1.83 2010/06/09 18:51:09 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/ChangeLog,v 1.84 2010/07/12 17:33:09 ssuominen Exp $
+
+ 12 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> msmtp-1.4.20.ebuild,
+ +files/msmtp-1.4.20-openssl-1.patch:
+ Fix building with OpenSSL >= 1.0.0 wrt #327955 by Alec M.
*msmtp-1.4.20 (09 Jun 2010)
diff --git a/mail-mta/msmtp/files/msmtp-1.4.20-openssl-1.patch b/mail-mta/msmtp/files/msmtp-1.4.20-openssl-1.patch
new file mode 100644
index 000000000000..5b7373fdd388
--- /dev/null
+++ b/mail-mta/msmtp/files/msmtp-1.4.20-openssl-1.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/327955
+
+--- src/tls.c
++++ src/tls.c
+@@ -888,7 +888,7 @@
+ char *buf;
+ int length;
+ /* needed to get the DNS subjectAltNames: */
+- STACK *subj_alt_names;
++ STACK_OF(GENERAL_NAME) *subj_alt_names;
+ int subj_alt_names_count;
+ GENERAL_NAME *subj_alt_name;
+ /* did we find a name matching hostname? */
+@@ -988,7 +988,7 @@
+ /* Try the DNS subjectAltNames. */
+ match_found = 0;
+ if ((subj_alt_names =
+- X509_get_ext_d2i(x509cert, NID_subject_alt_name, NULL, NULL)))
++ (STACK_OF(GENERAL_NAME)*)X509_get_ext_d2i(x509cert, NID_subject_alt_name, NULL, NULL)))
+ {
+ subj_alt_names_count = sk_GENERAL_NAME_num(subj_alt_names);
+ for (i = 0; i < subj_alt_names_count; i++)
diff --git a/mail-mta/msmtp/msmtp-1.4.20.ebuild b/mail-mta/msmtp/msmtp-1.4.20.ebuild
index a740902b1d33..630bc778975e 100644
--- a/mail-mta/msmtp/msmtp-1.4.20.ebuild
+++ b/mail-mta/msmtp/msmtp-1.4.20.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/msmtp-1.4.20.ebuild,v 1.1 2010/06/09 18:51:09 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/msmtp-1.4.20.ebuild,v 1.2 2010/07/12 17:33:09 ssuominen Exp $
EAPI=2
+inherit eutils
DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
HOMEPAGE="http://msmtp.sourceforge.net/"
@@ -32,7 +33,11 @@ DEPEND="${DEPEND}
PROVIDE="mta? ( virtual/mta )"
-src_configure () {
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-openssl-1.patch
+}
+
+src_configure() {
local myconf
if use gnutls ; then
@@ -51,7 +56,7 @@ src_configure () {
${myconf}
}
-src_install () {
+src_install() {
emake DESTDIR="${D}" install || die "install failed"
if use mta; then