summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Malm <gengor@gentoo.org>2009-07-05 20:57:15 +0000
committerGordon Malm <gengor@gentoo.org>2009-07-05 20:57:15 +0000
commit6be8d76aa6338bc4d03f16a215fc54407253cddb (patch)
treebd301e4899a06c884d02b0a0c3a67031a084e8a4 /mail-mta
parentUSB functionality seems to work in brief testing with libusb-compat. (diff)
downloadgentoo-2-6be8d76aa6338bc4d03f16a215fc54407253cddb.tar.gz
gentoo-2-6be8d76aa6338bc4d03f16a215fc54407253cddb.tar.bz2
gentoo-2-6be8d76aa6338bc4d03f16a215fc54407253cddb.zip
Avoid gcc-version test under non-hardened, stylistic change wrt #76512.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/postfix/ChangeLog6
-rw-r--r--mail-mta/postfix/postfix-2.4.11.ebuild6
-rw-r--r--mail-mta/postfix/postfix-2.5.5.ebuild8
-rw-r--r--mail-mta/postfix/postfix-2.5.7.ebuild6
-rw-r--r--mail-mta/postfix/postfix-2.6.2.ebuild6
5 files changed, 22 insertions, 10 deletions
diff --git a/mail-mta/postfix/ChangeLog b/mail-mta/postfix/ChangeLog
index dc3b540f60fa..34133f92009f 100644
--- a/mail-mta/postfix/ChangeLog
+++ b/mail-mta/postfix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-mta/postfix
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/ChangeLog,v 1.184 2009/06/08 17:16:59 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/ChangeLog,v 1.185 2009/07/05 20:57:15 gengor Exp $
+
+ 05 Jul 2009; Gordon Malm <gengor@gentoo.org> postfix-2.4.11.ebuild,
+ postfix-2.5.5.ebuild, postfix-2.5.7.ebuild, postfix-2.6.2.ebuild:
+ Avoid gcc-version test under non-hardened, stylistic change wrt #76512.
*postfix-2.6.2 (08 Jun 2009)
diff --git a/mail-mta/postfix/postfix-2.4.11.ebuild b/mail-mta/postfix/postfix-2.4.11.ebuild
index 41bdd01374c0..6343b3580802 100644
--- a/mail-mta/postfix/postfix-2.4.11.ebuild
+++ b/mail-mta/postfix/postfix-2.4.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.4.11.ebuild,v 1.1 2009/05/15 17:16:38 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.4.11.ebuild,v 1.2 2009/07/05 20:57:15 gengor Exp $
# NOTE: this ebuild is a regular ebuild without mailer-config support!
# Comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -250,7 +250,9 @@ src_compile() {
einfo "CC=${my_cc:=gcc}"
# Workaround for bug #76512
- [[ "$(gcc-version)" == "3.4" ]] && use hardened && replace-flags -O? -Os
+ if use hardened ; then
+ [[ "$(gcc-version)" == "3.4" ]] && replace-flags -O? -Os
+ fi
make DEBUG="" CC="${my_cc:=gcc}" OPT="${CFLAGS}" CCARGS="${mycc}" AUXLIBS="${mylibs}" \
makefiles || die "configure problem"
diff --git a/mail-mta/postfix/postfix-2.5.5.ebuild b/mail-mta/postfix/postfix-2.5.5.ebuild
index 08ab93d66e51..929dfd2b089d 100644
--- a/mail-mta/postfix/postfix-2.5.5.ebuild
+++ b/mail-mta/postfix/postfix-2.5.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.5.5.ebuild,v 1.6 2008/11/09 12:19:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.5.5.ebuild,v 1.7 2009/07/05 20:57:15 gengor Exp $
# NOTE: this ebuild is a regular ebuild without mailer-config support!
# Comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -250,7 +250,9 @@ src_compile() {
einfo "CC=${my_cc:=gcc}"
# Workaround for bug #76512
- [[ "$(gcc-version)" == "3.4" ]] && use hardened && replace-flags -O? -Os
+ if use hardened ; then
+ [[ "$(gcc-version)" == "3.4" ]] && replace-flags -O? -Os
+ fi
make DEBUG="" CC="${my_cc:=gcc}" OPT="${CFLAGS}" CCARGS="${mycc}" AUXLIBS="${mylibs}" \
makefiles || die "configure problem"
diff --git a/mail-mta/postfix/postfix-2.5.7.ebuild b/mail-mta/postfix/postfix-2.5.7.ebuild
index 35694231e21e..523d4abcc5e5 100644
--- a/mail-mta/postfix/postfix-2.5.7.ebuild
+++ b/mail-mta/postfix/postfix-2.5.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.5.7.ebuild,v 1.1 2009/05/15 17:16:38 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.5.7.ebuild,v 1.2 2009/07/05 20:57:15 gengor Exp $
# NOTE: this ebuild is a regular ebuild without mailer-config support!
# Comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -250,7 +250,9 @@ src_compile() {
einfo "CC=${my_cc:=gcc}"
# Workaround for bug #76512
- [[ "$(gcc-version)" == "3.4" ]] && use hardened && replace-flags -O? -Os
+ if use hardened ; then
+ [[ "$(gcc-version)" == "3.4" ]] && replace-flags -O? -Os
+ fi
make DEBUG="" CC="${my_cc:=gcc}" OPT="${CFLAGS}" CCARGS="${mycc}" AUXLIBS="${mylibs}" \
makefiles || die "configure problem"
diff --git a/mail-mta/postfix/postfix-2.6.2.ebuild b/mail-mta/postfix/postfix-2.6.2.ebuild
index b0213093acac..cc40d655b3ca 100644
--- a/mail-mta/postfix/postfix-2.6.2.ebuild
+++ b/mail-mta/postfix/postfix-2.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.6.2.ebuild,v 1.1 2009/06/08 17:16:59 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.6.2.ebuild,v 1.2 2009/07/05 20:57:15 gengor Exp $
# NOTE: this ebuild is a regular ebuild without mailer-config support!
# Comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -247,7 +247,9 @@ src_compile() {
einfo "CC=${my_cc:=gcc}"
# Workaround for bug #76512
- [[ "$(gcc-version)" == "3.4" ]] && use hardened && replace-flags -O? -Os
+ if use hardened ; then
+ [[ "$(gcc-version)" == "3.4" ]] && replace-flags -O? -Os
+ fi
make DEBUG="" CC="${my_cc:=gcc}" OPT="${CFLAGS}" CCARGS="${mycc}" AUXLIBS="${mylibs}" \
makefiles || die "configure problem"