summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-03-07 10:27:37 +0000
committerEray Aslan <eras@gentoo.org>2012-03-07 10:27:37 +0000
commit4e36f8fbe7c09a320ba275bd12ff4c41fe3e9594 (patch)
tree71bfe21f6731571eb25968952fb49fdb88f236f7 /mail-mta
parentversion bump (diff)
downloadgentoo-2-4e36f8fbe7c09a320ba275bd12ff4c41fe3e9594.tar.gz
gentoo-2-4e36f8fbe7c09a320ba275bd12ff4c41fe3e9594.tar.bz2
gentoo-2-4e36f8fbe7c09a320ba275bd12ff4c41fe3e9594.zip
Do not return success in init script with a broken configuration.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/postfix/ChangeLog9
-rw-r--r--mail-mta/postfix/files/postfix.rc6.2.741
-rw-r--r--mail-mta/postfix/files/postfix_master-monitor.patch328
-rw-r--r--mail-mta/postfix/postfix-2.10_pre20120305-r1.ebuild317
4 files changed, 676 insertions, 19 deletions
diff --git a/mail-mta/postfix/ChangeLog b/mail-mta/postfix/ChangeLog
index f3e9e5bfe0db..7cc45c5577bc 100644
--- a/mail-mta/postfix/ChangeLog
+++ b/mail-mta/postfix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-mta/postfix
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/ChangeLog,v 1.342 2012/03/06 15:03:53 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/ChangeLog,v 1.343 2012/03/07 10:27:37 eras Exp $
+
+*postfix-2.10_pre20120305-r1 (07 Mar 2012)
+
+ 07 Mar 2012; Eray Aslan <eras@gentoo.org>
+ +postfix-2.10_pre20120305-r1.ebuild, +files/postfix_master-monitor.patch,
+ files/postfix.rc6.2.7:
+ Do not return success in init script with a broken configuration.
06 Mar 2012; Eray Aslan <eras@gentoo.org> +files/postfix.rc6.2.7:
add checking to start() in init script
diff --git a/mail-mta/postfix/files/postfix.rc6.2.7 b/mail-mta/postfix/files/postfix.rc6.2.7
index 151617360e6b..aecd8e71f9d8 100644
--- a/mail-mta/postfix/files/postfix.rc6.2.7
+++ b/mail-mta/postfix/files/postfix.rc6.2.7
@@ -1,10 +1,15 @@
#!/sbin/runscript
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/files/postfix.rc6.2.7,v 1.1 2012/03/06 15:03:53 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/files/postfix.rc6.2.7,v 1.2 2012/03/07 10:27:37 eras Exp $
-# Please read http://www.postfix.org/MULTI_INSTANCE_README.html for multi instance support
+extra_started_commands="reload abort flush"
+
+description_reload="Re-read configuration files. Running processes terminate at their earliest convenience."
+description_abort="Stop the Postfix mail system abruptly. Running processes are signaled to stop immediately."
+description_flush="Force delivery: attempt to deliver every message in the deferred mail queue."
+# Please read http://www.postfix.org/MULTI_INSTANCE_README.html for multi instance support
CONF_DIR="/etc/postfix"
CONF_OPT="${SVCNAME##*.}"
if [ -n ${CONF_OPT} -a ${SVCNAME} != "postfix" ]; then
@@ -18,12 +23,6 @@ else
CONF_MESSAGE="(${CONF_DIR})"
fi
-extra_started_commands="reload abort flush"
-
-description_reload="Re-read configuration files. Running processes terminate at their earliest convenience."
-description_abort="Stop the Postfix mail system abruptly. Running processes are signaled to stop immediately."
-description_flush="Force delivery: attempt to deliver every message in the deferred mail queue."
-
depend() {
use logger dns ypbind amavisd antivirus postfix_greylist net saslauthd
if [ "${SVCNAME}" = "postfix" ]; then
@@ -32,7 +31,6 @@ depend() {
}
start() {
- local _retval
if [ ! -z "${CONF_PARAM}" ]; then
einfo "Please consider updating your config for postmulti support."
fi
@@ -42,20 +40,27 @@ start() {
return 1
fi
/usr/sbin/postfix ${CONF_PARAM} start >/dev/null 2>&1
- _retval=$?
- # check that master started correctly
- if [ "${_retval}" ]; then
- sleep 1
- /usr/sbin/postfix ${CONF_PARAM} status >/dev/null 2>&1
- _retval=$?
- fi
- eend "${_retval}"
+ eend $?
}
stop() {
ebegin "Stopping postfix ${CONF_MESSAGE}"
/usr/sbin/postfix ${CONF_PARAM} stop >/dev/null 2>&1
- eend $?
+ eend
+}
+
+status() {
+ local _retval
+ einfon ""
+ /usr/sbin/postfix ${CONF_PARAM} status
+ _retval=$?
+ if [ x${_retval} = 'x0' ]; then
+ mark_service_started "${SVCNAME}"
+ eend 0
+ else
+ mark_service_stopped "${SVCNAME}"
+ eend 3
+ fi
}
reload() {
diff --git a/mail-mta/postfix/files/postfix_master-monitor.patch b/mail-mta/postfix/files/postfix_master-monitor.patch
new file mode 100644
index 000000000000..539e3f0e6156
--- /dev/null
+++ b/mail-mta/postfix/files/postfix_master-monitor.patch
@@ -0,0 +1,328 @@
+diff --exclude=man --exclude=html --exclude=README_FILES --exclude=INSTALL --exclude=.indent.pro --exclude=Makefile.in -r -cr --new-file /var/tmp/postfix-2.10-20120305/HISTORY ./HISTORY
+*** /var/tmp/postfix-2.10-20120305/HISTORY Mon Mar 5 10:35:50 2012
+--- ./HISTORY Tue Mar 6 19:40:04 2012
+***************
+*** 17668,17670 ****
+--- 17668,17685 ----
+ of specific permit-like actions in Postfix SMTP server
+ access lists. Files: mantools/postlink, proto/postconf.proto,
+ global/mail_params.h, smtpd/smtpd.c, smtpd/smtpd_check.c.
++
++ 20120206
++
++ Workaround: some Linux systems don't use "postfix status"
++ to find out if the mail system still runs. Instead they
++ claim that Postfix runs even when the master has aborted.
++ Even worse, they refuse to start Postfix when the problem
++ is fixed, claiming that Postfix is still running! As a
++ workaround, "postfix start" now waits until *after* master
++ daemon process initialization and returns a non-zero exit
++ status if daemon initialization did not complete in time.
++ Of course the real fix is that Linux systems stop reporting
++ bogus information and use "postfix status" properly. Files:
++ conf/postfix-script, master/master.c, master/master.h.
++ master/master_monitor.c.
+diff --exclude=man --exclude=html --exclude=README_FILES --exclude=INSTALL --exclude=.indent.pro --exclude=Makefile.in -r -cr --new-file /var/tmp/postfix-2.10-20120305/conf/postfix-script ./conf/postfix-script
+*** /var/tmp/postfix-2.10-20120305/conf/postfix-script Fri Jan 15 20:07:52 2010
+--- ./conf/postfix-script Tue Mar 6 17:19:38 2012
+***************
+*** 124,130 ****
+ $daemon_directory/postfix-script check-warn
+ fi
+ $INFO starting the Postfix mail system
+! $daemon_directory/master &
+ ;;
+
+ drain)
+--- 124,134 ----
+ $daemon_directory/postfix-script check-warn
+ fi
+ $INFO starting the Postfix mail system
+! # NOTE: start as foreground process to get the initialization status.
+! $daemon_directory/master || {
+! $FATAL "mail system startup failed"
+! exit 1
+! }
+ ;;
+
+ drain)
+diff --exclude=man --exclude=html --exclude=README_FILES --exclude=INSTALL --exclude=.indent.pro --exclude=Makefile.in -r -cr --new-file /var/tmp/postfix-2.10-20120305/src/master/master.c ./src/master/master.c
+*** /var/tmp/postfix-2.10-20120305/src/master/master.c Fri Dec 9 20:10:00 2011
+--- ./src/master/master.c Tue Mar 6 19:41:15 2012
+***************
+*** 4,10 ****
+ /* SUMMARY
+ /* Postfix master process
+ /* SYNOPSIS
+! /* \fBmaster\fR [\fB-Ddtv\fR] [\fB-c \fIconfig_dir\fR] [\fB-e \fIexit_time\fR]
+ /* DESCRIPTION
+ /* The \fBmaster\fR(8) daemon is the resident process that runs Postfix
+ /* daemons on demand: daemons to send or receive messages via the
+--- 4,10 ----
+ /* SUMMARY
+ /* Postfix master process
+ /* SYNOPSIS
+! /* \fBmaster\fR [\fB-Ddftv\fR] [\fB-c \fIconfig_dir\fR] [\fB-e \fIexit_time\fR]
+ /* DESCRIPTION
+ /* The \fBmaster\fR(8) daemon is the resident process that runs Postfix
+ /* daemons on demand: daemons to send or receive messages via the
+***************
+*** 37,42 ****
+--- 37,46 ----
+ /* .IP "\fB-e \fIexit_time\fR"
+ /* Terminate the master process after \fIexit_time\fR seconds. Child
+ /* processes terminate at their convenience.
++ /* .IP \fB-f\fR
++ /* Run as a foreground process. By default, the master daemon
++ /* disappears into the background after successful initialization
++ /* (Postfix 2.10 and later).
+ /* .IP \fB-t\fR
+ /* Test mode. Return a zero exit status when the \fBmaster.pid\fR lock
+ /* file does not exist or when that file is not locked. This is evidence
+***************
+*** 63,69 ****
+ /* terminate only the master ("\fBpostfix stop\fR") and allow running
+ /* processes to finish what they are doing.
+ /* DIAGNOSTICS
+! /* Problems are reported to \fBsyslogd\fR(8).
+ /* ENVIRONMENT
+ /* .ad
+ /* .fi
+--- 67,75 ----
+ /* terminate only the master ("\fBpostfix stop\fR") and allow running
+ /* processes to finish what they are doing.
+ /* DIAGNOSTICS
+! /* Problems are reported to \fBsyslogd\fR(8). The exit status
+! /* is non-zero in case of problems, including problems while
+! /* initializing as a master daemon process in the background.
+ /* ENVIRONMENT
+ /* .ad
+ /* .fi
+***************
+*** 243,248 ****
+--- 249,256 ----
+ VSTRING *why;
+ WATCHDOG *watchdog;
+ ARGV *import_env;
++ int dont_fork = 0;
++ int monitor_fd = -1;
+
+ /*
+ * Fingerprint executables and core dumps.
+***************
+*** 311,317 ****
+ /*
+ * Process JCL.
+ */
+! while ((ch = GETOPT(argc, argv, "c:Dde:tv")) > 0) {
+ switch (ch) {
+ case 'c':
+ if (setenv(CONF_ENV_PATH, optarg, 1) < 0)
+--- 319,325 ----
+ /*
+ * Process JCL.
+ */
+! while ((ch = GETOPT(argc, argv, "c:Dde:ftv")) > 0) {
+ switch (ch) {
+ case 'c':
+ if (setenv(CONF_ENV_PATH, optarg, 1) < 0)
+***************
+*** 319,333 ****
+--- 327,346 ----
+ break;
+ case 'd':
+ master_detach = 0;
++ dont_fork = 1;
+ break;
+ case 'e':
+ event_request_timer(master_exit_event, (char *) 0, atoi(optarg));
+ break;
++ case 'f':
++ dont_fork = 1;
++ break;
+ case 'D':
+ debug_me = 1;
+ break;
+ case 't':
+ test_lock = 1;
++ dont_fork = 1;
+ break;
+ case 'v':
+ msg_verbose++;
+***************
+*** 345,350 ****
+--- 358,374 ----
+ usage(argv[0]);
+
+ /*
++ * Run a foreground monitor process that returns an exit status of 0 when
++ * the child background process reports successful initialization as a
++ * daemon process. We use a generous limit in case main/master.cf specify
++ * symbolic hosts/ports and the naming service is slow.
++ */
++ #define MASTER_INIT_TIMEOUT 100 /* keep this limit generous */
++
++ if (dont_fork == 0)
++ monitor_fd = master_monitor(MASTER_INIT_TIMEOUT);
++
++ /*
+ * If started from a terminal, get rid of any tty association. This also
+ * means that all errors and warnings must go to the syslog daemon.
+ */
+***************
+*** 471,476 ****
+--- 495,508 ----
+ var_mail_version, var_config_dir);
+
+ /*
++ * Report successful initialization to the foreground monitor process.
++ */
++ if (monitor_fd >= 0) {
++ write(monitor_fd, "", 1);
++ (void) close(monitor_fd);
++ }
++
++ /*
+ * Process events. The event handler will execute the read/write/timer
+ * action routines. Whenever something has happened, see if we received
+ * any signal in the mean time. Although the master process appears to do
+diff --exclude=man --exclude=html --exclude=README_FILES --exclude=INSTALL --exclude=.indent.pro --exclude=Makefile.in -r -cr --new-file /var/tmp/postfix-2.10-20120305/src/master/master.h ./src/master/master.h
+*** /var/tmp/postfix-2.10-20120305/src/master/master.h Wed Sep 7 13:18:25 2011
+--- ./src/master/master.h Tue Mar 6 17:06:35 2012
+***************
+*** 219,224 ****
+--- 219,229 ----
+ extern void master_str_watch(const MASTER_STR_WATCH *);
+ extern void master_int_watch(MASTER_INT_WATCH *);
+
++ /*
++ * master_monitor.c
++ */
++ extern int master_monitor(int);
++
+ /* DIAGNOSTICS
+ /* BUGS
+ /* SEE ALSO
+diff --exclude=man --exclude=html --exclude=README_FILES --exclude=INSTALL --exclude=.indent.pro --exclude=Makefile.in -r -cr --new-file /var/tmp/postfix-2.10-20120305/src/master/master_monitor.c ./src/master/master_monitor.c
+*** /var/tmp/postfix-2.10-20120305/src/master/master_monitor.c Wed Dec 31 19:00:00 1969
+--- ./src/master/master_monitor.c Tue Mar 6 17:32:19 2012
+***************
+*** 0 ****
+--- 1,100 ----
++ /*++
++ /* NAME
++ /* master_monitor 3
++ /* SUMMARY
++ /* Postfix master - start-up monitoring
++ /* SYNOPSIS
++ /* #include "master.h"
++ /*
++ /* int master_monitor(time_limit)
++ /* int time_limit;
++ /* DESCRIPTION
++ /* master_monitor() forks off a background child process, and
++ /* returns in the child. The result value is the file descriptor
++ /* on which the child process must write one byte after it
++ /* completes successful initialization as a daemon process.
++ /*
++ /* The foreground process waits for the child's completion for
++ /* a limited amount of time. It terminates with exit status 0
++ /* in case of success, non-zero otherwise.
++ /* DIAGNOSTICS
++ /* Fatal errors: system call failure.
++ /* BUGS
++ /* SEE ALSO
++ /* LICENSE
++ /* .ad
++ /* .fi
++ /* The Secure Mailer license must be distributed with this software.
++ /* AUTHOR(S)
++ /* Wietse Venema
++ /* IBM T.J. Watson Research
++ /* P.O. Box 704
++ /* Yorktown Heights, NY 10598, USA
++ /*--*/
++
++ /* System library. */
++
++ #include <sys_defs.h>
++ #include <signal.h>
++ #include <unistd.h>
++ #include <stdlib.h>
++
++ /* Utility library. */
++
++ #include <msg.h>
++ #include <iostuff.h>
++
++ /* Application-specific. */
++
++ #include <master.h>
++
++ /* master_monitor - fork off a foreground monitor process */
++
++ int master_monitor(int time_limit)
++ {
++ pid_t pid;
++ int pipes[2];
++ char buf[1];
++
++ /*
++ * Sanity check.
++ */
++ if (time_limit <= 0)
++ msg_panic("master_monitor: bad time limit: %d", time_limit);
++
++ /*
++ * Set up the plumbing for child-to-parent communication.
++ */
++ if (pipe(pipes) < 0)
++ msg_fatal("pipe: %m");
++ close_on_exec(pipes[0], CLOSE_ON_EXEC);
++ close_on_exec(pipes[1], CLOSE_ON_EXEC);
++
++ /*
++ * Fork the child, and wait for it to report successful initialization.
++ */
++ switch (pid = fork()) {
++ case -1:
++ /* Error. */
++ msg_fatal("fork: %m");
++ case 0:
++ /* Child. Initialize as daemon in the background. */
++ close(pipes[0]);
++ return (pipes[1]);
++ default:
++ /* Parent. Monitor the child in the foreground. */
++ close(pipes[1]);
++ switch (timed_read(pipes[0], buf, 1, time_limit, (char *) 0)) {
++ default:
++ /* The child process still runs, but something is wrong. */
++ (void) kill(pid, SIGKILL);
++ /* FALLTHROUGH */
++ case 0:
++ /* The child process exited prematurely. */
++ msg_fatal("daemon initialization failure");
++ case 1:
++ /* The child process initialized successfully. */
++ exit(0);
++ }
++ }
++ }
+--- src/master/Makefile.in 2012-01-22 17:55:16.000000000 +0200
++++ src/master/Makefile.in 2012-03-07 11:10:55.255442235 +0200
+@@ -2,10 +2,12 @@
+ SRCS = master.c master_conf.c master_ent.c master_sig.c master_avail.c \
+ master_spawn.c master_service.c master_status.c master_listen.c \
+ master_proto.c single_server.c multi_server.c master_vars.c \
+- master_wakeup.c master_flow.c master_watch.c mail_flow.c
++ master_wakeup.c master_flow.c master_watch.c mail_flow.c \
++ master_monitor.c
+ OBJS = master.o master_conf.o master_ent.o master_sig.o master_avail.o \
+ master_spawn.o master_service.o master_status.o master_listen.o \
+- master_vars.o master_wakeup.o master_watch.o master_flow.o
++ master_vars.o master_wakeup.o master_watch.o master_flow.o \
++ master_monitor.o
+ LIB_OBJ = single_server.o multi_server.o trigger_server.o master_proto.o \
+ mail_flow.o event_server.o
+ HDRS = mail_server.h master_proto.h mail_flow.h
diff --git a/mail-mta/postfix/postfix-2.10_pre20120305-r1.ebuild b/mail-mta/postfix/postfix-2.10_pre20120305-r1.ebuild
new file mode 100644
index 000000000000..6bf005083316
--- /dev/null
+++ b/mail-mta/postfix/postfix-2.10_pre20120305-r1.ebuild
@@ -0,0 +1,317 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.10_pre20120305-r1.ebuild,v 1.1 2012/03/07 10:27:37 eras Exp $
+
+EAPI=4
+
+inherit eutils multilib ssl-cert toolchain-funcs flag-o-matic pam versionator
+
+MY_PV="${PV/_pre/-}"
+MY_SRC="${PN}-${MY_PV}"
+MY_URI="ftp://ftp.porcupine.org/mirrors/postfix-release/experimental"
+VDA_PV="2.8.8"
+VDA_P="${PN}-vda-v10-${VDA_PV}"
+RC_VER="2.7"
+
+DESCRIPTION="A fast and secure drop-in replacement for sendmail."
+HOMEPAGE="http://www.postfix.org/"
+SRC_URI="${MY_URI}/${MY_SRC}.tar.gz
+ vda? ( http://vda.sourceforge.net/VDA/${VDA_P}.patch ) "
+
+LICENSE="IBM"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+berkdb cdb doc dovecot-sasl hardened ldap ldap-bind memcached mbox mysql nis pam postgres sasl selinux sqlite ssl vda"
+
+DEPEND=">=dev-libs/libpcre-3.4
+ dev-lang/perl
+ berkdb? ( >=sys-libs/db-3.2 )
+ cdb? ( || ( >=dev-db/tinycdb-0.76 >=dev-db/cdb-0.75-r1 ) )
+ ldap? ( net-nds/openldap )
+ ldap-bind? ( net-nds/openldap[sasl] )
+ mysql? ( virtual/mysql )
+ pam? ( virtual/pam )
+ postgres? ( dev-db/postgresql-base )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ sqlite? ( dev-db/sqlite:3 )
+ ssl? ( >=dev-libs/openssl-0.9.6g )"
+
+RDEPEND="${DEPEND}
+ dovecot-sasl? ( net-mail/dovecot )
+ memcached? ( net-misc/memcached )
+ net-mail/mailbase
+ selinux? ( sec-policy/selinux-postfix )
+ !mail-mta/courier
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/mini-qmail
+ !mail-mta/msmtp[mta]
+ !mail-mta/nbsmtp
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/qmail-ldap
+ !mail-mta/sendmail
+ !<mail-mta/ssmtp-2.64-r2
+ !>=mail-mta/ssmtp-2.64-r2[mta]
+ !net-mail/fastforward"
+
+# vda patch is broken for 2.10
+REQUIRED_USE="ldap-bind? ( ldap sasl )
+ !vda"
+
+S="${WORKDIR}/${MY_SRC}"
+
+pkg_setup() {
+ # Add postfix, postdrop user/group (bug #77565)
+ enewgroup postfix 207
+ enewgroup postdrop 208
+ enewuser postfix 207 -1 /var/spool/postfix postfix,mail
+}
+
+src_prepare() {
+ if use vda; then
+ epatch "${DISTDIR}"/${VDA_P}.patch
+ fi
+
+ if ! use berkdb; then
+ epatch "${FILESDIR}/${PN}_no-berkdb.patch"
+ fi
+
+ # wait for master to initialize properly for postfix start
+ epatch "${FILESDIR}/${PN}_master-monitor.patch"
+
+ sed -i -e "/^#define ALIAS_DB_MAP/s|:/etc/aliases|:/etc/mail/aliases|" \
+ src/util/sys_defs.h || die "sed failed"
+
+ # change default paths to better comply with portage standard paths
+ sed -i -e "s:/usr/local/:/usr/:g" conf/master.cf || die "sed failed"
+}
+
+src_configure() {
+ # Make sure LDFLAGS get passed down to the executables.
+ local mycc="-DHAS_PCRE" mylibs="${LDFLAGS} -lpcre -lcrypt -lpthread"
+
+ use pam && mylibs="${mylibs} -lpam"
+
+ if use ldap; then
+ mycc="${mycc} -DHAS_LDAP"
+ mylibs="${mylibs} -lldap -llber"
+ fi
+
+ if use mysql; then
+ mycc="${mycc} -DHAS_MYSQL $(mysql_config --include)"
+ mylibs="${mylibs} $(mysql_config --libs)"
+ fi
+
+ if use postgres; then
+ mycc="${mycc} -DHAS_PGSQL -I$(pg_config --includedir)"
+ mylibs="${mylibs} -lpq -L$(pg_config --libdir)"
+ fi
+
+ if use sqlite; then
+ mycc="${mycc} -DHAS_SQLITE"
+ mylibs="${mylibs} -lsqlite3"
+ fi
+
+ if use ssl; then
+ mycc="${mycc} -DUSE_TLS"
+ mylibs="${mylibs} -lssl -lcrypto"
+ fi
+
+ # broken. and "in other words, not supported" by upstream.
+ # Use inet_protocols setting in main.cf
+ #if ! use ipv6; then
+ # mycc="${mycc} -DNO_IPV6"
+ #fi
+
+ if use sasl; then
+ if use dovecot-sasl; then
+ # Set dovecot as default.
+ mycc="${mycc} -DDEF_SASL_SERVER=\\\"dovecot\\\""
+ fi
+ if use ldap-bind; then
+ mycc="${mycc} -DUSE_LDAP_SASL"
+ fi
+ mycc="${mycc} -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl"
+ mylibs="${mylibs} -lsasl2"
+ elif use dovecot-sasl; then
+ mycc="${mycc} -DUSE_SASL_AUTH -DDEF_SERVER_SASL_TYPE=\\\"dovecot\\\""
+ fi
+
+ if ! use nis; then
+ sed -i -e "s|#define HAS_NIS|//#define HAS_NIS|g" \
+ src/util/sys_defs.h || die "sed failed"
+ fi
+
+ if ! use berkdb; then
+ mycc="${mycc} -DNO_DB"
+ if use cdb; then
+ # change default hash format from Berkeley DB to cdb
+ sed -i -e "s/hash/cdb/" src/util/sys_defs.h || die
+ fi
+ fi
+
+ if use cdb; then
+ mycc="${mycc} -DHAS_CDB -I/usr/include/cdb"
+ CDB_LIBS=""
+ # Tinycdb is preferred.
+ if has_version dev-db/tinycdb ; then
+ einfo "Building with dev-db/tinycdb"
+ CDB_LIBS="-lcdb"
+ else
+ einfo "Building with dev-db/cdb"
+ CDB_PATH="/usr/$(get_libdir)"
+ for i in cdb.a alloc.a buffer.a unix.a byte.a ; do
+ CDB_LIBS="${CDB_LIBS} ${CDB_PATH}/${i}"
+ done
+ fi
+ mylibs="${mylibs} ${CDB_LIBS}"
+ fi
+
+ # Robin H. Johnson <robbat2@gentoo.org> 17/Nov/2006
+ # Fix because infra boxes hit 2Gb .db files that fail a 32-bit fstat signed check.
+ mycc="${mycc} -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE"
+ filter-lfs-flags
+
+ # Workaround for bug #76512
+ if use hardened; then
+ [[ "$(gcc-version)" == "3.4" ]] && replace-flags -O? -Os
+ fi
+
+ # Remove annoying C++ comment style warnings - bug #378099
+ append-flags -Wno-comment
+
+ emake DEBUG="" CC="$(tc-getCC)" OPT="${CFLAGS}" CCARGS="${mycc}" AUXLIBS="${mylibs}" makefiles
+}
+
+src_install () {
+ /bin/sh postfix-install \
+ -non-interactive \
+ install_root="${D}" \
+ config_directory="/etc/postfix" \
+ manpage_directory="/usr/share/man" \
+ readme_directory="/usr/share/doc/${PF}/readme" \
+ html_directory="/usr/share/doc/${PF}/html" \
+ command_directory="/usr/sbin" \
+ mailq_path="/usr/bin/mailq" \
+ newaliases_path="/usr/bin/newaliases" \
+ sendmail_path="/usr/sbin/sendmail" \
+ || die "postfix-install failed"
+
+ # Fix spool removal on upgrade
+ rm -Rf "${D}"/var
+ keepdir /var/spool/postfix
+
+ # Install rmail for UUCP, closes bug #19127
+ dobin auxiliary/rmail/rmail
+
+ # Provide another link for legacy FSH
+ dosym /usr/sbin/sendmail /usr/$(get_libdir)/sendmail
+
+ # Install qshape tool
+ dobin auxiliary/qshape/qshape.pl
+ doman man/man1/qshape.1
+
+ # Performance tuning tools and their manuals
+ dosbin bin/smtp-{source,sink} bin/qmqp-{source,sink}
+ doman man/man1/smtp-{source,sink}.1 man/man1/qmqp-{source,sink}.1
+
+ # Set proper permissions on required files/directories
+ dodir /var/lib/postfix
+ keepdir /var/lib/postfix
+ fowners -R postfix:postfix /var/lib/postfix
+ fperms 0750 /var/lib/postfix
+ fowners root:postdrop /usr/sbin/post{drop,queue}
+ fperms 02711 /usr/sbin/post{drop,queue}
+
+ keepdir /etc/postfix
+ if use mbox; then
+ mypostconf="mail_spool_directory=/var/spool/mail"
+ else
+ mypostconf="home_mailbox=.maildir/"
+ fi
+ "${D}"/usr/sbin/postconf -c "${D}"/etc/postfix \
+ -e ${mypostconf} || die "postconf failed"
+
+ insinto /etc/postfix
+ newins "${FILESDIR}"/smtp.pass saslpass
+ fperms 600 /etc/postfix/saslpass
+
+ newinitd "${FILESDIR}"/postfix.rc6.${RC_VER} postfix
+ # do not start mysql/postgres unnecessarily - bug #359913
+ use mysql || sed -i -e "s/mysql //" "${D}/etc/init.d/postfix"
+ use postgres || sed -i -e "s/postgresql //" "${D}/etc/init.d/postfix"
+
+ mv "${S}"/examples "${D}"/usr/share/doc/${PF}/
+ mv "${D}"/etc/postfix/{*.default,makedefs.out} "${D}"/usr/share/doc/${PF}/
+
+ dodoc *README COMPATIBILITY HISTORY INSTALL PORTING RELEASE_NOTES*
+
+ pamd_mimic_system smtp auth account
+
+ if use sasl; then
+ insinto /etc/sasl2
+ newins "${FILESDIR}"/smtp.sasl smtpd.conf
+ fi
+
+ # header files
+ insinto /usr/include/postfix
+ doins include/*.h
+
+ # Remove unnecessary files
+ rm -f "${D}"/etc/postfix/{*LICENSE,access,aliases,canonical,generic}
+ rm -f "${D}"/etc/postfix/{header_checks,relocated,transport,virtual}
+}
+
+pkg_preinst() {
+ # default for inet_protocols changed from ipv4 to all in postfix-2.9.
+ # check inet_protocols setting in main.cf and modify if necessary to prevent
+ # performance loss with useless DNS lookups and useless connection attempts.
+ [[ -d ${ROOT}/etc/postfix ]] && {
+ if [[ "$(${D}/usr/sbin/postconf -dh inet_protocols)" != "ipv4" ]]; then
+ if [[ ! -n "$(${D}/usr/sbin/postconf -c ${ROOT}/etc/postfix -nh inet_protocols)" ]];
+ then
+ ewarn "\nCOMPATIBILITY: adding inet_protocols=ipv4 to main.cf."
+ ewarn "That will keep the same behaviour as previous postfix versions."
+ ewarn "Specify inet_protocols explicitly if you want to enable IPv6.\n"
+ else
+ # delete inet_protocols setting. there is already one in /etc/postfix
+ sed -i -e /inet_protocols/d "${D}"/etc/postfix/main.cf || die
+ fi
+ fi
+ }
+}
+
+pkg_postinst() {
+ # Do not install server.{key,pem) SSL certificates if they already exist
+ if use ssl && [[ ! -f "${ROOT}"/etc/ssl/postfix/server.key \
+ && ! -f "${ROOT}"/etc/ssl/postfix/server.pem ]] ; then
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-Postfix SMTP Server}"
+ install_cert /etc/ssl/postfix/server
+ chown postfix:mail "${ROOT}"/etc/ssl/postfix/server.{key,pem}
+ fi
+
+ if [[ ! -e /etc/mail/aliases.db ]] ; then
+ ewarn
+ ewarn "You must edit /etc/mail/aliases to suit your needs"
+ ewarn "and then run /usr/bin/newaliases. Postfix will not"
+ ewarn "work correctly without it."
+ ewarn
+ fi
+
+ if [[ $(get_version_component_range 2 ${REPLACING_VERSIONS}) -lt 9 ]]; then
+ elog "If you are using old style postfix instances by symlinking"
+ elog "startup scripts in ${ROOT}etc/init.d, please consider"
+ elog "upgrading your config for postmulti support. For more info:"
+ elog "http://www.postfix.org/MULTI_INSTANCE_README.html"
+ if ! use berkdb; then
+ ewarn "\nPostfix is installed without BerkeleyDB support."
+ ewarn "Please turn on berkdb USE flag for hash or btree table"
+ ewarn "lookup support.\n"
+ fi
+ ewarn "Postfix daemons now live under /usr/libexec/postfix"
+ ewarn "Please adjust your main.cf accordingly by running"
+ ewarn "etc-update/dispatch-conf or similar and accepting the new"
+ ewarn "daemon_directory setting."
+ fi
+}