summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-06-17 15:22:20 +0000
committerTorsten Veller <tove@gentoo.org>2012-06-17 15:22:20 +0000
commitf4bccb91fd7012678d53d3a84f55a54d4b86b759 (patch)
tree731e8975f6ffdfeeebbe97b0e99a68b777da6bbd /mail-filter
parentAdd build.xml and fix various QA issues. #364915 (diff)
downloadgentoo-2-f4bccb91fd7012678d53d3a84f55a54d4b86b759.tar.gz
gentoo-2-f4bccb91fd7012678d53d3a84f55a54d4b86b759.tar.bz2
gentoo-2-f4bccb91fd7012678d53d3a84f55a54d4b86b759.zip
Cleanup
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamassassin/ChangeLog7
-rw-r--r--mail-filter/spamassassin/files/spamassassin-3.3.1-PERL-5-12.patch230
-rw-r--r--mail-filter/spamassassin/files/spamassassin-3.3.1-uninitialized_value.patch18
3 files changed, 6 insertions, 249 deletions
diff --git a/mail-filter/spamassassin/ChangeLog b/mail-filter/spamassassin/ChangeLog
index 77cc40763833..2e6836a5cfc0 100644
--- a/mail-filter/spamassassin/ChangeLog
+++ b/mail-filter/spamassassin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/spamassassin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/ChangeLog,v 1.212 2012/06/17 15:05:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/ChangeLog,v 1.213 2012/06/17 15:22:20 tove Exp $
+
+ 17 Jun 2012; Torsten Veller <tove@gentoo.org>
+ -files/spamassassin-3.3.1-PERL-5-12.patch,
+ -files/spamassassin-3.3.1-uninitialized_value.patch:
+ Cleanup
17 Jun 2012; Agostino Sarubbo <ago@gentoo.org> -spamassassin-3.3.1-r4.ebuild:
Remove old
diff --git a/mail-filter/spamassassin/files/spamassassin-3.3.1-PERL-5-12.patch b/mail-filter/spamassassin/files/spamassassin-3.3.1-PERL-5-12.patch
deleted file mode 100644
index d7a6b14c2530..000000000000
--- a/mail-filter/spamassassin/files/spamassassin-3.3.1-PERL-5-12.patch
+++ /dev/null
@@ -1,230 +0,0 @@
---- a/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Dns.pm 2010-03-16 10:49:21.000000000 -0400
-+++ b/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Dns.pm 2010-07-20 15:54:23.000000000 -0400
-@@ -754,7 +754,7 @@
- dbg("dns: entering helper-app run mode");
- $self->{old_slash} = $/; # Razor pollutes this
- %{$self->{old_env}} = ();
-- if ( defined %ENV ) {
-+ if ( %ENV ) {
- # undefined values in %ENV can result due to autovivification elsewhere,
- # this prevents later possible warnings when we restore %ENV
- while (my ($key, $value) = each %ENV) {
---- a/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/HTML.pm 2010-03-16 10:49:21.000000000 -0400
-+++ b/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/HTML.pm 2010-07-20 15:52:50.000000000 -0400
-@@ -191,7 +191,7 @@
- my $self = shift;
- my %options = @_;
-
-- return join('', @{ $self->{text} }) unless keys %options;
-+ return join('', @{ $self->{text} }) unless %options;
-
- my $mask;
- while (my ($k, $v) = each %options) {
---- a/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Plugin/BodyEval.pm 2010-03-16 10:49:21.000000000 -0400
-+++ b/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Plugin/BodyEval.pm 2010-07-20 16:04:57.000000000 -0400
-@@ -119,7 +119,7 @@
- }
-
- # If there are no words, mark if there's at least 1 image ...
-- if (keys %html == 0 && exists $pms->{html}{inside}{img}) {
-+ if (!%html && exists $pms->{html}{inside}{img}) {
- # Use "\n" as the mark since it can't ever occur normally
- $html{"\n"}=1;
- }
---- a/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Plugin/Check.pm 2010-03-16 10:49:21.000000000 -0400
-+++ b/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Plugin/Check.pm 2010-07-20 16:03:00.000000000 -0400
-@@ -307,64 +307,51 @@
- my $package_name = __PACKAGE__;
- my $methodname = $package_name."::_".$ruletype."_tests_".$clean_priority;
-
-- if (defined &{$methodname} && !$doing_user_rules) {
--run_compiled_method:
-- # dbg("rules: run_generic_tests - calling %s", $methodname);
-- my $t = Mail::SpamAssassin::Timeout->new({ deadline => $master_deadline });
-- my $err = $t->run(sub {
-- no strict "refs";
-- $methodname->($pms, @{$opts{args}});
-- });
-- if ($t->timed_out() && $master_deadline && time > $master_deadline) {
-- info("check: exceeded time limit in $methodname, skipping further tests");
-- $pms->{deadline_exceeded} = 1;
-- }
-- return;
-- }
-+ if (!defined &{$methodname} || $doing_user_rules) {
-
-- # use %nopts for named parameter-passing; it's more friendly to future-proof
-- # subclassing, since new parameters can be added without breaking third-party
-- # subclassed implementations of this plugin.
-- my %nopts = (
-- ruletype => $ruletype,
-- doing_user_rules => $doing_user_rules,
-- priority => $priority,
-- clean_priority => $clean_priority
-- );
--
-- # build up the eval string...
-- $self->{evalstr_methodname} = $methodname;
-- $self->{evalstr_chunk_current_methodname} = undef;
-- $self->{evalstr_chunk_methodnames} = [];
-- $self->{evalstr_chunk_prefix} = []; # stack (array) of source code sections
-- $self->{evalstr} = ''; $self->{evalstr_l} = 0;
-- $self->{evalstr2} = '';
-- $self->begin_evalstr_chunk($pms);
--
-- $self->push_evalstr_prefix($pms, '
-- # start_rules_plugin_code '.$ruletype.' '.$priority.'
-- my $scoresptr = $self->{conf}->{scores};
-- ');
-- if (defined $opts{pre_loop_body}) {
-- $opts{pre_loop_body}->($self, $pms, $conf, %nopts);
-- }
-- $self->add_evalstr($pms,
-- $self->start_rules_plugin_code($ruletype, $priority) );
-- while (my($rulename, $test) = each %{$opts{testhash}->{$priority}}) {
-- $opts{loop_body}->($self, $pms, $conf, $rulename, $test, %nopts);
-- }
-- if (defined $opts{post_loop_body}) {
-- $opts{post_loop_body}->($self, $pms, $conf, %nopts);
-- }
-+ # use %nopts for named parameter-passing; it's more friendly
-+ # to future-proof subclassing, since new parameters can be added without
-+ # breaking third-party subclassed implementations of this plugin.
-+ my %nopts = (
-+ ruletype => $ruletype,
-+ doing_user_rules => $doing_user_rules,
-+ priority => $priority,
-+ clean_priority => $clean_priority
-+ );
-+
-+ # build up the eval string...
-+ $self->{evalstr_methodname} = $methodname;
-+ $self->{evalstr_chunk_current_methodname} = undef;
-+ $self->{evalstr_chunk_methodnames} = [];
-+ $self->{evalstr_chunk_prefix} = []; # stack (array) of source code sections
-+ $self->{evalstr} = ''; $self->{evalstr_l} = 0;
-+ $self->{evalstr2} = '';
-+ $self->begin_evalstr_chunk($pms);
-+
-+ $self->push_evalstr_prefix($pms, '
-+ # start_rules_plugin_code '.$ruletype.' '.$priority.'
-+ my $scoresptr = $self->{conf}->{scores};
-+ ');
-+ if (defined $opts{pre_loop_body}) {
-+ $opts{pre_loop_body}->($self, $pms, $conf, %nopts);
-+ }
-+ $self->add_evalstr($pms,
-+ $self->start_rules_plugin_code($ruletype, $priority) );
-+ while (my($rulename, $test) = each %{$opts{testhash}->{$priority}}) {
-+ $opts{loop_body}->($self, $pms, $conf, $rulename, $test, %nopts);
-+ }
-+ if (defined $opts{post_loop_body}) {
-+ $opts{post_loop_body}->($self, $pms, $conf, %nopts);
-+ }
-
-- $self->flush_evalstr($pms, 'run_generic_tests');
-- $self->free_ruleset_source($pms, $ruletype, $priority);
-+ $self->flush_evalstr($pms, 'run_generic_tests');
-+ $self->free_ruleset_source($pms, $ruletype, $priority);
-
-- # clear out a previous version of this method
-- undef &{$methodname};
-+ # clear out a previous version of this method
-+ undef &{$methodname};
-
-- # generate the loop that goes through each line...
-- my $evalstr = <<"EOT";
-+ # generate the loop that goes through each line...
-+ my $evalstr = <<"EOT";
- {
- package $package_name;
-
-@@ -373,40 +360,51 @@
- sub $methodname {
- EOT
-
-- for my $chunk_methodname (@{$self->{evalstr_chunk_methodnames}}) {
-- $evalstr .= " $chunk_methodname(\@_);\n";
-- }
-+ for my $chunk_methodname (@{$self->{evalstr_chunk_methodnames}}) {
-+ $evalstr .= " $chunk_methodname(\@_);\n";
-+ }
-
-- $evalstr .= <<"EOT";
-+ $evalstr .= <<"EOT";
- }
-
- 1;
- }
- EOT
-
-- delete $self->{evalstr}; # free up some RAM before we eval()
-- delete $self->{evalstr2};
-- delete $self->{evalstr_methodname};
-- delete $self->{evalstr_chunk_current_methodname};
-- delete $self->{evalstr_chunk_methodnames};
-- delete $self->{evalstr_chunk_prefix};
--
-- dbg("rules: run_generic_tests - compiling eval code: %s, priority %s",
-- $ruletype, $priority);
--# dbg("rules: eval code to compile: $evalstr");
-- my $eval_result;
-- { my $timer = $self->{main}->time_method('compile_gen');
-- $eval_result = eval($evalstr);
-- }
-- if (!$eval_result) {
-- my $eval_stat = $@ ne '' ? $@ : "errno=$!"; chomp $eval_stat;
-- warn "rules: failed to compile $ruletype tests, skipping:\n".
-- "\t($eval_stat)\n";
-- $pms->{rule_errors}++;
-- }
-- else {
-+ delete $self->{evalstr}; # free up some RAM before we eval()
-+ delete $self->{evalstr2};
-+ delete $self->{evalstr_methodname};
-+ delete $self->{evalstr_chunk_current_methodname};
-+ delete $self->{evalstr_chunk_methodnames};
-+ delete $self->{evalstr_chunk_prefix};
-+
-+ dbg("rules: run_generic_tests - compiling eval code: %s, priority %s",
-+ $ruletype, $priority);
-+ # dbg("rules: eval code to compile: $evalstr");
-+ my $eval_result;
-+ { my $timer = $self->{main}->time_method('compile_gen');
-+ $eval_result = eval($evalstr);
-+ }
-+ if (!$eval_result) {
-+ my $eval_stat = $@ ne '' ? $@ : "errno=$!"; chomp $eval_stat;
-+ warn "rules: failed to compile $ruletype tests, skipping:\n".
-+ "\t($eval_stat)\n";
-+ $pms->{rule_errors}++;
-+ return;
-+ }
- dbg("rules: compiled $ruletype tests");
-- goto run_compiled_method;
-+ }
-+
-+#run_compiled_method:
-+# dbg("rules: run_generic_tests - calling %s", $methodname);
-+ my $t = Mail::SpamAssassin::Timeout->new({ deadline => $master_deadline });
-+ my $err = $t->run(sub {
-+ no strict "refs";
-+ $methodname->($pms, @{$opts{args}});
-+ });
-+ if ($t->timed_out() && $master_deadline && time > $master_deadline) {
-+ info("check: exceeded time limit in $methodname, skipping further tests");
-+ $pms->{deadline_exceeded} = 1;
- }
- }
-
---- a/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Plugin/MIMEEval.pm 2010-03-16 10:49:21.000000000 -0400
-+++ b/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Plugin/MIMEEval.pm 2010-07-20 16:06:47.000000000 -0400
-@@ -498,7 +498,7 @@
- # perhaps just limit to test, and image?
- next if ($ctype eq 'application/ics');
-
-- my $cte = lc $p->get_header('content-transfer-encoding') || '';
-+ my $cte = lc($p->get_header('content-transfer-encoding') || '');
- next if ($cte !~ /^base64$/);
- foreach my $l ( @{$p->raw()} ) {
- my $len = length $l;
diff --git a/mail-filter/spamassassin/files/spamassassin-3.3.1-uninitialized_value.patch b/mail-filter/spamassassin/files/spamassassin-3.3.1-uninitialized_value.patch
deleted file mode 100644
index 4cd51294b036..000000000000
--- a/mail-filter/spamassassin/files/spamassassin-3.3.1-uninitialized_value.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-http://svn.apache.org/viewvc/spamassassin/trunk/spamd/spamd.raw?r1=950076&r2=950216&pathrev=950216
-https://bugs.gentoo.org/show_bug.cgi?id=342591
---- a/Mail-SpamAssassin-3.3.1/spamd/spamd.raw 2010-03-16 10:49:25.000000000 -0400
-+++ b/Mail-SpamAssassin-3.3.1/spamd/spamd.raw 2010-10-25 16:21:02.000000000 -0400
-@@ -443,10 +443,12 @@
- # socket of 'none' means as much as --syslog=null. Sounds complicated? It is.
- # But it works.
- # )
--my $log_socket = lc($opt{'syslog-socket'});
-+my $log_socket = $opt{'syslog-socket'};
-
- if (!defined $log_socket || $log_socket eq '') {
- $log_socket = am_running_on_windows() ? 'none' : 'unix';
-+} else {
-+ $log_socket = lc $log_socket;
- }
-
- # This is the default log file; it can be changed on the command line