summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2004-10-27 15:47:55 +0000
committerLim Swee Tat <st_lim@gentoo.org>2004-10-27 15:47:55 +0000
commit47cb5baa6e51e2a23723c8cb288e6eb32867d79d (patch)
treefd3886eac2d7226df3e845d2015c09ac9a79e989 /mail-filter
parentMarked ~amd64. (Manifest recommit) (diff)
downloadgentoo-2-47cb5baa6e51e2a23723c8cb288e6eb32867d79d.tar.gz
gentoo-2-47cb5baa6e51e2a23723c8cb288e6eb32867d79d.tar.bz2
gentoo-2-47cb5baa6e51e2a23723c8cb288e6eb32867d79d.zip
Fixed bug #68526.
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/dspam/ChangeLog11
-rw-r--r--mail-filter/dspam/dspam-3.2.0.ebuild12
2 files changed, 16 insertions, 7 deletions
diff --git a/mail-filter/dspam/ChangeLog b/mail-filter/dspam/ChangeLog
index 28522419915f..8f0a2b2561e7 100644
--- a/mail-filter/dspam/ChangeLog
+++ b/mail-filter/dspam/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for mail-filter/dspam
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/ChangeLog,v 1.20 2004/10/24 15:08:56 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/ChangeLog,v 1.21 2004/10/27 15:47:55 st_lim Exp $
+
+ 27 Oct 2004; Lim Swee Tat <st_lim@gentoo.org> dspam-3.2.0.ebuild:
+ Fixed bug #68526. Noted that preference-extensions only work when using
+ mysql and not when using db4.
+
+*dspam-3.2.0 (27 Oct 2004)
+
+ 27 Oct 2004; Lim Swee Tat <st_lim@gentoo.org> dspam-3.2.0.ebuild:
+ Removed the agent, and removed some lines for db4
*dspam-3.2_rc3 (24 Oct 2004)
diff --git a/mail-filter/dspam/dspam-3.2.0.ebuild b/mail-filter/dspam/dspam-3.2.0.ebuild
index f4a6fb3ea465..85e560eb25e6 100644
--- a/mail-filter/dspam/dspam-3.2.0.ebuild
+++ b/mail-filter/dspam/dspam-3.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.2.0.ebuild,v 1.1 2004/10/24 15:08:56 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.2.0.ebuild,v 1.2 2004/10/27 15:47:55 st_lim Exp $
inherit eutils
@@ -64,7 +64,6 @@ src_compile() {
# these are the default settings
myconf="${myconf} --with-signature-life=14"
myconf="${myconf} --enable-broken-return-codes"
- myconf="${myconf} --enable-preferences-extension"
myconf="${myconf} --enable-experimental"
myconf="${myconf} --enable-long-username"
myconf="${myconf} --enable-robinson"
@@ -92,6 +91,7 @@ src_compile() {
myconf="${myconf} --with-mysql-libraries=/usr/lib/mysql"
myconf="${myconf} --with-client-compression"
myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
# an experimental feature available with MySQL and PgSQL backend
if use neural ; then
@@ -102,6 +102,7 @@ src_compile() {
myconf="${myconf} --with-pgsql-includes=/usr/include/postgresql"
myconf="${myconf} --with-pgsql-libraries=/usr/lib/postgresql"
myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
# an experimental feature available with MySQL and PgSQL backend
if use neural ; then
@@ -111,6 +112,7 @@ src_compile() {
myconf="${myconf} --with-storage-driver=ora_drv"
myconf="${myconf} --with-oracle-home=${ORACLE_HOME}"
myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
# I am in no way a Oracle specialist. If someone knows
# how to query the version of Oracle, then let me know.
@@ -122,15 +124,13 @@ src_compile() {
elif use sqlite ; then
myconf="${myconf} --with-storage-driver=sqlite_drv"
myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
else
myconf="${myconf} --with-storage-driver=libdb4_drv"
- myconf="${myconf} --with-db4-includes=/usr/include"
- myconf="${myconf} --with-db4-libraries=/usr/lib"
fi
- econf ${myconf} \
- --with-delivery-agent="${agent}" || die
+ econf ${myconf} || die
emake || die
}