summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-08-15 15:18:24 +0000
committerTorsten Veller <tove@gentoo.org>2010-08-15 15:18:24 +0000
commit163b929f5a12521fa5b42c6735d67b3e63c53dc9 (patch)
tree372899801d55b1c5f114d2423ba5d8966aeb86b1 /mail-filter
parentCleanup (diff)
downloadgentoo-2-163b929f5a12521fa5b42c6735d67b3e63c53dc9.tar.gz
gentoo-2-163b929f5a12521fa5b42c6735d67b3e63c53dc9.tar.bz2
gentoo-2-163b929f5a12521fa5b42c6735d67b3e63c53dc9.zip
Remove the perl-5.12 warnings (#328939). Thanks to David Abbott
(Portage version: 2.2_rc67_p525/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamassassin/ChangeLog8
-rw-r--r--mail-filter/spamassassin/files/spamassassin-3.3.1-PERL-5-12.patch230
-rw-r--r--mail-filter/spamassassin/spamassassin-3.3.1-r3.ebuild202
3 files changed, 439 insertions, 1 deletions
diff --git a/mail-filter/spamassassin/ChangeLog b/mail-filter/spamassassin/ChangeLog
index c29f33928fca..c534f9219849 100644
--- a/mail-filter/spamassassin/ChangeLog
+++ b/mail-filter/spamassassin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/spamassassin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/ChangeLog,v 1.181 2010/07/06 21:01:14 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/ChangeLog,v 1.182 2010/08/15 15:18:23 tove Exp $
+
+*spamassassin-3.3.1-r3 (15 Aug 2010)
+
+ 15 Aug 2010; Torsten Veller <tove@gentoo.org>
+ +spamassassin-3.3.1-r3.ebuild, +files/spamassassin-3.3.1-PERL-5-12.patch:
+ Remove the perl-5.12 warnings (#328939). Thanks to David Abbott
06 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
spamassassin-3.3.1-r2.ebuild:
diff --git a/mail-filter/spamassassin/files/spamassassin-3.3.1-PERL-5-12.patch b/mail-filter/spamassassin/files/spamassassin-3.3.1-PERL-5-12.patch
new file mode 100644
index 000000000000..d7a6b14c2530
--- /dev/null
+++ b/mail-filter/spamassassin/files/spamassassin-3.3.1-PERL-5-12.patch
@@ -0,0 +1,230 @@
+--- a/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Dns.pm 2010-03-16 10:49:21.000000000 -0400
++++ b/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Dns.pm 2010-07-20 15:54:23.000000000 -0400
+@@ -754,7 +754,7 @@
+ dbg("dns: entering helper-app run mode");
+ $self->{old_slash} = $/; # Razor pollutes this
+ %{$self->{old_env}} = ();
+- if ( defined %ENV ) {
++ if ( %ENV ) {
+ # undefined values in %ENV can result due to autovivification elsewhere,
+ # this prevents later possible warnings when we restore %ENV
+ while (my ($key, $value) = each %ENV) {
+--- a/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/HTML.pm 2010-03-16 10:49:21.000000000 -0400
++++ b/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/HTML.pm 2010-07-20 15:52:50.000000000 -0400
+@@ -191,7 +191,7 @@
+ my $self = shift;
+ my %options = @_;
+
+- return join('', @{ $self->{text} }) unless keys %options;
++ return join('', @{ $self->{text} }) unless %options;
+
+ my $mask;
+ while (my ($k, $v) = each %options) {
+--- a/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Plugin/BodyEval.pm 2010-03-16 10:49:21.000000000 -0400
++++ b/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Plugin/BodyEval.pm 2010-07-20 16:04:57.000000000 -0400
+@@ -119,7 +119,7 @@
+ }
+
+ # If there are no words, mark if there's at least 1 image ...
+- if (keys %html == 0 && exists $pms->{html}{inside}{img}) {
++ if (!%html && exists $pms->{html}{inside}{img}) {
+ # Use "\n" as the mark since it can't ever occur normally
+ $html{"\n"}=1;
+ }
+--- a/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Plugin/Check.pm 2010-03-16 10:49:21.000000000 -0400
++++ b/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Plugin/Check.pm 2010-07-20 16:03:00.000000000 -0400
+@@ -307,64 +307,51 @@
+ my $package_name = __PACKAGE__;
+ my $methodname = $package_name."::_".$ruletype."_tests_".$clean_priority;
+
+- if (defined &{$methodname} && !$doing_user_rules) {
+-run_compiled_method:
+- # dbg("rules: run_generic_tests - calling %s", $methodname);
+- my $t = Mail::SpamAssassin::Timeout->new({ deadline => $master_deadline });
+- my $err = $t->run(sub {
+- no strict "refs";
+- $methodname->($pms, @{$opts{args}});
+- });
+- if ($t->timed_out() && $master_deadline && time > $master_deadline) {
+- info("check: exceeded time limit in $methodname, skipping further tests");
+- $pms->{deadline_exceeded} = 1;
+- }
+- return;
+- }
++ if (!defined &{$methodname} || $doing_user_rules) {
+
+- # use %nopts for named parameter-passing; it's more friendly to future-proof
+- # subclassing, since new parameters can be added without breaking third-party
+- # subclassed implementations of this plugin.
+- my %nopts = (
+- ruletype => $ruletype,
+- doing_user_rules => $doing_user_rules,
+- priority => $priority,
+- clean_priority => $clean_priority
+- );
+-
+- # build up the eval string...
+- $self->{evalstr_methodname} = $methodname;
+- $self->{evalstr_chunk_current_methodname} = undef;
+- $self->{evalstr_chunk_methodnames} = [];
+- $self->{evalstr_chunk_prefix} = []; # stack (array) of source code sections
+- $self->{evalstr} = ''; $self->{evalstr_l} = 0;
+- $self->{evalstr2} = '';
+- $self->begin_evalstr_chunk($pms);
+-
+- $self->push_evalstr_prefix($pms, '
+- # start_rules_plugin_code '.$ruletype.' '.$priority.'
+- my $scoresptr = $self->{conf}->{scores};
+- ');
+- if (defined $opts{pre_loop_body}) {
+- $opts{pre_loop_body}->($self, $pms, $conf, %nopts);
+- }
+- $self->add_evalstr($pms,
+- $self->start_rules_plugin_code($ruletype, $priority) );
+- while (my($rulename, $test) = each %{$opts{testhash}->{$priority}}) {
+- $opts{loop_body}->($self, $pms, $conf, $rulename, $test, %nopts);
+- }
+- if (defined $opts{post_loop_body}) {
+- $opts{post_loop_body}->($self, $pms, $conf, %nopts);
+- }
++ # use %nopts for named parameter-passing; it's more friendly
++ # to future-proof subclassing, since new parameters can be added without
++ # breaking third-party subclassed implementations of this plugin.
++ my %nopts = (
++ ruletype => $ruletype,
++ doing_user_rules => $doing_user_rules,
++ priority => $priority,
++ clean_priority => $clean_priority
++ );
++
++ # build up the eval string...
++ $self->{evalstr_methodname} = $methodname;
++ $self->{evalstr_chunk_current_methodname} = undef;
++ $self->{evalstr_chunk_methodnames} = [];
++ $self->{evalstr_chunk_prefix} = []; # stack (array) of source code sections
++ $self->{evalstr} = ''; $self->{evalstr_l} = 0;
++ $self->{evalstr2} = '';
++ $self->begin_evalstr_chunk($pms);
++
++ $self->push_evalstr_prefix($pms, '
++ # start_rules_plugin_code '.$ruletype.' '.$priority.'
++ my $scoresptr = $self->{conf}->{scores};
++ ');
++ if (defined $opts{pre_loop_body}) {
++ $opts{pre_loop_body}->($self, $pms, $conf, %nopts);
++ }
++ $self->add_evalstr($pms,
++ $self->start_rules_plugin_code($ruletype, $priority) );
++ while (my($rulename, $test) = each %{$opts{testhash}->{$priority}}) {
++ $opts{loop_body}->($self, $pms, $conf, $rulename, $test, %nopts);
++ }
++ if (defined $opts{post_loop_body}) {
++ $opts{post_loop_body}->($self, $pms, $conf, %nopts);
++ }
+
+- $self->flush_evalstr($pms, 'run_generic_tests');
+- $self->free_ruleset_source($pms, $ruletype, $priority);
++ $self->flush_evalstr($pms, 'run_generic_tests');
++ $self->free_ruleset_source($pms, $ruletype, $priority);
+
+- # clear out a previous version of this method
+- undef &{$methodname};
++ # clear out a previous version of this method
++ undef &{$methodname};
+
+- # generate the loop that goes through each line...
+- my $evalstr = <<"EOT";
++ # generate the loop that goes through each line...
++ my $evalstr = <<"EOT";
+ {
+ package $package_name;
+
+@@ -373,40 +360,51 @@
+ sub $methodname {
+ EOT
+
+- for my $chunk_methodname (@{$self->{evalstr_chunk_methodnames}}) {
+- $evalstr .= " $chunk_methodname(\@_);\n";
+- }
++ for my $chunk_methodname (@{$self->{evalstr_chunk_methodnames}}) {
++ $evalstr .= " $chunk_methodname(\@_);\n";
++ }
+
+- $evalstr .= <<"EOT";
++ $evalstr .= <<"EOT";
+ }
+
+ 1;
+ }
+ EOT
+
+- delete $self->{evalstr}; # free up some RAM before we eval()
+- delete $self->{evalstr2};
+- delete $self->{evalstr_methodname};
+- delete $self->{evalstr_chunk_current_methodname};
+- delete $self->{evalstr_chunk_methodnames};
+- delete $self->{evalstr_chunk_prefix};
+-
+- dbg("rules: run_generic_tests - compiling eval code: %s, priority %s",
+- $ruletype, $priority);
+-# dbg("rules: eval code to compile: $evalstr");
+- my $eval_result;
+- { my $timer = $self->{main}->time_method('compile_gen');
+- $eval_result = eval($evalstr);
+- }
+- if (!$eval_result) {
+- my $eval_stat = $@ ne '' ? $@ : "errno=$!"; chomp $eval_stat;
+- warn "rules: failed to compile $ruletype tests, skipping:\n".
+- "\t($eval_stat)\n";
+- $pms->{rule_errors}++;
+- }
+- else {
++ delete $self->{evalstr}; # free up some RAM before we eval()
++ delete $self->{evalstr2};
++ delete $self->{evalstr_methodname};
++ delete $self->{evalstr_chunk_current_methodname};
++ delete $self->{evalstr_chunk_methodnames};
++ delete $self->{evalstr_chunk_prefix};
++
++ dbg("rules: run_generic_tests - compiling eval code: %s, priority %s",
++ $ruletype, $priority);
++ # dbg("rules: eval code to compile: $evalstr");
++ my $eval_result;
++ { my $timer = $self->{main}->time_method('compile_gen');
++ $eval_result = eval($evalstr);
++ }
++ if (!$eval_result) {
++ my $eval_stat = $@ ne '' ? $@ : "errno=$!"; chomp $eval_stat;
++ warn "rules: failed to compile $ruletype tests, skipping:\n".
++ "\t($eval_stat)\n";
++ $pms->{rule_errors}++;
++ return;
++ }
+ dbg("rules: compiled $ruletype tests");
+- goto run_compiled_method;
++ }
++
++#run_compiled_method:
++# dbg("rules: run_generic_tests - calling %s", $methodname);
++ my $t = Mail::SpamAssassin::Timeout->new({ deadline => $master_deadline });
++ my $err = $t->run(sub {
++ no strict "refs";
++ $methodname->($pms, @{$opts{args}});
++ });
++ if ($t->timed_out() && $master_deadline && time > $master_deadline) {
++ info("check: exceeded time limit in $methodname, skipping further tests");
++ $pms->{deadline_exceeded} = 1;
+ }
+ }
+
+--- a/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Plugin/MIMEEval.pm 2010-03-16 10:49:21.000000000 -0400
++++ b/Mail-SpamAssassin-3.3.1//lib/Mail/SpamAssassin/Plugin/MIMEEval.pm 2010-07-20 16:06:47.000000000 -0400
+@@ -498,7 +498,7 @@
+ # perhaps just limit to test, and image?
+ next if ($ctype eq 'application/ics');
+
+- my $cte = lc $p->get_header('content-transfer-encoding') || '';
++ my $cte = lc($p->get_header('content-transfer-encoding') || '');
+ next if ($cte !~ /^base64$/);
+ foreach my $l ( @{$p->raw()} ) {
+ my $len = length $l;
diff --git a/mail-filter/spamassassin/spamassassin-3.3.1-r3.ebuild b/mail-filter/spamassassin/spamassassin-3.3.1-r3.ebuild
new file mode 100644
index 000000000000..f59d6e76ce89
--- /dev/null
+++ b/mail-filter/spamassassin/spamassassin-3.3.1-r3.ebuild
@@ -0,0 +1,202 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/spamassassin-3.3.1-r3.ebuild,v 1.1 2010/08/15 15:18:23 tove Exp $
+
+EAPI="2"
+
+inherit perl-module eutils
+
+MY_P=Mail-SpamAssassin-${PV//_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="SpamAssassin is an extensible email filter which is used to identify spam."
+HOMEPAGE="http://spamassassin.apache.org/"
+SRC_URI="http://apache.osuosl.org/spamassassin/source/${MY_P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
+# need keyword request for Mail-SPF ppc ppc64
+IUSE="berkdb qmail ssl doc ldap mysql postgres sqlite ipv6"
+
+DEPEND=">=dev-lang/perl-5.8.8-r8
+ virtual/perl-MIME-Base64
+ >=virtual/perl-PodParser-1.32
+ virtual/perl-Storable
+ virtual/perl-Time-HiRes
+ >=dev-perl/HTML-Parser-3.43
+ >=dev-perl/Mail-DKIM-0.37
+ >=dev-perl/Net-DNS-0.53
+ dev-perl/Digest-SHA1
+ dev-perl/libwww-perl
+ >=virtual/perl-Archive-Tar-1.26
+ app-crypt/gnupg
+ >=virtual/perl-IO-Zlib-1.04
+ >=dev-util/re2c-0.12.0
+ dev-perl/Mail-SPF
+ dev-perl/NetAddr-IP
+ ssl? (
+ dev-perl/IO-Socket-SSL
+ dev-libs/openssl
+ )
+ berkdb? (
+ virtual/perl-DB_File
+ )
+ ldap? ( dev-perl/perl-ldap )
+ mysql? (
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ )
+ postgres? (
+ dev-perl/DBI
+ dev-perl/DBD-Pg
+ )
+ sqlite? (
+ dev-perl/DBI
+ dev-perl/DBD-SQLite
+ )
+ ipv6? (
+ dev-perl/IO-Socket-INET6
+ )"
+
+PATCHES=( "${FILESDIR}/${P}-PERL-5-12.patch" )
+
+RDEPEND="${DEPEND}"
+
+# - Disable tests as they will fail
+# - Please see http://www.cpantesters.org/distro/M/Mail-SpamAssassin.html#Mail-SpamAssassin-3.3.1
+# - for more info, upstream problem not specific to Gentoo
+SRC_TEST="skip"
+
+src_configure() {
+ # - Set SYSCONFDIR explicitly so we can't get bitten by bug 48205 again
+ # (just to be sure, nobody knows how it could happen in the first place).
+ myconf="SYSCONFDIR=/etc DATADIR=/usr/share/spamassassin"
+
+ # If ssl is enabled, spamc can be built with ssl support
+ if use ssl; then
+ myconf+=" ENABLE_SSL=yes"
+ else
+ myconf+=" ENABLE_SSL=no"
+ fi
+
+ # Set the path to the Perl executable explictly. This will be used to
+ # create the initial sharpbang line in the scripts and might cause
+ # a versioned app name end in there, see
+ # <http://bugs.gentoo.org/show_bug.cgi?id=62276>
+ myconf+=" PERL_BIN=/usr/bin/perl"
+
+ # Add Gentoo tag to make it easy for the upstream devs to spot
+ # possible modifications or patches.
+ #version_tag="g${PV:6}${PR}"
+ #version_str="${PV//_/-}-${version_tag}"
+
+ # Create the Gentoo config file before Makefile.PL is called so it
+ # is copied later on.
+ #echo "version_tag ${version_tag}" > rules/11_gentoo.cf
+
+ # Setting the following env var ensures that no questions are asked.
+ perl-module_src_configure
+}
+
+src_compile() {
+ export PERL_MM_USE_DEFAULT=1
+ emake spamc/Makefile || die "emake failed"
+
+ # Now compile all the stuff selected.
+ perl-module_src_compile
+
+ if use qmail; then
+ emake spamc/qmail-spamc || die "building qmail-spamc emake failed"
+ fi
+
+}
+
+src_install () {
+ perl-module_src_install
+
+ # Create the stub dir used by sa-update and friends
+ dodir /var/lib/spamassassin || die
+
+ # Move spamd to sbin where it belongs.
+ dodir /usr/sbin
+ mv "${D}"/usr/bin/spamd "${D}"/usr/sbin/spamd || die "move spamd failed"
+
+ if use qmail; then
+ dobin spamc/qmail-spamc || die
+ fi
+
+ dosym /etc/mail/spamassassin /etc/spamassassin || die
+
+ # Disable plugin by default
+ sed -i -e 's/^loadplugin/\#loadplugin/g' "${D}"/etc/mail/spamassassin/init.pre || die
+
+ # Add the init and config scripts.
+ newinitd "${FILESDIR}"/3.3.1-spamd.init spamd || die
+ newconfd "${FILESDIR}"/3.0.0-spamd.conf spamd || die
+
+ use postgres && \
+ sed -i -e 's:@USEPOSTGRES@::' "${D}/etc/init.d/spamd" || \
+ sed -i -e '/@USEPOSTGRES@/d' "${D}/etc/init.d/spamd"
+
+ use mysql && \
+ sed -i -e 's:@USEMYSQL@::' "${D}/etc/init.d/spamd" || \
+ sed -i -e '/@USEMYSQL@/d' "${D}/etc/init.d/spamd"
+
+ dodoc NOTICE TRADEMARK CREDITS INSTALL.VMS UPGRADE USAGE \
+ sql/README.bayes sql/README.awl procmailrc.example sample-nonspam.txt \
+ sample-spam.txt spamassassin.spec spamd/PROTOCOL spamd/README.vpopmail \
+ spamd-apache2/README.apache || die
+
+ # Rename some docu files so they don't clash with others
+ newdoc spamd/README README.spamd || die
+ newdoc sql/README README.sql || die
+ newdoc ldap/README README.ldap || die
+
+ if use qmail; then
+ dodoc spamc/README.qmail || die
+ fi
+
+ cp "${FILESDIR}"/secrets.cf "${D}"/etc/mail/spamassassin/secrets.cf.example || die
+ fperms 0400 /etc/mail/spamassassin/secrets.cf.example
+
+ cat <<EOF > "${T}/local.cf.example"
+# Sensitive data, such as database connection info, should be stored in
+# /etc/mail/spamassassin/secrets.cf with appropriate permissions
+EOF
+
+ insinto /etc/mail/spamassassin/
+ doins "${T}/local.cf.example" || die
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+ elog "If you plan on using the -u flag to spamd, please read the notes"
+ elog "in /etc/conf.d/spamd regarding the location of the pid file.\n"
+ elog "If you build ${PN} with optional dependancy support,"
+ elog "you can enable them in /etc/mail/spamassassin/init.pre\n"
+ elog "You need to configure your database to be able to use Bayes filter"
+ elog "with database backend, otherwise it will still use (and need) the"
+ elog "Berkeley DB support."
+ elog "Look at the sql/README.bayes file in the documentation directory"
+ elog "for how to configure it.\n"
+ elog "If you plan to use Vipul's Razor, note that versions up to and"
+ elog "including version 2.82 include a bug that will slow down the entire"
+ elog "perl interpreter. Version 2.83 or later fixes this."
+ elog "If you do not plan to use this plugin, be sure to comment out"
+ elog "its loadplugin line in /etc/mail/spamassassin/v310.pre.\n"
+ elog "The DKIM plugin is now enabled by default for new installs,"
+ elog "if the perl module Mail::DKIM is installed."
+ elog "However, installation of SpamAssassin will not overwrite existing"
+ elog ".pre configuration files, so to use DKIM when upgrading from a"
+ elog "previous release that did not use DKIM, a directive:\n"
+ elog "loadplugin Mail::SpamAssassin::Plugin::DKIM"
+ elog "will need to be uncommented in file 'v312.pre', or added"
+ elog "to some other .pre file, such as local.pre.\n"
+ ewarn "Rules are no longer included with SpamAssassin out of the box".
+ ewarn "You will need to immediately run sa-update, or download"
+ ewarn "the additional rules .tgz package and run sa-update --install"
+ ewarn "with it, to get a ruleset.\n"
+ elog "If when you run sa-update and receive a GPG validation error."
+ elog "Then you need to import an updated sa-update key."
+ elog "sa-update --import /usr/share/spamassassin/sa-update-pubkey.txt\n"
+}